Solved

Cisco SDSL Router config  Data link always fails

Posted on 2010-08-21
6
591 Views
Last Modified: 2013-12-14
I have a large issue on client site with a router that I am trying to configure for SDSL.  I know the line is working fine as I have another old non cisco router working but the new one never works the CD light is there but the data never comes through.   Can someone aid me and take a look at  the running configs attached. The line is in the UK.  Thanks

uilding configuration...

Current configuration : 4012 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname seh_tenants
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$qWrc$inKkBM2isgJnhpcvO3/wJ.
enable password 7 1316121A1918167A7A
!
no aaa new-model
!
!
ip source-route
no ip routing
!
!
no ip cef
!
!
!
!
vtp mode transparent
username seh secret 5 $1$Vfp6$grIvNdQu34kKS9pnQdd4l1
!
!
!
archive
 log config
  hidekeys
!
!
controller DSL 0
 mode atm
 line-term cpe
 line-mode 2-wire line-zero
 dsl-mode shdsl symmetric annex B
 ignore-error-duration  15
 line-rate auto
!
vlan 2
!
!
!
!
interface BRI0
 no ip address
 encapsulation hdlc
 no ip route-cache
 shutdown
 isdn termination multidrop
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface FastEthernet0
!
interface FastEthernet1
 shutdown
!
interface FastEthernet2
 shutdown
!
interface FastEthernet3
 shutdown
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 no ip route-cache
!
interface Vlan2
 ip address 192.168.2.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan3
 ip address 192.168.3.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan4
 ip address 192.168.4.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan5
 ip address 192.168.5.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan6
 ip address 192.168.6.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan7
 ip address 192.168.7.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan8
 ip address 192.168.8.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan9
 ip address 192.168.9.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan10
 ip address 192.168.10.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan11
 ip address 192.168.11.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan12
 ip address 192.168.12.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan13
 ip address 192.168.13.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan14
 ip address 192.168.14.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan15
 ip address 192.168.15.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan16
 ip address 192.168.16.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan17
 ip address 192.168.17.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan18
 ip address 192.168.18.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan19
 ip address 192.168.19.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan20
 ip address 192.168.20.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan21
 ip address 192.168.21.1 255.255.255.0
!
interface Vlan41
 ip address 192.168.41.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan42
 ip address 192.168.42.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan43
 ip address 192.168.43.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Dialer0
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 shutdown
 dialer pool 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname account21469@spitfirellu.net
 ppp chap password 7 02070758041301351E1F5D4F5C
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
no ip http secure-server
!
ip nat inside source route-map nonat interface Dialer0 overload
!
ip access-list extended nonat
 permit ip 192.0.0.0 0.255.255.255 any
!
!
!
!
route-map nonat permit 10
 match ip address nonat
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 password 7 1316121A1918167A7A
 login
!
scheduler max-task-time 5000
end

Open in new window


{edited by MEE}
0
Comment
Question by:jonperry2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
6 Comments
 
LVL 13

Expert Comment

by:luc_roy
ID: 33495177
try taking out  "ignore-error-duration  15" but the configuration must be based on the providers settings.

look at this solutions basd on service type, here is a link to configuraiont of all the different types

http://www.cisco.com/en/US/tech/tk175/tk15/tech_configuration_examples_list.html
0
 

Author Comment

by:jonperry2
ID: 33502533
Yes I've checked through most of this and removed the ignore line but alas there is still only a flicker  of data which is most frustating and importantly no data still. Just to confirm that if I get a CD light then there is no hardware fault? Any other thoughts would be appreciated.
0
 

Accepted Solution

by:
jonperry2 earned 0 total points
ID: 33565851
Eventually worked this out myself by correcting the NAT config.  

My script if  of any  help  - eg for UK NAT SDSL cisco configs is as follows

                                ^

secc#sh run
Building configuration...

Current configuration : 4012 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname secc
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$qWrc$inKkBM2isgJnhpcvO3/wJ.
enable password 7 1316121A1918167A7A
!
no aaa new-model
!
!
ip source-route
no ip routing
!
!
no ip cef
!
!
!
!
vtp mode transparent
username secc secret
!
!
!
archive
 log config
  hidekeys
!
!
controller DSL 0
 mode atm
 line-term cpe
 line-mode 2-wire line-zero
 dsl-mode shdsl symmetric annex B
 ignore-error-duration  15
 line-rate auto
!
!
!
!
!
interface BRI0
 no ip address
 encapsulation hdlc
 no ip route-cache
 shutdown
 isdn termination multidrop
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface FastEthernet0
!
interface FastEthernet1
 shutdown
!
interface FastEthernet2
 shutdown
!
interface FastEthernet3
 shutdown
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 no ip route-cache
!
interface Vlan2
 ip address 192.168.2.1 255.255.255.0
 ip helper-address 192.168.1.100
!
interface Vlan3
 ip address 192.168.3.1 255.255.255.0
 ip helper-address 192.168.1.100
!
nterface Dialer0
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 shutdown
 dialer pool 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname xxx@spitfirellu.net
 ppp chap password xxx
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
no ip http secure-server
!
ip nat inside source route-map nonat interface Dialer0 overload
!
ip access-list extended nonat
 permit ip 192.0.0.0 0.255.255.255 any
!
!
!
!
route-map nonat permit 10
 match ip address nonat
!
!
control-plane
!
!
0

Featured Post

Database Solutions Engineer FAQs

In this series, we will discuss common questions received as a database Solutions Engineer at Percona. In this role, we speak with a wide array of MySQL and MongoDB users responsible for both extremely large and complex environments to smaller single-server environments.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
This article is a collection of issues that people face from time to time and possible solutions to those issues. I hope you enjoy reading it.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Suggested Courses
Course of the Month11 days, 15 hours left to enroll

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question