Solved

Help with Cisco bonded ADSL

Posted on 2010-08-21
15
1,035 Views
Last Modified: 2013-12-14
I'm no Cisco expert and I certainly don't understand the underlying workings of bonded ADSL so hoping for some help with this please.

We ordered bonded ADSL and using a Cisco 2811 bonding 4 lines.  Now there was an issue with one of the lines initially but BT sorted that out, now we seem to get high throughput for a minute or so and then it drops down to abysmal speeds, around 4k per second.  So it's making the whole solution unusable.

Any ideas on how I can get to the bottom of this?  The ISP behaves like they don't understand the underlying technologies either - they've now asked us to take one line out at a time and do speed tests to see if an individual line is causing this.  This makes sense but they keep coming up with things like this which means I have to take time to go on site to run these diagnostics, only to push the results back to them and have them come back to me with more things to do on site.

I can telnet to the Cisco and run SDM remotely so if there are any diagnostics you can recommend.

Thanks!
0
Comment
Question by:ebooyens
15 Comments
 
LVL 11

Expert Comment

by:yarwell
ID: 33494617
Is this using MLPPP bonding or something else ? Four lines from the same ISP ? What are the individual line link speeds show dsl interface atm 0 etc both up and down, also the attenuation and noise margin each way.

Are you on a small rural exchange or a big one in a town.

There is merit in bonding two lines first and assessing the throughput, then adding the third, etc.
0
 
LVL 4

Author Comment

by:ebooyens
ID: 33494707
Sorry but I'm not sure how it is bonded.  How can I check?

Four lines with the same ISP yes and it's in an urban area.

I'll get the line stats and come back to you
0
 
LVL 11

Expert Comment

by:yarwell
ID: 33494831
references in the config to multilink (see below) would be MLPPP otherwise it would be some kind of VPN over multiple WAN connections or possibly load sharing (which isn't really bonding).

interface Multilink1
 ip address x.x.x.x 255.255.x.x
 ppp multilink
 ppp multilink fragment disable
 ppp multilink group 1

interface Serial0/0/0
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial0/1/0
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
0
 
LVL 7

Expert Comment

by:diepes
ID: 33495234
Hi ebooyens: i would suggest attaching the router config here (minus passwords) else it would be very hard to understand how the bonding has been setup.
0
 
LVL 4

Author Comment

by:ebooyens
ID: 33496272
Right, thanks guys, here is the full config (deleted the sensitive lines) and then the line stats for each line below.  Let me know if there are any other diagnostic commands I can run.  Appreciate your help:

Using 4497 out of 245752 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname [HOSTNAME]
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
!
aaa session-id common
!
!
ip cef
!
!
ip domain name [WANDOMAIN]
ip name-server [DNS1]
ip name-server [DNS2]
ip name-server [DNS3]
multilink bundle-name authenticated
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface FastEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$
 ip address [LANIP] [LANSUBNET]
 duplex full
 speed auto
 no mop enabled
!
interface FastEthernet0/1
 description $ETH-LAN$
 ip address [WANIP] [WANSUBNET]
 duplex auto
 speed auto
!
interface ATM0/0/0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0/0/0.1 point-to-point
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface ATM0/1/0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0/1/0.1 point-to-point
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 2
 !
!
interface ATM0/2/0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0/2/0.1 point-to-point
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 3
 !
!
interface ATM0/3/0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0/3/0.1 point-to-point
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 4
 !
!
interface Dialer0
 ip address negotiated
 ip load-sharing per-packet
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname [bondedhostname]
 ppp chap password 0 [bondedpassword]
!
interface Dialer1
 ip address negotiated
 ip load-sharing per-packet
 encapsulation ppp
 dialer pool 2
 dialer-group 2
 ppp authentication chap callin
 ppp chap hostname [bondedhostname]
 ppp chap password 0 [bondedpassword]
!
interface Dialer2
 ip address negotiated
 ip load-sharing per-packet
 encapsulation ppp
 dialer pool 3
 dialer-group 3
 ppp authentication chap callin
 ppp chap hostname [bondedhostname]
 ppp chap password 0 [bondedpassword]
!
interface Dialer3
 ip address negotiated
 ip load-sharing per-packet
 encapsulation ppp
 dialer pool 4
 dialer-group 4
 ppp authentication chap callin
 ppp chap hostname [bondedhostname]
 ppp chap password 0 [bondedpassword]
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 0.0.0.0 0.0.0.0 Dialer2
ip route 0.0.0.0 0.0.0.0 Dialer3
!
!
!
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
dialer-list 3 protocol ip permit
dialer-list 4 protocol ip permit
!
!
control-plane
!
!
line con 0
line aux 0
!
scheduler allocate 20000 1000
!
end









ATM0/0/0
Alcatel 20190 chipset information
                ATU-R (DS)                      ATU-C (US)
Modem Status:    Showtime (DMTDSL_SHOWTIME)
DSL Mode:        ITU G.992.1 (G.DMT) Annex A
ITU STD NUM:     0x03                            0x2
Vendor ID:       'STMI'                          'P   '
Vendor Specific: 0x0000                          0x0000
Vendor Country:  0x0F                            0xB5
Chip ID:         C196 (0)
DFE BOM:         DFE3.0 Annex A (1)
Capacity Used:   93%                             88%
Noise Margin:     9.0 dB                          9.0 dB
Output Power:    20.0 dBm                        12.5 dBm
Attenuation:     44.0 dB                         23.5 dB
Defect Status:   None                            None
Last Fail Code:  None
Watchdog Counter: 0xD1
Watchdog Resets: 0
Selftest Result: 0x00
Subfunction:     0x00
Interrupts:      4166 (0 spurious)
PHY Access Err:  0
Activations:     6
LED Status:      OFF
LED On Time:     0
LED Off Time:    0
Init FW:         init_AMR-3.0.014_no_bist.bin
Operation FW:    AMR-3.0.014.bin
FW Source:       embedded
FW Version:      3.0.14

                 Interleave             Fast    Interleave              Fast
Speed (kbps):          8064                0           832                 0
Cells:               144213                0     151926206                 0
Reed-Solomon EC:        364                0            17                 0
CRC Errors:             219                0            15                 0
Header Errors:          176                0             6                 0
Total BER:                1662E-10               0E-0
Leakage Average BER:      1105E-10               0E-0
                        ATU-R (DS)      ATU-C (US)
Bitswap:               enabled            enabled
Bitswap success:          0                   0
Bitswap failure:          0                   0

LOM Monitoring : Disabled


DMT Bits Per Bin
000: 0 0 0 0 0 0 5 7 7 9 A B B B B B
010: C C B B B B B A A A 9 8 7 7 5 3
020: 0 0 0 0 0 A B B C C C C D D B D
030: D D D D D E E E E E D D D D D D
040: 0 D D D D D D D D D D D D D D D
050: D D 2 D D D D D D D D D D D C C
060: D C C C C C C C C C C C C C C C
070: C C C C C C B C C B B B B B B B
080: B B B B B B B B B B B B B B B B
090: B B B B A A A B A B A A A A A A
0A0: A 9 A A A 9 A A A A A A A 3 A 9
0B0: 9 9 9 9 9 9 9 9 8 9 9 9 9 9 9 9
0C0: 9 9 8 8 8 8 8 8 8 8 8 8 8 8 8 7
0D0: 7 7 5 0 4 7 7 6 7 7 7 7 7 7 7 7
0E0: 7 7 7 7 7 6 6 6 6 6 6 6 6 6 5 6
0F0: 6 5 5 5 5 5 5 5 5 5 5 5 5 5 5 4

DSL: Training log buffer capability is not enabled




ATM0/1/0
Alcatel 20190 chipset information
                ATU-R (DS)                      ATU-C (US)
Modem Status:    Showtime (DMTDSL_SHOWTIME)
DSL Mode:        ITU G.992.1 (G.DMT) Annex A
ITU STD NUM:     0x03                            0x2
Vendor ID:       'STMI'                          'P   '
Vendor Specific: 0x0000                          0x0000
Vendor Country:  0x0F                            0xB5
Chip ID:         C196 (0)
DFE BOM:         DFE3.0 Annex A (1)
Capacity Used:   94%                             86%
Noise Margin:     5.0 dB                         11.0 dB
Output Power:    18.5 dBm                        12.5 dBm
Attenuation:     44.0 dB                         23.5 dB
Defect Status:   None                            None
Last Fail Code:  None
Watchdog Counter: 0x49
Watchdog Resets: 0
Selftest Result: 0x00
Subfunction:     0x00
Interrupts:      4145 (0 spurious)
PHY Access Err:  0
Activations:     3
LED Status:      OFF
LED On Time:     0
LED Off Time:    0
Init FW:         init_AMR-3.0.014_no_bist.bin
Operation FW:    AMR-3.0.014.bin
FW Source:       embedded
FW Version:      3.0.14

                 Interleave             Fast    Interleave              Fast
Speed (kbps):          8128                0           832                 0
Cells:               181244                0     156702313                 0
Reed-Solomon EC:          0                0            15                 0
CRC Errors:            1550                0             2                 0
Header Errors:          840                0             0                 0
Total BER:                3764E-10               0E-0
Leakage Average BER:      2464E-10               0E-0
                        ATU-R (DS)      ATU-C (US)
Bitswap:               enabled            enabled
Bitswap success:          0                   0
Bitswap failure:          0                   0

LOM Monitoring : Disabled


DMT Bits Per Bin
000: 0 0 0 0 0 0 6 7 7 9 A B B B C C
010: B C C B B B B A A A 9 8 7 6 4 2
020: 0 0 0 0 0 A B B B B B B C C C C
030: C C D C D D D D D D D D D D D D
040: 0 D D D D D D D D D D D D D D D
050: D D D D D 2 D D D D C C C D D D
060: C D D D C C C C C C C C C C C C
070: C C C C C C C C B C C C C B C C
080: B C C C C B B B B B B B B B B B
090: B B A B B B B B B A B B B A B A
0A0: A 9 A A A A A A A A A A A A A A
0B0: A A A 9 9 9 9 9 9 9 9 9 9 9 9 9
0C0: 9 9 9 9 9 8 8 8 8 8 8 8 5 5 7 7
0D0: 7 6 3 0 4 7 7 7 7 7 7 7 7 7 7 7
0E0: 7 7 7 7 7 6 6 6 6 6 6 6 6 6 6 6
0F0: 6 6 5 5 5 5 5 5 5 5 5 0 0 3 4 4

DSL: Training log buffer capability is not enabled



ATM0/2/0
Alcatel 20190 chipset information
                ATU-R (DS)                      ATU-C (US)
Modem Status:    Showtime (DMTDSL_SHOWTIME)
DSL Mode:        ITU G.992.1 (G.DMT) Annex A
ITU STD NUM:     0x03                            0x2
Vendor ID:       'STMI'                          'P   '
Vendor Specific: 0x0000                          0x0000
Vendor Country:  0x0F                            0xB5
Chip ID:         C196 (0)
DFE BOM:         DFE3.0 Annex A (1)
Capacity Used:   97%                             86%
Noise Margin:     7.5 dB                         10.0 dB
Output Power:    19.0 dBm                        12.5 dBm
Attenuation:     45.0 dB                         23.5 dB
Defect Status:   None                            None
Last Fail Code:  None
Watchdog Counter: 0x7C
Watchdog Resets: 0
Selftest Result: 0x00
Subfunction:     0x00
Interrupts:      4138 (0 spurious)
PHY Access Err:  0
Activations:     2
LED Status:      OFF
LED On Time:     0
LED Off Time:    0
Init FW:         init_AMR-3.0.014_no_bist.bin
Operation FW:    AMR-3.0.014.bin
FW Source:       embedded
FW Version:      3.0.14

                 Interleave             Fast    Interleave              Fast
Speed (kbps):          7872                0           832                 0
Cells:               266943                0     313275456                 0
Reed-Solomon EC:      15226                0           116                 3
CRC Errors:             226                0            52                 3
Header Errors:          182                0            25                 1
Total BER:                65535E-255             0E-0
Leakage Average BER:      65535E-255             0E-0
                        ATU-R (DS)      ATU-C (US)
Bitswap:               enabled            enabled
Bitswap success:          0                   0
Bitswap failure:          0                   0

LOM Monitoring : Disabled


DMT Bits Per Bin
000: 0 0 0 0 0 0 6 7 8 9 A B B C C C
010: C C B B B A A A A A 9 8 7 6 4 2
020: 0 0 0 0 0 B C D D D D D D D B D
030: D D D D D D D E E E E E E E E E
040: 0 E E E E E E E E E E E E E D D
050: D D 2 D D D D D D D D D D D D D
060: D D C D D D C D D D C C C C C C
070: C C C C C C C B B B B B B B B B
080: B B B B B B B B A B B B 9 B A A
090: A B A A A A A A A A A A A A A 9
0A0: A A A A A A 9 9 A A A 9 9 8 9 9
0B0: 9 9 9 9 9 9 9 9 9 9 9 9 8 9 9 8
0C0: 8 8 8 8 8 8 8 8 8 8 8 7 6 5 7 7
0D0: 7 6 4 0 4 6 7 7 7 7 7 7 7 7 7 7
0E0: 7 7 7 6 6 6 6 6 6 6 6 6 6 6 5 5
0F0: 5 5 5 5 5 5 5 5 5 5 5 4 2 2 4 4

DSL: Training log buffer capability is not enabled





ATM0/3/0
Alcatel 20190 chipset information
                ATU-R (DS)                      ATU-C (US)
Modem Status:    Showtime (DMTDSL_SHOWTIME)
DSL Mode:        ITU G.992.1 (G.DMT) Annex A
ITU STD NUM:     0x03                            0x2
Vendor ID:       'STMI'                          'P   '
Vendor Specific: 0x0000                          0x0000
Vendor Country:  0x0F                            0xB5
Chip ID:         C196 (0)
DFE BOM:         DFE3.0 Annex A (1)
Capacity Used:   94%                             86%
Noise Margin:     5.5 dB                         10.0 dB
Output Power:    18.5 dBm                        12.5 dBm
Attenuation:     45.0 dB                         23.5 dB
Defect Status:   None                            None
Last Fail Code:  None
Watchdog Counter: 0x99
Watchdog Resets: 0
Selftest Result: 0x00
Subfunction:     0x00
Interrupts:      4138 (0 spurious)
PHY Access Err:  0
Activations:     2
LED Status:      OFF
LED On Time:     0
LED Off Time:    0
Init FW:         init_AMR-3.0.014_no_bist.bin
Operation FW:    AMR-3.0.014.bin
FW Source:       embedded
FW Version:      3.0.14

                 Interleave             Fast    Interleave              Fast
Speed (kbps):          8128                0           832                 0
Cells:               153988                0     140881708                 0
Reed-Solomon EC:          0                0            11                 0
CRC Errors:             373                0             7                 0
Header Errors:          294                0             5                 0
Total BER:                1070E-10               0E-0
Leakage Average BER:      6580E-11               0E-0
                        ATU-R (DS)      ATU-C (US)
Bitswap:               enabled            enabled
Bitswap success:          0                   0
Bitswap failure:          0                   0

LOM Monitoring : Disabled


DMT Bits Per Bin
000: 0 0 0 0 0 0 6 7 9 A A B B C C C
010: B C B B B A A A A 9 9 8 7 6 4 2
020: 0 0 0 0 0 A A B A A B C C C C C
030: C C C D D D D D D D D D D D D E
040: 0 E E D D D E D D D D D D D D D
050: D 2 D D D D D D D D D D D D C C
060: D D C C D D D D D C D D D C C C
070: C C C C C C C C C B C C C C B B
080: C B B B B B B B B B B B B B B B
090: B B B B B B B B A B B A A B A A
0A0: A A A A A A A A A 9 A A A 8 9 9
0B0: 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9
0C0: 8 8 8 8 8 8 8 8 8 8 8 8 7 7 7 8
0D0: 8 7 5 0 5 7 7 7 7 7 7 7 7 7 7 7
0E0: 7 6 6 7 6 6 6 6 6 6 6 6 6 5 6 6
0F0: 5 5 5 5 5 5 5 5 5 5 4 4 2 2 4 4

DSL: Training log buffer capability is not enabled
0
 
LVL 4

Author Comment

by:ebooyens
ID: 33496277
Here's the same as an attachment, bit easier to read
cisco-1841.txt
0
 
LVL 4

Author Comment

by:ebooyens
ID: 33496290
Sorry, being stupid, the file is called cisco-1841 but it's a 2811, just in case someone's wondering
0
6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

 
LVL 11

Expert Comment

by:yarwell
ID: 33496363
without "ppp multilink" and with "ip load-sharing per-packet" we can assume it isn't MLPPP but is just per packet load balancing.

will go digest the rest !
0
 
LVL 5

Expert Comment

by:Imran Saeed
ID: 33498031
Please check the link even though its for Nildram but I have tried this config on another ISP by replacing the necessary parameters and it straight away worked.

http://www.nildram.net/support/section/bonded-adsl-_-load-balanced/2/
0
 
LVL 11

Expert Comment

by:yarwell
ID: 33499079
The Nildram config doesn't have the word "multi" in it

their  config is :-

!
ip domain name nildram.net
ip name-server 212.139.132.5 or 212.139.132.6
ip name-server 212.139.132.21 or 212.139.132.22
no ftp-server write-enable
!

whereas above we have :-

ip domain name [WANDOMAIN]
ip name-server [DNS1]
ip name-server [DNS2]
ip name-server [DNS3]
multilink bundle-name authenticated
!

is the last line necessary / desirable ?? is load sharing multilink at all ?
0
 
LVL 11

Accepted Solution

by:
yarwell earned 500 total points
ID: 33499144
I chewed through the ADSL line parameters. Lines 1 and 3 are achieving the full 8128 speed which is pretty good on a 44 dB attenuation. Lines 0 and 2 fall a bit short of that. All four upstreams are at the full 832 rate for ADSL1.

Assuming these are BT Wholesale circuits the IP Profiles will be

7000
7150
6500
7150

I'm not sure how the load balancing algorithm copes with these external constraints, but as a starter for 10 I would try running just lines 1 and 3 as they have the full 8128 sync speed and hence 7150 IP profile = 6700 kbits/s of data each downstream.
0
 
LVL 4

Author Comment

by:ebooyens
ID: 33499172
I checked with the ISP and this is their response.  I will remove that line but sounds like it won't make much difference:

"No, there is no need for the multilink bundle-name as it's not a bundle (As you would have on an MLPPP session). You are bonded on per packet load balanced. We manage the downstream from our LNS and your config gives you the upstream. The interesting thing is that no matter what your config, it should have little or no impact on your downstream performance as we are managing that"

They're now asking whether AV isn't blocking IP streams and slowing the connection down, we have a Sonicwall device in between the Cisco and the network which performs deep packet inspection.  I'll have to bypass the Sonciwall and do some tests to confirm this isn't the issue.

So the line stats look OK then?  Thanks for the suggestions.  I'll report back after removing that lines and doing some more tests when on site.
0
 
LVL 4

Author Comment

by:ebooyens
ID: 33499184
Thanks Yarwell, I'll try that and report back
0
 
LVL 4

Author Comment

by:ebooyens
ID: 33501337
Thanks all, it turns out I owe my ISP an apology (now there's something you don't hear very often!!) - if I turn off all gateway AV and Anti-Spyware on the Sonicwall I'm getting a Meg a second plus consistently.  Now need to sort the Sonicwall, but thanks for the advice on the Cisco, I learnt a fair bit
0
 

Expert Comment

by:jostick
ID: 36909309
OK, year too late but I found that Sonicwalls are a bottle-neck when security services are enabled. Hope this helps somebody.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Cable Modem Provisioning from DPoE compliant server  This Article is to support CMTS administrators to provide an overview of DOCSIS compliance configuration file, and to provision a cable modem located at customer place from a Back office serve…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now