How to set default wallpaper for all terminal server 2003 users?

Hello,

I would like to set default wallpaper (say company logo) for all Terminal Server Users. How can I achieve this? I'm able to disable the changing the wallpaper through group policy, but unable to find the proper way to set the default wallpaper.

Any further help would be greatly appreciated. Thanks.
SrinathSAsked:
Who is Participating?
 
Rant32Commented:
If you have a Windows 7 client, you can set up GP preferences with the GPMC.

If not, first, distribute the wallpaper to your Terminal Servers.
Then you can add a few lines to the user's logon script to change the setting in the registry.

reg add "HKCU\Control Panel\Desktop" /v Wallpaper /t REG_SZ /d "C:\Readonly\CompanyWallpaper.bmp"
reg add "HKCU\Control Panel\Desktop" /v Wallpaper /t REG_SZ /d 10

The change will take place at the next logon.
0
 
dreamcomputer2000Commented:
You will find that addressed in Experts Exchange question ID: 24417522
0
 
ploftinCommented:
Edit the registry on the terminal server.  Go to "HKEY_USERS\.DEFAULT\Control Panel\Desktop\Wallpaper" and set it to the desired wallpaper.  It may have to be a .BMP to function properly.
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
SrinathSAuthor Commented:
@ploftin,

I already did that to change the default login background. But the desktop wallpaper is not changed. I tried to enable / disable "Acitive Desktop", "Active Desktop Wallpaper", "Prevent Users from changing default wallpaper" and also tried to save the theme with the default wallpaper and applied it to through group policy setting named "User specific theme..."

Nothing worked! Even I ran the gpupdate and restarted the server. ???
0
 
SrinathSAuthor Commented:
@rant32,

How can I make it as a script (batch file!)? Is this script needs to be executed on every time users login into the server?

Thanks
0
 
ConUladhCommented:
Side topic: Don't forget that whatever you do on the Terminal server that the RDP client normally defaults to not showing the desktop background anyway. To change that you need to go to the experience tab of options when launching RDP from the client.
0
 
Rant32Commented:
Setting two registry keys does no harm, I recommend to run it always at login. It does make the setting somewhat persistent. It also depends on whether you have multiple Terminal Servers and if the users are using roaming profiles.

Question: Do you have an AD Organizational Unit that has your Terminal Servers in them? Do you already have a Group Policy Object that is applied to Terminal Servers? Preferably one that has Loopback Policy Processing enabled, so you can use the Terminal Server policy to apply user settings to those servers only.

In that case, you can simply use the existing policy and add a user startup script (a simple .CMD/.BAT file will work).

(Another place to add a logon script is of course the User Profile tab of the user's AD account, but that is really messy).
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.