[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now


Exchange 2010 database won't mount - Error 0x6d9

Posted on 2010-08-21
Medium Priority
Last Modified: 2012-05-10
Hi Experts,
I am running a single Exchange 2010 server on Windows 2008 R2.  It's been running fine, but tonight decided to apply some security updates to windows.  After rebooting, the exchange databases (mailbox and public folders) came up dismounted.  I uninstalled the security patches but they still won't mount.  THANK YOU for any help!

Trying to mount manually, I get this error:

Microsoft Exchange Error
Failed to mount database 'Exchange 2010 Mailbox Database'.

Exchange 2010 Mailbox Database
The RPC query to retrieve the copy status for Database Exchange 2010 Mailbox Database failed. The service might not be running. Error message: A server-side administrative operation has failed. The Microsoft Exchange Replication service may not be running on server MAILSERVER.DOMAIN.com. Specific RPC error message: Error 0x6d9 (There are no more endpoints available from the endpoint mapper) from cli_GetCopyStatusEx2


I ran a healthcheck
The only thing that came back was an error stating "Active Directory domain 'DOMAIN' has an unrecognized Exchange signature".  From what I read, this is actually a bug that there is no problem???  

I ran eseutil /mh
As far as I can tell, came back clean or at least it wasn't a dirty shutdown:
Checksum Information:
Expected Checksum: 0x0ead93c2
  Actual Checksum: 0x0ead93c2

        File Type: Database
         Checksum: 0xead93c2
   Format ulMagic: 0x89abcdef
   Engine ulMagic: 0x89abcdef
 Format ulVersion: 0x620,17
 Engine ulVersion: 0x620,17
Created ulVersion: 0x620,17
     DB Signature: Create time:03/30/2010 10:51:51 Rand:3058294 Computer:
         cbDbPage: 32768
           dbtime: 278928513 (0x10a01c81)
            State: Clean Shutdown
     Log Required: 0-0 (0x0-0x0)
    Log Committed: 0-0 (0x0-0x0)
   Log Recovering: 0 (0x0)
  GenMax Creation: 00/00/1900 00:00:00
         Shadowed: Yes
       Last Objid: 59285
     Scrub Dbtime: 0 (0x0)
       Scrub Date: 00/00/1900 00:00:00
     Repair Count: 0
      Repair Date: 00/00/1900 00:00:00
 Old Repair Count: 0
  Last Consistent: (0x2CF99,6CF,D9)  08/21/2010 19:25:17
      Last Attach: (0x2ACF0,9,86)  08/10/2010 10:38:04
      Last Detach: (0x2CF99,6CF,D9)  08/21/2010 19:25:17
             Dbid: 1
    Log Signature: Create time:03/30/2010 10:51:51 Rand:3087173 Computer:
       OS Version: (6.1.7600 SP 0 NLS 60101.60101)

Previous Full Backup:
        Log Gen: 183870-183890 (0x2ce3e-0x2ce52) - OSSnapshot
           Mark: (0x2CE53,8,16)
           Mark: 08/20/2010 21:00:10

Previous Incremental Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Previous Copy Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Previous Differential Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Current Full Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Current Shadow copy backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

     cpgUpgrade55Format: 0
    cpgUpgradeFreePages: 0
cpgUpgradeSpaceMapPages: 0

       ECC Fix Success Count: none
   Old ECC Fix Success Count: none
         ECC Fix Error Count: none
     Old ECC Fix Error Count: none
    Bad Checksum Error Count: none
Old bad Checksum Error Count: none

  Last checksum finish Date: 00/00/1900 00:00:00
Current checksum start Date: 00/00/1900 00:00:00
      Current checksum page: 0

I ran dcdiag /test:dns
Came back with a failure on the RReg

Directory Server Diagnosis

Performing initial setup:
   * Identified AD Forest.
   Done gathering initial info.

Doing initial required tests

   Testing server: Default-First-Site-Name\SERVERNAME
      Starting test: Connectivity
         ......................... SERVERNAME passed test Connectivity

Doing primary tests

   Testing server: Default-First-Site-Name\SERVERNAME

      Starting test: DNS

         DNS Tests are running and not hung. Please wait a few minutes...
         ......................... SERVERNAME passed test DNS

   Running partition tests on : ForestDnsZones

   Running partition tests on : DomainDnsZones

   Running partition tests on : Schema

   Running partition tests on : Configuration

   Running partition tests on : DOMAIN

   Running enterprise tests on : DOMAIN.com
      Starting test: DNS
         Test results for domain controllers:

            DC: SERVERNAME.DOMAIN.com
            Domain: DOMAIN.com

               TEST: Records registration (RReg)
                  Network Adapter
                  [00000006] Broadcom BCM5709C NetXtreme II GigE (NDIS VBD Clien

                     Missing CNAME record at DNS server DOMAIN CONTROLLER IP ADDRESS:

                     Missing A record at DNS server DOMAIN CONTROLLER IP ADDRESS:

                     Missing SRV record at DNS server DC IP:

                     Missing SRV record at DNS server DC IP:

                     Missing SRV record at DNS server DC IP:

                     Missing SRV record at DNS server DC IP:

                     Missing SRV record at DNS server DC IP:

                     Missing SRV record at DNS server DC IP:

                     Missing SRV record at DNS server DC IP:

                     Missing SRV record at DNS server DC IP:

                     Missing SRV record at DNS server DC IP:

                     Missing SRV record at DNS server DC IP:

                     Missing SRV record at DNS server DC IP:

                     Missing SRV record at DNS server DC IP:

                     Missing A record at DNS server DC IP:

                     Missing SRV record at DNS server DC IP:

                     Missing SRV record at DNS server DC IP:

                     Missing SRV record at DNS server DC IP:

               Error: Record registrations cannot be found for all the network

         Summary of DNS test results:

                                            Auth Basc Forw Del  Dyn  RReg Ext
            Domain: DOMAIN.com

         ......................... DOMAIN.com failed test DNS

I tried restarting the Microsoft Exchange Search Indexer service but it won't restart.  It comes up started upon bootup, but I read somewhere a restart might help, but trying to restart, it just hangs on stopping.  

Question by:thetraveler359
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions

Expert Comment

ID: 33493997
Please following the below article and see if that resolves your Issue.


LVL 74

Expert Comment

by:Glen Knight
ID: 33494094
Check the TCP/IP configuration of the network card, is it using a valid Windows DNS server for DNS resolution?  It should only have internal addresses.

Check the DC's as well.  If you make changes rester the NETLOGON service (or do a full server restart)

Expert Comment

ID: 33494131
When you ran the updates, did you update any hardware drivers?  Check the update logs.

Broadcom BCM5709C NetXtreme II GigE

Check the install date of the current drivers on the above card and if recently updated roll back.  May not have been a problem with the security patches but rather a problem with your network card / drivers.
Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

LVL 19

Expert Comment

ID: 33494636
If the database is in clean shutdown. Move all the logs to other location and then try to mount.
check this.
LVL 28

Accepted Solution

sunnyc7 earned 2000 total points
ID: 33497613
I wish everyone in EE asked questions like this :) - very detailed / complete with steps taken.

a) Did you restart the DC / Exchange once after you were facing these issues.
Is that an option / Do you need to schedule downtime for this ?

b) RPC Endpoint mapper KB

I'd go with dcdiag /fix if restart didnt solve it.

c) check if Exchange Services are running under Local System Account.
Also check if RPC is running under local system account
Indexer service - no cause of worry.

Please post back.

Author Comment

ID: 33500625
Thank you for all the responses!  I really appreciate it.  I did check out the suggestions (my permissions were fine, didn't do any hardware driver updates and luckily didn't get to having to try moving the log files)

Turned out to, I think, be DNS related.  I did do a dcdiag /fix and that seems to have done the trick.  I'm not sure if there was something else going on as well, though, as on the next reboot I did after I posted here, a lot of the Exchange services didn't start up.  I did the fix, rebooted again, and got it mounted after that.  

Could a service have been showing as running but not actually running/started?  

Regardless, just glad it's working again, and before this Monday morning when everyone would be in an uproar to have mail going!   Thank you again!

Author Comment

ID: 33500640
I'm sorry demazter, I probably should have given you partial credit as you were pointing in the right direction too.
LVL 28

Expert Comment

ID: 33500695
start > run > services.msc

Press F5 and refresh.
also monitor the event log \windows\system
Lot many times the services need to be refreshed to make sure it's Started / starting / or Stopping state's.

thanks for the points.

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Know the reasons and solutions to move/import EDB to New Exchange Server. Also, find out how to recover an Exchange .edb file and to restore the file back.
Wouldn't it be nice if objects in Active Directory automatically moved into the correct Organizational Units? This is what AutoAD aims to do and as a plus, it automatically creates Sites, Subnets, and Organizational Units.
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
how to add IIS SMTP to handle application/Scanner relays into office 365.
Suggested Courses

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question