• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1238
  • Last Modified:

Windows 7 Explorer Not showing all image icons/thumbnails

My system is Win 7 Uitimate, 64 bit.  I have tens-of-thousands of jpg images that I need to sort through.  Somewhere along the way, Explorer stopped displaying all of the icons or thumbnaiils.  I can turn icons on/off, and I cleared the icon cache, but I cannot get all of the icons in a folder to be displayed.  I recall that there was a setting in XP that limited the amount of memory available for icons/thumbnails, but I cannot seem to locate this same info for Win 7.  What controls this behavior?  How do I adjust it?
2 Solutions
Brad HoweDevOps ManagerCommented:

Try this, Should work with Win Vista/7 too.

Open the Registry Editor
Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer
Create a new DWORD/STRING called "Max Cached Icons" and set its value to 8192.
Restart your machine.

Also, it would be best to delete the cache file if it exsits here

XP - C:\Documents and Settings\<USER ID>\Local Settings\Application Data\IconCache.db
VISTA/7 - C:\Users\<USER ID>\AppData\Local\IconCache.db

Let us know if it helps.
Tony HungateDirector of TrainingCommented:
This may be helpful as well, it was the a common fix for vista, and should work for 7 as well.


mkuetzingAuthor Commented:
These two solutions were identical & solved my problem.  Note:  removing the cashe file did not help prior to rebooting following the registry change.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now