Failed to mount database after 'Move-DatabasePath'

Hi guys,

Tried moving a database this afternoon because we've run out of space on the current drive. Running MS Server 2008 with Exchange 2010. Ran the 'Move Database Path' option through Exchange Management Console, but after an hour and a half the files seem to have moved but I got the error:

--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
Failed to mount database 'Mailbox Database 0207276594'.

Mailbox Database 0207276594
Failed
Error:
Couldn't mount the database that you specified. Specified database: Mailbox Database 0207276594; Error code: An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-4005)
 [Database: Mailbox Database 0207276594, Server: S1.managed.espoke.co.uk].

An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-4005)
 [Database: Mailbox Database 0207276594, Server: S1.managed.espoke.co.uk]

An Active Manager operation failed. Error: Operation failed with message: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-4005)
 [Server: S1.managed.espoke.co.uk]

MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-4005)





--------------------------------------------------------
OK
--------------------------------------------------------


I've tried remounting it but it still doesn't want to happen.

Any suggestions are welcome!

Thanks in advance.
espokeAsked:
Who is Participating?
 
mattibuttConnect With a Mentor Commented:
ok if you click on file properties and then advance untick this file is ready for archive aND THEN TRY
2
 
mattibuttCommented:
all the exchange services were stopped before you mounted ?
0
 
mattibuttCommented:
if you try again make sure there is no log file exists in the folder it only has the database file
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
espokeAuthor Commented:
All the Exchange Services are started, I've also restarted the server and then ensured they were all started again.

I've moved the log files out of the Log Folder and hit Mount and it does the same again, but re-creates some files in the log folder..
0
 
mattibuttCommented:
how big is the database ?
if database is bigger then the size used by exchange database then it will fail, what i meant was during the copying process all exchanges services should have been stopped while you were moving files also have a look at this link if you bring the database server which is no correctly shutdown that can also cause a problem by not having a clean database this link also gives you some more perspectives.
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_24989416.html
0
 
mattibuttCommented:
any luck buddy?
0
 
espokeAuthor Commented:
Nope, been through the post by ismail.mohammed to no avail...
I've tried various things with eseutil

Suggestions on that page was ESEUTIL /P then /D

When I run /P I get:

Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
Version 14.00
Copyright (C) Microsoft Corporation. All Rights Reserved.

Error: Access to source database 'E:\Exchange Server\V14\Mailbox\Mailbox Databas
e 0207276594"' failed with Jet error -1032.

Operation terminated with error -1032 (JET_errFileAccessDenied, Cannot access fi
le, the file is locked or in use) after 20.31 seconds.
0
 
mattibuttCommented:
can you create an empty database first into the new location and see how it goes
0
 
mattibuttCommented:
make sure log and database folder is the same one also the account you are using is an exchange admin
0
 
espokeAuthor Commented:
Sorry, I'd pasted the wrong error message, it's this one:

Initiating REPAIR mode...
        Database: E:\Exchange Server\V14\Mailbox\Mailbox Database 0207276594\Mai
lbox Database 0207276594 - Copy.edb
  Temp. Database: TEMPREPAIR6052.EDB

Checking database integrity.




Operation terminated with error -4005 (JET_errFileCompressed, read/write access
is not supported on compressed files) after 1.969 seconds.
0
 
mattibuttCommented:
exchange doesnt support archive files for the database
0
 
espokeAuthor Commented:
Ok, it's just doing that now... Would this be the problem? Or should I still run eseutil? Also I managed to create and mount a new database ok by the way..
0
 
mattibuttCommented:
well if its working after removing archive then dont create new database
0
 
mattibuttCommented:
dont eseutil yet if your database mount then there is no need for it
0
 
espokeAuthor Commented:
You've literally saved my ass. No need for me to re-run eseutil, I managed to mount the database again once I'd turned off 'Compress contents to save disk space' on the EDB file.

I didn't realise, but I've got 'Compress this drive to save disk space' on the actual drive, so I'd assume the option on the file was enabled due to that.

Thanks again.
0
 
mattibuttCommented:
its bullshit life is full of surprise sometime microsoft technology play with our head but i am really glad its working i can understand how this responsibility makes us venerable
0
 
espokeAuthor Commented:
After copying the DB to a new drive with the option 'Compress this drive to save disk space' enabled, I went to the EDB file and disabled all compression under the File's advanced options which sorted it!
0
 
mattibuttCommented:
Vulnerable * didnt spell it correctly lol i actually ran into something similar when i was moving my server from 2003 to 2008 but my issue was virtual pc it cant deal with the file larger then 2.6 gig and it has made me do all of this crap eseutil but it the end it was virtual pc who messed up
0
 
cepollyCommented:
saved me as well. the compression part 1st and i'm guess the archive as well.
0
 
megacybercsCommented:
Thank you a lot @mattibutt. After reading dozens of forums and trying all kind or repairs and checks, finally found the solution that saved my ass and my night.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.