Oracle Enterprise Manager 11g Database Control

I am unable to start Oracle Enterprise Manager 11g Database Control, and I got an error.
Anyone knows how to fix it?
I'm using Windows XP...
emctl.jpg
mawinghoAsked:
Who is Participating?
 
sumit2906Connect With a Mentor Commented:
try doing this:
set ORACLE_UNQNAME=<db unique name>
emctl start dbconsole
0
 
mawinghoAuthor Commented:
It doesn't work...
What the db_unique_name should be?
How do I find out?

emctl.jpg
0
 
sumit2906Connect With a Mentor Commented:
select DB_UNIQUE_NAME from v$database;
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
sumit2906Connect With a Mentor Commented:
Also, did you did any changes in your server recently, like changing the host name/ip address, that could cause issue with EM.
0
 
mawinghoAuthor Commented:
no...............I don't know much about oracle...I am just learning...
0
 
mawinghoAuthor Commented:
the db_unique_name should be orcl
now another problem is Oracle_Unqname

db-unique-name.jpg
emctl.jpg
0
 
sumit2906Connect With a Mentor Commented:
try this:
set ORACLE_UNQNAME=orcl
0
 
mawinghoAuthor Commented:
the error message is different now...but still doesn't work...
 

emctl.jpg
0
 
sumit2906Connect With a Mentor Commented:
check whether you have the above directory existing, I mean:
D:\app\bin\product.....
0
 
mawinghoAuthor Commented:
no...

dir.jpg
0
 
mawinghoAuthor Commented:
why oracle used my computer name and domain name?
It should be localhost...
don't know whether oracle installer has a problem...
0
 
sumit2906Connect With a Mentor Commented:
I think you have two options now:
1) recreate the EM configuration, you can use:
emca -config dbcontrol db -repos recreate

2) the second option(a faster one) is to edit your emctl.bat file which is avaialbel in oracle_home/bin directory, and add following lines after setlocal:
set HOST=localhost
set HOSTNAME=localhost
set ORACLE_HOSTNAME=localhost
0
 
mawinghoAuthor Commented:
I did the first option just now...
but still have the same problem...
0
 
sumit2906Connect With a Mentor Commented:
try the second one..add those three lines in your emctl.bat file.
0
 
mawinghoAuthor Commented:
I tried the second options and executed the bat file
still doesn't work...
still got the same message.
0
 
sumit2906Connect With a Mentor Commented:
what is the error message?
0
 
mawinghoAuthor Commented:
same as the previous one
emctl.jpg
0
 
sumit2906Connect With a Mentor Commented:
you need to do following :
1) edit the emctl.bat (open in notepad) file and add those three SET commands:
set HOST=localhost
set HOSTNAME=localhost
set ORACLE_HOSTNAME=localhost
2) save the emctl.bat file
3)from the command prompt run:
set ORACLE_UNQNAME=orcl
emctl start dbconsole
0
 
mawinghoAuthor Commented:
I did that already
0
 
mawinghoAuthor Commented:
it is ok now :)
0
 
mawinghoAuthor Commented:
in fact, why I have such problem?
0
 
sumit2906Connect With a Mentor Commented:
seems to me a bug, also aftetr configuring you EM, if you change your machine name or host name, this could happen as host name is used in config files. you can try metalink for more info.great that the workaround worked for you.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.