Solved

Outlook 2007 cannot connect to Exchange 2000 mailbox

Posted on 2010-08-22
76
610 Views
Last Modified: 2012-08-13
I have just installed Microsoft Outlook 2007 on a Windows Server 2008 X64 machine. However, I can't seem to connect to my exchange 2000 server mailbox. When I try to add the exchange server and mailbox name administrator it prompts for username and password. I type the username and password and it keeps saying it's not correct when it is. Everything works fine on Outlook 2000. The Server 2008 machine is on the same domain as the exchange server and can ping it without any problems. Any assistance on this is appreciated.
0
Comment
Question by:lineonecorp
  • 37
  • 36
  • 2
76 Comments
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33500294
Try turning off encryption between outlook and the exchange server. Which is on the "Security" tab mentioned in the steps below.

OR

 try NTLM authentication
http://support.microsoft.com/kb/927612
Control Panel-->Mail click your Outlook profile, and then click Properties.
Click E-mail Accounts, and then click Change.
In the Change E-mail Account dialog box, click More Settings.
In the Microsoft Exchange dialog box, click the Security tab.
In the Logon network security list, click Password Authentication (NTLM), and then click OK.
Click Next, click Finish, and then click Close two times
0
 

Author Comment

by:lineonecorp
ID: 33501532

Tried NTLM authentication but it didn't work.
0
 

Author Comment

by:lineonecorp
ID: 33501547
Tried turning off encryption and it also didn't work. Any other ideas? Any changes needed on Exchange 2000 server?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33501558
What about turning off encryption between outlook and the Exchange server?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33501565
ignore my post above
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33501628
Are you sure the mailbox you are connecting to is on Exchange 2000 and not Exchange 5.5? Outlook 2007 does not connect to Exchange 5.5.

Another thing to check is that you have installed all the outlook 2007 updates as these resolve several password issues.
0
 

Author Comment

by:lineonecorp
ID: 33502056
I am positive it's Exchange 2000 and all Outlook 2007 updates are applied.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33502086
have you tried
DOMAIN\Username

Or

UPN

as the username?
0
 

Author Comment

by:lineonecorp
ID: 33502259
I have tried both for the username and it still won't work
0
 

Author Comment

by:lineonecorp
ID: 33518369
Any other ideas?
0
 

Author Comment

by:lineonecorp
ID: 33518374
I just did an XP install with Outlook 2007 and it connects to exchange 2000 without any problems so it may be a setting with the Server 2008 - 64 bit operating system.
0
 

Author Comment

by:lineonecorp
ID: 33526399
One more piece of information - we can connect via IMAP.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33537047
I will try this tomorrow. Is it 2008 R2 or normal 2008?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33537073
Have you tried non cached mode?
0
 

Author Comment

by:lineonecorp
ID: 33537455
2008 R2 - I have tried non cached mode and it does not work.
0
 

Author Comment

by:lineonecorp
ID: 33538290
MegaNuk3:

Definitely appreciate your time on this - it shouldn't be this difficult.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33540517
I have just installed outlook 2007 (no service packs) onto a Windows 2008 R2 Enterprise server (64bit) that was in a Workgroup with no updates and using DHCP and was able to connect to an Exchange 2003 mailbox after entering the username and password (because it is not a domain joined machine you would have to enter credentials)

I'll dig around and see if I still have any Exchange 2000 anywhere...
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33540528
If you share a folder from the Exchange 2000 server can you map to it from the Windows 2008 r2 server and access the share?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33543519
hmmm, I have just finished installing Exchange 2000 & SP3 on a Windows 2000 Advanced SP4 server (which I have also just installed to test this) and I can access a mailbox from Outlook 2007 on Windows 2008 R2 x64

So unfortunately that doesn't help you, but at least we now know that Outlook 2007 can talk to Exchange 2000 from a Windows 2008 R2 x64 machine
0
 

Author Comment

by:lineonecorp
ID: 33554956
This does help me as I now know it's doable - you're going the extra mile for sure on this. I will doublecheck the share business.  

As far as the 2000 server you set up, is the Windows 2008 R2 machine a member of the domain or is the process the same as with the 2003 box - that you have to enter your name and password again when connecting via Outlook?

If the 2008 box is not a member of the 2000 domain how are you getting Outlook to connect to the Exchange 2000 - OWA?

0
 

Author Comment

by:lineonecorp
ID: 33563784
Some additional info.  


XP machine joined to the 2000 Domain

When I log in from the XP VM running Outlook 2007 that is joined to the domain and go into local admin properties everything looks good (the local admin has the same name/password as the domain admin. so I see for example assuming the domain is called GA,

the administrator 'picture' with the title Administrator beside it

and then below that the doubleheaded administrator picture with the title GA\ Domain Admins.


2008 Server joined to 2000 domain:

However when I look at the Administrator properties on the 2008 box - again local admin has same name and password as 2000 Domain Admin -  joined to the same domain, I see

the first line the same - e.g. the single head icon and the title Administrator

but then on the following line I see GA\Administrator - and then a whole pile of numbers/letters e.g. S-1-5 .... -

and then on the line below that - the 3rd line - I see GA\Domain Admins\number/letter business again

Can you check your 2008 Server joined to the 2000 domain and see if you have the same type of configuration.

Thanks in advance.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33565760
Sorry, I am away this week, so can't get back on my lab till this weekend.

My windows 2008 r2 machine is in a workgroup by itself and not a member of any domains. I use the windows 2000 dc for dns resolution, then when outlook connects to the mailbox via MAPI, I am prompted for credentials because my Windows 2008 username and password are different to the domain ones.

Did you try the share test?
0
 

Author Comment

by:lineonecorp
ID: 33570308
I will try the share - got distracted. As far as your comment about 2008 not being part of Domain I am not familiar with connecting from an Outlook running on a non-member system to Exchange on a DC. Our 2000 system is the DNS server so are you saying that we can unjoin the 2008 from the domain and then point the 2007 Outlook on the 2008 box to the 2000 box running Exchange and connect via MAPI.  How do we signify the Exchange server then when we are mapping Outlook to the Exchange store - UNC? IP? Also is there a way around having to enter the credentials each time? If we had local 2008 accounts with the same name?

0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33571526
You can use the exchange servername because you are using the 2000 dns server for name resolution. Using the same username and password on the non domain joined windows 2008 server should allow outlook to open without a credentials prompt.
0
 

Author Comment

by:lineonecorp
ID: 33582009
I will give that a try.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33585741
You shouldn't have to disjoin the w2k8 server from the domain, but it might help if there is domain / machine account trust issue that is causing your problem. I would expect the share test to fail too in that case.
0
 

Author Comment

by:lineonecorp
ID: 33602435
Here are screen shots that show the weird admin properties issue I mentioned.
GA--XPLOCAL.bmp
GA---2008LOCAL.bmp
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33610996
I'll add my W2K8 server to the W2k domain and see what I get...

I have also tested creating a local user called w2kuser1 which has the same password as the w2kuser1 domain account and can open outlook without a password prompt on the W2k8 server while it is stil in a workgroup... I will add the W2k8 server to the domain and do some more testing...
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33611811
I've added my W2K8 server to the W2K domain and can log in as W2K\w2kuser1 and W2K\w2kuser2 (new user) and access their Exchange 2000 mailboxes in both cached mode and non cached mode wihout and issue.

After adding the W2K8 server to the domain I looked in the W2k8\Administrators (local group) and it shows the local administrator account and just a SID (S-1-5-21-...... number) for the W2K\Domain Admins group.

I can "net view \\w2k-e2k-01"  (my E2k server and W2K server) from the w2k8 server can you do the same?

I am going to mess around a bit more to see if I can get my SID to resolve to "W2K\Domain Admins"

0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33612310
Hmmm, I have now added some more W2K users to the local Administrators group and the display name is displaying as well as the SID in brackets next to it like yours, so I think this is a "feature" of W2k8 so you can ignore it.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33612318
Try creating a new W2k user with an E2k mailbox with a strong password like P@55w0rd and then see you can open that mailbox from the W2k8 box after logging on as this new user...
0
 

Author Comment

by:lineonecorp
ID: 33613244
I will give your suggestions a try.
0
 

Author Comment

by:lineonecorp
ID: 33614011
Still have the password prompt problem. What operating system is the Server 2008 and Office your running? I am running Windows Server 2008 R2 64 bit with Office Home/Business 2010 (32 bit). The 2000 box is Server 2000 Advanced Server.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33617515
I am running Windows Server 2008 R2 64bit with Outlook 2007 SP2 (not office just outlook). I thought this problem was originally with outlook 2007 not outlook 2010. 1.) Did you upgrade in an effort to try and resolve the issue?

2.) Have you tried starting outlook with /safe to see if then connects so you can rule out any 3rd party add-ins.

3.) Also with the new user account you created, did you logon to the W2k8 server as that account and then try and setup outlook OR did you just setup a new outlook profile and provide the new credentials? If you logged onto the W2k8 server as that account then it proves that there is nothing wrong with that account.

4.) Also from the W2K8 server you should be able to open internet explorer and go to http://e2kservername/exchange and then enter the credentials and access the mailbox via OWA. Does this work for you? Or does that also tell you that the credentials are incorrect?
0
 

Author Comment

by:lineonecorp
ID: 33623842
See @@@

I am running Windows Server 2008 R2 64bit with Outlook 2007 SP2 (not office just outlook). I thought this problem was originally with outlook 2007 not outlook 2010. 1.) Did you upgrade in an effort to try and resolve the issue?

@@@  My mistake, I am running Windows Server 2008 R2 64 bit with Office 2007 (32 bit) (Just Outlook). The 2000 A/D/ Exchange 2000 box is Server 2000 Advanced Server.

2.) Have you tried starting outlook with /safe to see if then connects so you can rule out any 3rd party add-ins.

@@@ Same problem still exist

3.) Also with the new user account you created, did you logon to the W2k8 server as that account and then try and setup outlook OR did you just setup a new outlook profile and provide the new credentials? If you logged onto the W2k8 server as that account then it proves that there is nothing wrong with that account.

@@@ I created the account on the 2000 box, logged onto the W2K8 server as that account and loaded up Outlook to try and connect to Exchange.

4.) Also from the W2K8 server you should be able to open internet explorer and go to http://e2kservername/exchange and then enter the credentials and access the mailbox via OWA. Does this work for you? Or does that also tell you that the credentials are incorrect?

@@@ OWA works without any problems.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33635302
Try telling Outlook to prompt for credentials
Control Panel-->Mail click your Outlook profile, and then click Properties.
Click E-mail Accounts, and then click Change.
In the Change E-mail Account dialog box, click More Settings.
In the Microsoft Exchange dialog box, click the Security tab.
Tick the 'Always prompt for logon credentials' tickbox and then click OK.
Click Next, click Finish, and then click Close two times

close and re-open outlook and then enter the credentials, do you have the same issue? can you post the error outlook is presenting?
0
 

Author Comment

by:lineonecorp
ID: 33637905
Same problem. There is no error message, it keeps prompting for password even though it's correct. When I connect to Exchange 2000 on my Server 2003 box running Outlook 2007 it connects without any problem or passsword prompt.
0
The problems with reply email signatures

Do you wish that you could place an email signature under a reply? Well, unfortunately, you can't. That great Exchange/Office 365 signature you've created will just appear at the bottom of an email chain. What a pain! Is there really no way to solve this? Well, there might be...

 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33638103
This is so odd. when you open OWA does it open straight to the mailbox or does OWA prompt you for credentials too?

See if there are any stored credentials affecting this...

Start->Run->type "Control keymgr.dll" (without the quotes) and press Enter, then delete the saved passwords & let me know the status

NOTE: You might want to backup the stored passwords first.
0
 

Author Comment

by:lineonecorp
ID: 33649674
Will try this.
0
 

Author Comment

by:lineonecorp
ID: 33658715
Still has the password prompt message.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33667344
Does Outlook have to work on there for an application or something? Maybe you should re-install Outlook or try a different version.

Or download MFCMAPI and see if that can access the mailbox without the password prompt issue to see if it is a MAPI issue or Outlook issue.
0
 

Author Comment

by:lineonecorp
ID: 33676337
I will try the MFCMAPI idea - sounds promising.

Yes we need Outlook and we need Outlook 2007.
0
 

Author Comment

by:lineonecorp
ID: 33688663
I used the MFCMAPI utility and chosed Session > Login with Flags. It prompted for a Mail Profile which I typed "Outlook" and it went through the Outlook creating an account wizard. I filled in the information for exchange server/username and it still prompts for password.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33696223
Do you have any other MAPI applications installed on that server? What about Exchange System Manager?

Maybe it is time to uninstall Outlook 2007 and then re-install it and see if that fixes your MAPI logon issue OR uninstall Outlook and install Exchange System Manager (if not installed on there aleady) and then see if MFCMAPI can logon to a mailbox or not.
0
 

Author Comment

by:lineonecorp
ID: 33696695
There is no other MAPI applications or Exchange System Manager installed on the Server 2008 box. I have already uninstalled Outlook 2007 and installed 2003 and it still has the password prompt issue. I have also reinstalled the Server 2008 box and put a fresh copy of Outlook 2007 and I still have the same problem. The problem does not exist with Windows XP or Windows 2003 - there isn't even any password prompt when I setup the account in Outlook using Windows XP or Windows 2003.
0
 

Author Comment

by:lineonecorp
ID: 33796203
Should we pack this in? Are you aware if the EE protocol allows for us to allow you to remote into our system?  Or does that have to be done outside of EE? I'm not sure if you would want to do that and even if you did whether it would be ok per the rules that rule here.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33801971
What happens if you install a fresh W2k8 server on different hardware or a VM and then don't join it to the domain (leave it in a workgroup) and try and access the mailbox? It should prompt for a password only once and then let you in.

0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33802012
Or install windows 7 64bit which is pretty much a client version of Windows 2008 and then see if Outlook can connect from it.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33802062
Otherwise setup netMon and see what packets are being returned from where when the password prompt issue hits...
0
 

Author Comment

by:lineonecorp
ID: 33824919
Sorry I have been away for a few days. I will take up your suggestions.
0
 

Author Comment

by:lineonecorp
ID: 33828707
Still prompts for password on a fresh install of Windows 2008 64 Bit and Windows 7 64 bit.  It's leaning toward some sort of setting needing to be done on the Exchange Server? The same problem happens using Outlook 2003. XP connects fine without any problem using Outlook 2007 or Outlook 2003.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33833779
Did you add those 64 bit machines to the domain or leave them in the workgroup?

Did you ever get round to trying the share test?
0
 

Author Comment

by:lineonecorp
ID: 33836313
Left it in a workgroup - I can access shares without password prompt.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33839451
Does the Exchange server or DC log anything in the event logs when you try and connect and get the password prompt?

Did you create a share on the E2k server and only give your test account read rights? This is to verify your test account can access the E2K server over RPC... much like MAPI.
0
 

Author Comment

by:lineonecorp
ID: 33851704
I don't see any event logs under system/application log files under the DC/Exchange server related to the password prompt.

I created a share on the E2K server with read access on the test account and I can access without any problems.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33864082
Hmmm, are you in the US? I am in the UK

have you thought about setting up a lab with a new E2k server in it (in it's own AD forest) and see if you can connect to that from W2k8? And then if you can you can compare the 2 E2k servers and see what the difference is...
0
 

Author Comment

by:lineonecorp
ID: 33882194
We are in Canada.  Is it acceptable to have Experts remote in for situations like this? I'm thinking you might see something we're missing. Or does that kind of thing go outside of the Experts Exchange loop?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33883096
Hmmm, I don't see why remoting in would be a problem. As long as we post what the solution to the problem was..

email me:  MegaNuk3   at   yahoo  dot  com
0
 

Author Comment

by:lineonecorp
ID: 33916082
Will set things up at this end and will get in contact with you.  Thanks for all the work and patience.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 33938356
sorry, I have been informed that me remoting is against the terms of use of EE, so won't be connecting to your system.

I will get some of the other Exchange Experts to have a look at this question and see if they have any 'fresh' ideas.
0
 

Author Comment

by:lineonecorp
ID: 33954792
Ok.  I did wonder about that in my earlier question.
0
 
LVL 31

Accepted Solution

by:
MegaNuk3 earned 250 total points
ID: 33955996
Do you have Outlook 2003 around somewhere, that might be worth trying on this server.

Otherwise do the AutoConfig test on Outlook 2007 to make sure it is not finding Autodiscover info from somewhere(like the internet) and that is why it cannot log you on:

Test outlook autoconfig.
With outlook open do: Hold down the CTRL key and then right-click on the Outlook icon in the system tray(near the time on the bottom right-hand side of the screen)-->Test e-mail autoconfiguration-->enter a valid e-mail address and password-->make sure "Use AutoDiscover" is the only one ticked-->Press Test and then look in the Log

and paste the log on EE after modifying any confidential info out of it (using mspaint or something)
0
 

Author Comment

by:lineonecorp
ID: 33971047
Megannuk3:

I will do as you suggest with the Autoconfig test.
0
 

Author Comment

by:lineonecorp
ID: 34024246
Just says "Autoconfiguration is unable to determine your settings!"
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 250 total points
ID: 34052064
I believe you are running into an authentication issue between windows 2008 and windows 2000
on the windows 2008 system set the LmCompatibilityLevel value to 1

http://technet.microsoft.com/en-us/library/cc960646.aspx
0
 

Author Comment

by:lineonecorp
ID: 34076480
Thanks. I will give this a try.
0
 

Author Comment

by:lineonecorp
ID: 34138980
endital1097/MegaNuk3

http://technet.microsoft.com/en-us/library/cc960646.aspx  - it worked!!!

Thank you, thank you.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 34139647
Thanks to endital for highlighting that! I can stop pulling my hair out and sleep at night.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 34139694
What was the lmcompatabilitylevel set to?
0
 
LVL 32

Expert Comment

by:endital1097
ID: 34141350
great, thanks for the update
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 34142869
Feel free to close the question and give Endital1097 the points, or at least most of them ;-)
0
 

Author Comment

by:lineonecorp
ID: 34143133
I'm upping the points and will split.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 34143623
Thanks, what was the lmcompatabilitylevel set to? I will check my lab later where it was working and see what the default level is from install
0
 

Author Comment

by:lineonecorp
ID: 34149419
it was set to 1.  Again thanks for all the effort.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 34150176
My E2k W2k machine had lmcompatibility set to 0
and my W2k8 machine didn't have it at all
(the above settings worked for me from the moment I installed the servers during testing)

what were your values on both servers?

0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now