Solved

How do I change the sending server address or set a masquerade address in Exchange Server 2007

Posted on 2010-08-23
11
730 Views
Last Modified: 2013-11-30
I recently migrated a customer from Exchange 2003 to Exchange 2007 ( as part of SBS 2008). Since doing this, they have been getting a number of non-delivery messages based upon the recipients server carrying out a reverse lookup on the mail server address. To put some detail on this, the old mail server was called OLDSERVER but mail was masqueraded to be sent from MAIL.mydomain.co.uk which was setup in the external DNS so that reverse lookup worked correctly. The new server is called NEWSERVER.mydomain.co.uk, and mail shows as coming from that address. Reverse lookup on the IP address however still shows as MAIL.mydomain.co.uk and therefore fails. I want to change the address mail appears to be sent from back to MAIL.mydomain.co.uk. Everywhere I have looked suggests that I would do this in the "Send connector" in Microsoft Exchange Management Console (EMC->Organisation Configuration->Hub Transport->Send Connectors), but when I look in there, the FQDN that shows is WEB.mydomain.co.uk which is the address I set for Outlook Web Access. Somewhere else must be setting the Send Address for outbound email to NEWSERVER.mydomain.co.uk, but I cannot find out where in order to change this?

When I run the command "Get-SendConnector | ft Id*,fq*" in the Exchange Management Shell, it returns the FQDN of WEB.mydomain.co.uk, but when I telnet to the server on port 25 and issue HELO, it responds with NEWSERVER.mydomain.co.uk!

Where is this being set and how do I change the sending server address or set a masquerade address to MAIL.mydomain.co.uk.

Thanks
0
Comment
Question by:solplus
  • 5
  • 4
  • 2
11 Comments
 
LVL 32

Accepted Solution

by:
endital1097 earned 500 total points
ID: 33500189
telnet into is the receive connector, that is why it doesn't match the send settings
you need to run set-sendconnector -fqdn mail.mydomain.co.uk
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33500205
if you want to modify the receive connector so that outside senders see mail.mydomain.co.uk you'll need to run
Set-receiveconnector -fqdn mail.mydomain.co.uk
0
 

Author Comment

by:solplus
ID: 33500323
Doh! Of course it is. Forget my telnet test.

 I have confirmed the send connector setting through Exchange Management Console, which shows as WEB.mydomain.co.uk and with "Get-SendConnector | ft ID*,fq*" which  gives me output:
Windows SBS Internet Send NEWSERVER       WEB.mydomain.co.uk
and not NEWSERVER.mydomain.co.uk which is what is actually showing in outbound mail!

Where can outbound email be getting set to NEWSERVER.mydomain.co.uk
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33500357
are you looking at message headers sent to an external recipient to determine this? the first hop of the message internally will be newserver.mydomain.co.uk because the receive connector gets the message first. the connection to the oustide with use the send connector fqdn.
0
 

Author Comment

by:solplus
ID: 33500390
When I look at an external email is says:
Received: from NEWSERVER.mydomain.co.uk
I want it to say:
Received: from MAIL.mydomain.co.uk
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33500426
Change the Fully Qualified Domain name that is set on your SEND connector, not your RECEIVE connector to mail.mydomain.co.uk and all will be well.

Endital1097's first comment is correct.
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33500443
my second comment for updating the receive was for inbound messages (if you wanted to change what you saw in the telnet session)
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33500465
what does it say on the last hop when the external server receives the message

Received: from www5.experts-exchange.com (64.156.132.145) by
 mail.contoso.com (192.168.4.7) with Microsoft SMTP Server id 8.2.176.0;
 Mon, 23 Aug 2010 08:55:39 -0400
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33500511
The default send connector on SBS 08 is called Windows SBS Send Connector.

How many send connectors do you have?

Do you send your mail to an internal server for sending or directly out from the SBS box?
0
 

Author Comment

by:solplus
ID: 33500591
Double Doh! I was looking at the wrong hop. The last hop is indeed WEB.mydomain.co.uk. I have now changed the send connector to MAIL. I think I will just slip away quietly!
0
 

Author Closing Comment

by:solplus
ID: 33500622
Had I checked my facts, I would have got to a solution quicker!
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Check out this infographic on what you need to make a good email signature that will work perfectly for your organization.
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now