Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 778
  • Last Modified:

Exchange OMA and iphone with exchange account no longer recieving unread email via push

We administer several SBS 2003 networks with for different companies, all of which have iPhones connecting to exchange OMA to recieve and send email via PUSH. These have all been working fine until recently. One of our clients is having the following issue on their iPhones.

When they recieve email to the SBS Exchange mailbox it doesn't automatically PUSH through to their phone (and yes PUSH is the selected option in the settings)
If the phone is setup for an account on a different network it works fine.
Itterestingly enough if the client logs into Outlook Web Access via serverDomainname\exchange the phone then senses that their is new email and recieves the new unread messages moments later.

Similar thing happens if they log into Outlook Mobile Access via a browser, but only when the unread emails are viewed.

I have tried setting the exchange account up on a different phone to verify it isn't the phone itself. The problem appears to be with the OMA on the Server but I don't know where to start looking to rectify, as nothing has changed to my knowledge and everything was working fine up untill last week.

Any help/suggestions are greatly appreciated.
0
mendmycomputer
Asked:
mendmycomputer
  • 2
1 Solution
 
stewie123Commented:
Hi,

Apple has a KB address this issue, please check the following article, #2:

http://support.apple.com/kb/TS1868

Hope this helps.
0
 
Alan HardistyCo-OwnerCommented:
Please have a read of my Exchange 2003 / Activesync article and make sure you have the registry key mentioned in the article set.  This is to do with background anti-virus scanning and is the most likely reason for your current problem.

http://www.experts-exchange.com/M_5220872.html
0
 
mendmycomputerAuthor Commented:
Hi Both, Thanks for both answers, come to think of it we did update the Trens Worry free Business Security on the server just the other week. I'd love to read the article you mention AlanHardisty but your profile page says you have submitted no articles... anychance of a directlink?
0
 
Alan HardistyCo-OwnerCommented:
Sorry - the link seems to have the wrong one!  I am sure i posted this one:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html

And this is the bit you need from there:

If you are getting inconsistent Synchronisation from your device to your Exchange 2003 server, please add the following registry key to the server:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\VirusScan
ProactiveScanning REG_DWORD 1
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now