• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3544
  • Last Modified:

How to enable sound on VMWARE Virtual machine server 2008

We have a VM Server 2008 64bit , it appears there's no sound hardware, we use that server for terminal services connections and would like to enable sound so users can hear audio files from the server in their workstations, in device manager there's no audio hardware, tried to enter the VM bios with no avail.
Removed the "Outlook" Zone, and added the "Remote Desktop/Terminal Services" Zone instead.

rindi,
EE ZA Storage

Open in new window

0
iNc0g
Asked:
iNc0g
1 Solution
 
robbeCommented:
You should just enable sound when initiating the terminal server connection. You should be able to redirect sound without the need of a sound card in the server.
0
 
John HurstBusiness Consultant (Owner)Commented:
Make sure the VM guest machine has the VMware Tools installed. After that, make sure you have a valid sound driver for your guest (although that really should come from VMware when creating the guest).

Also, look in the VM machine properties (.VMX file) and make sure Sound is configured and connected. (Still need the Tools installed). ... Thinkpads_User
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
bgoeringCommented:
The answer kinds of depends on what VMware virtualization platform you are using. In ESX or ESXi there is not any easy way to provide sound on client VMs because those platforms to do not support emulated audio hardware. Your Windows 2008 terminal server would require seeing audio hardware in order to export the sound to RDP guests.

If you are on the 4.1 version of ESX or ESXi you might be able to work around this by obtaining a USB sound device such as the one at http://www.amazon.com/Creative-Labs-Xmod-Sound-Card/dp/B000IZ96LQ and makeing that available to you Windows 2008 guest vm. Notice that I say "MIGHT BE ABLE TO WORK AROUND" because this card, and no other sounds cards are on the supported list of USB devices to be made available to virtual machines. You would just have to try it and see.

Now if you are using some other virtualization platform (Workstation, Server, Player) let me know and I will see if I can find a solution for that.

Good Luck
0
 
Cláudio RodriguesFounder and CEOCommented:
I have this running at home, Windows VMs (2008, XP, 7) running on ESXi (4.0) and sound DOES work over RDP.
On 2008 RDS make sure you install the Desktop Experience role (assuming RDS SH is installed).

Cláudio Rodrigues
Microsoft MVP - Remote Desktop Services
Citrix CTP
0
 
iNc0gAuthor Commented:
in server 2008:
- Administrative Tools | Remote Desktop Services | Remote Desktop Session Host Configuration | RD Session Host Configuration – Properties of RDP-Tcp Connection| Client Settings Tab – Redirection section – Uncheck (disable the following-) Audio and video playback.

solved the problem.
0
 
robbeCommented:
iNc0g that was posted in the link i posted earlier. Too bad you did'nt check that one:

Here is a procedure for 2003:
http://www.techontour.com/os-servers/2007/06/20/enable-sound-in-windows-terminal-server-2003/
0
 
iNc0gAuthor Commented:
in server 2008:
- Administrative Tools | Remote Desktop Services | Remote Desktop Session Host Configuration | RD Session Host Configuration – Properties of RDP-Tcp Connection| Client Settings Tab – Redirection section – Uncheck (disable the following-) Audio and video playback.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Tackle projects and never again get stuck behind a technical roadblock.
Join Now