Solved

Server NIC stops working intermittently

Posted on 2010-08-23
11
518 Views
Last Modified: 2013-11-09
I have a strange problem with my Windows 2003 Server.  Since last week the server has intermittently become inaccessible.  It will be working away fine and all of a sudden nobody can access it.  You can't ping the server nor can you ping any hosts from the server itself.  Usually if you wait a while it comes back of it's own accord but this can sometimes take hours.  Rebooting the server once or twice usually fixed it for a while but today I rebooted about 6 or 7 times with no luck and then I just left it logged in and after about 20 minutes it came back "online" and has been fine for the past 2 hours or so.

It doesn't seem to be software related as I disabled all firewalls and anti-virus software.  I also restarted in safe mode with networking and it was still down under this setup.  I am thinking there is a hardware issue with the NIC but unfofrtunately it's an old single NIC server so I need to purchase a second card to prove this theory.

When it goes down, the odd thing is that the ethernet lights always stay on and it always says connected.  It seems to be sending packets ok but receiving none or very few.  There is nothing showing up in the event logs and I have also tried replacing the CAT5 cable which made no difference.  

Is there anything else I can do, any suggestions for narrowing the problem down further???
0
Comment
Question by:alankinane
11 Comments
 
LVL 4

Expert Comment

by:mrbrain646
ID: 33501119
I would also try a different switch port. They can sometimes go bad. Not sure what brand of server you have but HP has diagnostics you can run from smartstart cd.
I would also update the drivers and firmware for the nic and do a windows update.
0
 
LVL 3

Expert Comment

by:Dave_LaSalle
ID: 33501167
You can try to ping loopback during failure.  If it failes then I suspect card.  If it doesn't fail then check the Hub/Switch it is connected to, try a different port.  If it's a managed product there may be something there to check.

-dave
0
 

Author Comment

by:alankinane
ID: 33501242
It's an IBM xSeries server.  I already update the driver for the NIC but will try the firmware also.  I was able to ping localhost and also the static IP address of the server.  I will try connecting to a different port in the switch though.  Thanks for the suggestions.....
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 
LVL 7

Expert Comment

by:marektech
ID: 33501265
Agreed I have experienced a similar problem which has been caused by the switch. If you are able to log on to the switch via a web interface checking the logs would be a good place to start.

Also maybe the server has multiple network cards, maybe you can just try using a different NIC?

If you can't ping the loop back (127.0.0.1) from the server as Dave mentioned above then something is wrong with the NIC itself.
0
 
LVL 27

Expert Comment

by:Steve
ID: 33501617
youve already updated NIC drivers and advise you can ping loopback and ip.
Id try rolling the driver back to an old one as its a shame its suddenly stopped working.

Id definately try another switch port but things also worth trying to help diagnose next time it happens:

Try disconnecting the network cable and reconnecting after 30 seconds. Similar tests to try are rebooting the switch or disabling the NIC on the server and re-enabling again in network connextions.

What does IPconfig /all provide during the issue?

0
 
LVL 2

Expert Comment

by:hydrokid
ID: 33501712
on the switch that the server is connected too, check for errors and data information.
you can try port spanning and packet sniffing on another port to track traffics on the port connected to your server.
0
 
LVL 7

Accepted Solution

by:
celazkon earned 500 total points
ID: 33501816
I experienced similar behavior about a year ago. What solved it for me was:
1. Try different switch if possible.
2. Check all devices connected to the switch, chances are that some device is malfunctioning and causes these trouble. I used the following approach to find it out: when the server was not accessible, try to unplug all cabels from the switch and connect only the server and one PC (e.g. notebook). If this only device works and server is accessible, the probable cause is a problem with some device on the network. Then simply try one-by-one which cable is connected to the messy device. (I used ipconfig /release and /renew after every cable connected back to the switch). In my case the problem was with the docking station for notebook, so remember to try ALL devices.
3. If the above steps don't solve your issue, try to install a different network card into server, as allready adviced.

Hope it helps you a bit.
0
 

Author Comment

by:alankinane
ID: 33501823
I actually have two switches.  One 24 port switch that the server was connected to and the other is a 5-port firewall which I have a few PCs connected to also.  I had the server connected to the 24-port but I am trying it with the firewall now.  I have also now updated the firmware on the nic.  We'll see how it goes.  Thanks for all the suggestions people......
0
 

Author Comment

by:alankinane
ID: 33508802
Update:  It stayed up for the rest of yesterday and was working first thing this morning.  Then it went down again.  I think now that it is the 24-port switch that is causing the problem (or a device connected to it perhaps).  Initially when we went down this morning the server and PC connected to the firewall appeared unaffected but then they went down also so I think the 24-port is bringing everything down.

Upon restarting the 24-port switch everything came back up again although it took about 15 minutes or so after restarting the device.

I have ordered a replacement 24-port switch and will see how that goes.
0
 
LVL 27

Expert Comment

by:Steve
ID: 33509120
@alankinane

great stuff! Although rebooting the server has been your previous fix, we needed to establish if the server was actually at fault.
If you've already ordered the switch you may as well see how it goes but take care what is connected as another device on the network could still be the cause.
0
 

Author Closing Comment

by:alankinane
ID: 33529926
It turns out it that one of the CAT5 cables in the 24-port switch was connected to another port and thus creating a loop.  I should really have checked for this first before buying a new switch.  Not sure who connected it like this or why it suddenly started to become an issue now as it appears it has been connected like this for some time.
0

Featured Post

Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Windows 10 and VLANs don't work (any update) 5 154
server plus 2 102
fiber and Gig ports on 3650 5 55
Booster, Repeater, or Wireless Access Point 9 56
This article is a how to to configure a UCS Ethernet-uplink portchannel via the console. It is easy to do and can be done quite quickly. In certain versions of the UCS manager the portchannel has issues coming up and this is a workaround. I am…
Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
This video shows how to use Hyena, from SystemTools Software, to bulk import 100 user accounts from an external text file. View in 1080p for best video quality.
Established in 1997, Technology Architects has become one of the most reputable technology solutions companies in the country. TA have been providing businesses with cost effective state-of-the-art solutions and unparalleled service that is designed…

821 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question