?
Solved

session timing out too soon - IIS 6, ASP.NET application

Posted on 2010-08-23
6
Medium Priority
?
554 Views
Last Modified: 2012-05-10
I have an ASP.net application running on Windows Server 2003.  My application seems to time out after only 20 minutes of inactivity.

I have set the Web.config as follows:
<sessionState stateConnectionString="tcpip=127.0.0.1:42424" sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes"
   cookieless="false" timeout="125" />

I have also set the Session Timeout in the web properties to 120 minutes.

The Application Pool is set to recycle only at 5:00 am.
Under the Performance tab, Shutdown idle worker processes = 120 minutes

This is causing a lot of problems for my users and they are about to start throwing things! :)
I have ready a lot of other posts, but nothing seems to work for me.
Urgent help needed.  Thanks!
0
Comment
Question by:lanier3532
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
6 Comments
 
LVL 5

Accepted Solution

by:
tvPrasad earned 2000 total points
ID: 33502539
If you want to change the timeout value to be longer, you can easily change the timeout value in your local web.config file (the timeout value is in minutes):

<system.web>
    <authentication mode="Forms">
          <forms timeout="50000000"/>
    </authentication>
</system.web>

Hope this helps
0
 

Author Comment

by:lanier3532
ID: 33502790
thanks.  I'll give it a try.  I've set mine to 240
0
 
LVL 2

Expert Comment

by:MatrixDweller
ID: 33503285
I thought the timeout value was in seconds, so setting it to 125 is going to be 2 minutes and 5 seconds.

You also have to set it in IIS. See this thread for more information on the subject.
http://forums.asp.net/t/1283350.aspx
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 
LVL 2

Expert Comment

by:MatrixDweller
ID: 33503318
My bad it is minutes. You'll still need to set it in IIS.
0
 
LVL 5

Expert Comment

by:tvPrasad
ID: 33503425
HI,

One more point... make sure you are using the correct Application pool.

Thanks
0
 

Author Closing Comment

by:lanier3532
ID: 33541581
Working great now.  Thanks!
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Running classic asp applications under Windows Server 2008 R2 (x64) and IIS 7 is not as easy as one may think. It took me a while to figure it out while getting error 8002801d a few times. After you install the OS you will need to install the fol…
Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question