Solved

Default SMTP e-mail address wrong for only new users

Posted on 2010-08-23
9
337 Views
Last Modified: 2012-06-21
In our working Exchange 2007 system, a strange problem has popped up.

When HR goes about creating new users and an associated mailbox, the default SMTP reply address is created with the wrong domain suffix.

Our default email reply address is user@company.com
Now, When created, a new user is getting a default email reply address of user@family.com.

Family.com is a masquerade address created for a half-dozen family members of our ownership.  Until recently, if asked to create a mailbox for a new family user, I would create the mailbox, it would get the default 'company.com' reply address, I would uncheck the  "automatically update email addresses by recipient policy" box, add family.com and change the default SMTP address to user@family.com.  Standard Stuff.

Now all newly created users are getting the family.com address instead of company.com.  Removing the family.com recipient policy breaks incoming email for those few family users, internal mail for them still works fine.  The family.com recipient policy has been in place for years and has never caused a problem.  All other requirements to allow mail to route to and from user@family.com have been in place for years.

I have unchecked 'automatically update...etc' for all users...but new users have it checked by default...and are getting the family.com reply SMTP primary.

I CANNOT remove the family.com recipient policy.  The Default Recipient policy was giving us company.com as an address until recently.

Is there somewhere in ADSI edit that defines the default SMTP reply address?

Is there somewhere in the Exchange config where I can have 'automatically update...' turned off by default.


I use this wonderful ADModify program to batch edit exchange, but there is nothing in there to help.

We do too many new users for HR to be mucking around changing Default smtp reply addresses.
0
Comment
Question by:handgunowner
  • 4
  • 4
9 Comments
 
LVL 9

Expert Comment

by:Dan Arseneau
ID: 33502618
Is the user account set to inherit the email addresses from the policy?
0
 
LVL 9

Expert Comment

by:Dan Arseneau
ID: 33502628
Sorry, just noticed you said you unchecked this setting.  You could use Custom Attributes and then a policy based on that value.
0
 

Author Comment

by:handgunowner
ID: 33502638
Other than the 'automatically update email addresses by recipient policy' box, where would that be?

The box is unchecked on all current users, but checked by default for new users.
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 
LVL 28

Expert Comment

by:sunnyc7
ID: 33502643
Open Exchange

Org config
Hub Transport
Email Address Policy
Right click > Edit

See which email address is BOLD (default)
Is it company / or family.

0
 
LVL 9

Accepted Solution

by:
Dan Arseneau earned 500 total points
ID: 33502673
I create custom email policies for this purpose.  I have a Custom Attribute set to something like NewYork...then for all accounts that have NewYork in CA1, it applies the appropriate email address.
0
 

Author Comment

by:handgunowner
ID: 33502706
Sunnyc7

Exchange 2007 Email Address Policy tab has two named entries.  Family.com has only one SMTP address (family.com) and Default has company.com.  There is no bolding.

Dan

Yeah, I could go this route, but I am really curious about why it switched over from company.com to family.com for only new users.
0
 
LVL 9

Expert Comment

by:Dan Arseneau
ID: 33503457
You can easily report on that value via Powershell to see who does/doesn't have this setting enabled.

Get-Mailbox | ft DisplayName, EmailAddressPolicyEnabled
0
 

Author Comment

by:handgunowner
ID: 33503499
Tried that

All addresses are FALSE for enabled policy

It only effects new users being created
0
 

Author Closing Comment

by:handgunowner
ID: 33512692
I never found out why the problem started up, but this was a good work-around.

I added a nonsense custom attribute, and combined with the fact that ONLY new users have that box checked - solved the problem for new users.
0

Featured Post

The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Unified EndPoint Management 1 26
Exchange 2010 Room mailboxes 5 35
Exchange 2016 install absolute nightmare 10 44
need assistance with this powershell script 4 43
This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
Having trouble getting your hands on Dynamics 365 Field Service or Project Service trial? Worry No More!!!
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question