How to upgrade Citrix Secure Gateway 3.1 to 3.2

Hello,

How would I upgrade my CSG 3.1 to 3.2? I'd like to also upgrade my WI from 5.0 to 5.3? My goal is to get Citrix to work with MACs, iphone and ipad. How do I upgrade?

Current Environment:

LAN Server #1: Server 2008 Std 64bit - is the Data Collector that runs our apps.

Installed on the server:
Access Management Console
XenApp
Passthrough Client
Citrix XenApp Plugin for Streamed Apps
XenApp Advance Configuration
EMR Application
Not a DC, however joined RAPA.local

DMZ Server #2: Server 2003 Std, SP2, 32bit, 4GB RAM and Disk space 67.70, free 59.22GB - Citrix Web Interface and Citrix Secure Gateway.

Installed on the server:
Licensing Server
Web Interface
Citrix Secure Gateway
IIS


Not a DC, however joined RAPA.local

Citrix Web Interface Version:             5.0.1.29110
Citrix Secure Gateway:                   3.1
IIS:                         V6.0
IIS Site:                         Default Web Site
Path:                         /Citrix/XenApp

Thanks,

nimdatx
LVL 1
Jaime CamposAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
nappy_dConnect With a Mentor Commented:
Your settings will not be lost.  I just upgraded from FP2 to FP3 last weekend.  However, it is recommended that you have your settings documented as well Citrix recommends a remove/reinstall over an in place upgrade.

I assumed that you were already at FP2.
0
 
nappy_dCommented:
You should already be able to allow iPhones and iPads access to your WI and CSG. Please refer to this article.

In terms of upgrading to feature pack 3 features for WI and CSG, please refer to this URL http://support.citrix.com/proddocs/index.jsp?topic=/xenapp/xenapp5fp3-w2k8-wrapper.html
0
 
Jaime CamposAuthor Commented:
I'm sorry your links did not work. Is that what you call it (Feature pack 3) when ugrading to 5.3 & 3.2?

Do you know where I can find a step by step article on upgrading these versions and appling hotfixes to my XenApp 5?

Thanks,

nimdatx
0
[Webinar] Kill tickets & tabs using PowerShell

Are you tired of cycling through the same browser tabs everyday to close the same repetitive tickets? In this webinar JumpCloud will show how you can leverage RESTful APIs to build your own PowerShell modules to kill tickets & tabs using the PowerShell command Invoke-RestMethod.

 
Jaime CamposAuthor Commented:
How do I find the feature pack I'm on and can I simply jump up to 3 just like that?
0
 
nappy_dCommented:
The link I provided gives you all the info on the setup.  I highly recommend that you DO read thru it prior to the upgrade to make sure you have all your ducks in a row.

This is a more direct link http://support.citrix.com/proddocs/topic/xenapp5fp3-w2k8/xenapp5fp3-w2k8-install-and-setup-wrapper.html

To find out your version, of WI look at your folder name in \Program Files\Citrix\Web Interface\
0
 
Jaime CamposAuthor Commented:
I have Feature Pack 1, so I'd like to know if I can install Feature Pack 3 or do I need to go from 1, then 2 and then 3? I know how to find out versions of WI and CSG, but I'd like to find out exactly what Feature pack I currently have, besides looking at my install CD. I just want to make sure.

You mentioned that I did not need to upgrade WI and CSG to use iPhone and iPad, but I was told differantly on this site, so can you send any documentation?

You have provided a link on how to upgrade Feature pack, now why would I want to do the feature pack upgrade and again can I go from 1 to 3?

My initial post was how can I upgrade WI and CSG to the current versions without losing my settings?  production Farm? Can you help me with that?
0
 
Jaime CamposAuthor Commented:
SO should I go from 1 to 2 then 3? Will you entertain the other questions I have? Thanks.
0
All Courses

From novice to tech pro — start learning today.