Checkpoint VPN through Iptables

My company have a firewall Linux / iptables, managed by firewallbuilder.

There is a user in my company, that needs to access a another company using a VPN client (Check Point VPN-1 SecureClient NGX R60 HFA2). But I am not able to perform this configuration in firewallbuilder / iptables.

The another company IT, which has firewall checkpoint, said that I needed just allow udp 500 port to ther firewall and put the rule as stateful. I confirmed that all rules in firewallbuilder are stateful by default and even allow all ports from client to destination, the VPN client does not work.

How can I troubleshoot this problem?
strausswalterAsked:
Who is Participating?
 
jimmyray7Connect With a Mentor Commented:
Try also allowing UDP port 4500, which is sometimes used if a client is behind NAT.
0
 
Dave HoweSoftware and Hardware EngineerCommented:
I have a cp secureclient (r60, but r56 works too) behind a nat. the boxes to tick are office mode and both udp encapsulation boxes in the advanced settings properties page for the connection.
0
 
strausswalterAuthor Commented:
I am concluding that the problem is not about ports, I already allow all ports. The problem apparently, is NAT related. I sow that IPSec is not compatible with traditional NAT, I would have to enable NAT-T. I am researching how to setup this type of NAT in iptables.

Using a direct Internet link at client computer (without NAT), the VPN client run normally.
0
 
strausswalterAuthor Commented:
Problem solved.

With the help of the company that use this vpn client, I downloaded the VPN client and tried re-install the vpn client in another computer. Looking for the client IP in iptables logs (tail -f /var/log/messages | grep 10.220.2.4) I could see a connect to another company firewall IP (201.x.x.x) at 4500 port. But in a secound connection the VPN client attempted to connect in a strange internal IP (10.1.x.x) at port 500.

The problem was that another company already owned the network 10.220.0.0, but they did not realize it. We assume, after these results, that after the first access the VPN client downloaded the another company network topology and the vpn client thought that it was in the company network and attempted to access a internal server.

We create a separate VLAN to this client, with another network address.

Now it is working properly.
0
 
Dave HoweSoftware and Hardware EngineerCommented:
no company owns 10.x.x.x - its an rfc1918 subnet :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.