Solved

(0x507) error when trying to Connect to TS 2008 from XP SP3

Posted on 2010-08-23
11
4,434 Views
Last Modified: 2013-11-21
I have terminal services set up on a Windows server 2008 that is also a domain controller. I have no issues connecting to it remotely through machines running Windows 7. However, I have several machines running XP SP3 that cannot seem to connect. I get to the initial log in screen in TS which authenticates no problem. It is when I launch an application and enter in my credentials that I get the RemoteApp error:
An authentication error has occurred (Code: 0x507)

Remote computer: {domain name}

Any help would be appreciated
0
Comment
Question by:B00m3r
11 Comments
 
LVL 37

Expert Comment

by:Neil Russell
ID: 33503870
Upgrade to the latest RDP client.
0
 
LVL 37

Expert Comment

by:Neil Russell
ID: 33503898
OR Are you using smart cards at all over the TS session?
0
 

Author Comment

by:B00m3r
ID: 33503927
No, I'm not using smart cards. I've done all optional and required windows updates on the machines. Is the latest RDP client only downloadable from microsoft directly?
I've also enabled NLA through the registry.
0
Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

 
LVL 37

Expert Comment

by:Neil Russell
ID: 33503956
I wouldnt download ANY windows components form anywhere EXCEPT microsoft!
0
 

Author Comment

by:B00m3r
ID: 33503980
I meant through their website as apposed to doing it through Windows Update
0
 
LVL 37

Expert Comment

by:Neil Russell
ID: 33504060
What version of the client are you currently running?
 
0
 

Author Comment

by:B00m3r
ID: 33504106
Right now I'm running Version 6.0. To the best of my knowledge that is the latest version.
0
 

Author Comment

by:B00m3r
ID: 33504230
Scratch that, I'm running RDC 6.1
0
 
LVL 2

Expert Comment

by:sameeragayan
ID: 33504341
Check "Always Prompt for Password" on RDP - Properties and see whether it will work that way.

5436645654656.png
0
 
LVL 2

Expert Comment

by:DavidGerald
ID: 33520801
Have you configured your RAP and CAP policies correctly?
Also have you got NLA enabled on enabled on the connection in session host server, if so try disabling.  Make sure encryption on the samce screen is set to client compatible.
0
 

Accepted Solution

by:
B00m3r earned 0 total points
ID: 33521046
I was able to resolve the issue. The registry changes that I had for XP SP3 to enable NLA weren't correct.
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Know what services you can and cannot, should and should not combine on your server.
This article explains how to install and use the NTBackup utility that comes with Windows Server.
This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question