?
Solved

SharePoint Email Enabled Docuemnt Library and Global Adddress List Problem

Posted on 2010-08-23
5
Medium Priority
?
524 Views
Last Modified: 2012-08-14
Dear Experts,
I have email enabled document libraries in Moss2007 that work fine when clients manually type in the email adddress in Outlook or if they create a contact in Outlook.

The contact/address that gets created in the Global Address List will not work though.  It will pull up when addreessing but the message bounces back with an "Email address not found".  If you double click on the contact in the address bar there is no email address which would explain the bounce.  In the Exchange Contact properties there is an "External Email Address" entry with the correct document library email address.  After manaully creating an SMTP email address with the same email address, the contact that pulls up when addressing a new message now has an SMTP address and no bounch occurs but the message is not arriving in the document library.

To recap, when manualy entering the email address of the document libary in Outlook, or by entering the document library as an outlook contact, messages are deliverd to the document libary just fine.  Only the contact/exchange  contact that gets created by the document library doesn't work.  

Thanks,

Jeff
0
Comment
Question by:camusa2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
5 Comments
 
LVL 7

Expert Comment

by:arduk
ID: 33506396
are you using exchange 2007?

we recently upgraded to exchange 2007, and ran into a similar sounding problem - the contact was created, but the email policy was not automatically applied

see http://lambertqin.spaces.live.com/blog/cns!E93C48B467E6B3E1!1375.entry for more info.

To work around this, we now run a powershell script each night which applies email policy to all contacts created by sharepoint.

hope this helps
0
 

Author Comment

by:camusa2
ID: 33514709
Update:  

The message envelope arrives in the docuemnt library but the attachments are lost.  This is only for email addressed using the GAL.  If I use an Outlook Contact, the attachment gets deliver properly.  Any help is greatly appreciated.

Thanks,

Jeff
0
 

Accepted Solution

by:
camusa2 earned 0 total points
ID: 33515000
Problem solved ????

Experts, I stumbled upon the following article "http://www.yana.be/Lists/Posts/Post.aspx?ID=7" that fixes my problem but would now like to know why it's happening so I can avoid a lot of manual labor.  The problem is that a couple properties are not being set on the contact in AD/Exchange.  The "Internet Encoding" and "MAPIRecipient" property were not set on the contact and had to be manualy edited using ADSI editor which immediatley fixed the problem.

What needs to be done so these 2 properties get set properly when creating contacts using SP?

Thanks,

Jeff
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 34680019
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question