[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

remote desktop to Linux box

Posted on 2010-08-23
23
Medium Priority
?
1,101 Views
Last Modified: 2013-12-15
I managed to used NX to remote desktop to SuSe Linux box.

If I remote desktop from home to my windows box at work, I can see the exact image which is present at work. (meaning the session is same)

However when I remote desktop to Linux box, its a complete new session.
Lets say if I have an  opened eclipse on Linux box which is kept open, after remote desktop to linux box, I get a new session and I can't open eclipse on this new session as it is already open on the actual linux box.

My question is why do I get new session when I remote desktop to Linux. I am expecting to see the exact same session which is present on Linux box so that I can use all the window/session which are currently open in linux box. Is this possible??
0
Comment
Question by:learningunix
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 14
  • 3
  • 2
  • +3
23 Comments
 
LVL 3

Expert Comment

by:shawnmstout
ID: 33506426
you have to append the connection with a :1 to join the first session here is an example

192.168.0.1:1
ip_address:session_number

and thats it
0
 
LVL 5

Expert Comment

by:tniemetz
ID: 33506440
In your NX client settings look for an option called "Shadow" - that's the only way to connect to an existing session with NX. I think it's in the General tab of the configuration section.
0
 

Author Comment

by:learningunix
ID: 33506791
is the "shadow " available for free NX version? as i couldn't find it
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 

Author Comment

by:learningunix
ID: 33506861
:1  also didn't work for me.
0
 
LVL 3

Expert Comment

by:shawnmstout
ID: 33507125
im sorry the option i have you was for vncviewer, for nix you should join the same session, are you suspending the session when you leave it?  this is very important cause if you dont suspend it then you would be opening a new session.
0
 

Author Comment

by:learningunix
ID: 33507144
no i didn't suspend the session before leaving. i'll try that tomorrow morning when i go to work and see.

I did see bunch of options in /usr/NX/etc/server.cfg file  like

EnableDesktopSharing= “1”
 EnableSystemDesktopSharingAuthorization = "0"

and many others. may be one this might also work.  i'll try tomorrow and see.
0
 
LVL 35

Expert Comment

by:torimar
ID: 33509179
You have to select "Desktop: Shadow" in the client, and set "EnableSessionShadowingAuthorization" to 0 in the server.cfg.
Check here: http://www.opensourcetutor.com/2007/06/21/nomachine-nx-desktop-sharing-shadowing-now-available/

ps:
As I tried to tell you in your last question, NX (or FreeNX: http://freenx.berlios.de/) is required only when the server runs headless, i.e. without its own desktop, because NX will emulate a virtual X server. If the server you want to remote into already runs its own X windows system, any VNC will do. Most Linux distros come with a VNC server pre-installed which only needs to be enabled.
Check this for complete reference: http://tr.opensuse.org/Remote_Access_to_SUSE
0
 

Author Comment

by:learningunix
ID: 33510282
I tried this
>>
You have to select "Desktop: Shadow" in the client, and set "EnableSessionShadowingAuthorization" to 0 in the server.cfg.
>>

Client failed with

NX> 726 Asking user for authorization to attach to session
NX> 596 Error: Unrecognized answer from nxnode: Xlib: No protocol specified

nxclient: cannot connect to X server :0.0
.

NX> 999 Bye.
NX> 105 NX> 280 Exiting on signal: 15

0
 

Author Comment

by:learningunix
ID: 33510473
I tried this:

EnableSessionShadowing = "1"
EnableInteractiveSessionShadowing = "1"
EnableSessionShadowingAuthorization = "0"
EnableDesktopSharing = "1"
EnableInteractiveDesktopSharing = "1"
EnableFullDesktopSharing = "1"
EnableAdministratorDesktopSharing = "1"
EnableDesktopSharingAuthorization = "0"
EnableSystemDesktopSharingAuthorization = "0"

This time it went pass the authorization phase and it was trying to establish and it failed saying "The connection with the remote server was shut down. please check the state of your network connection"
0
 
LVL 35

Expert Comment

by:torimar
ID: 33510522
Try setting:

EnableInteractiveSessionShadowing = "1"
EnableInteractiveDesktopSharing = "1"

to "0". "Interactive" may mean that feedback is expected from inside the running session.
0
 

Author Comment

by:learningunix
ID: 33510601
Didn't work setting to "0" .

One thing I noticed is. It was trying to establish "Display Connection" and then suddenly it failed with the above error message.

0
 

Author Comment

by:learningunix
ID: 33510646
i have attached the image of failure...
img.bmp
0
 

Author Comment

by:learningunix
ID: 33510724
well i also noticed it said "Established Display Connection" but in the end it fails with the connection error.
0
 

Author Comment

by:learningunix
ID: 33512314
it looks a font issue based on this:
http://openfacts2.berlios.de/wikien/index.php/BerliosProject:FreeNX_-_FAQ/Server

 DEFAULT_FONT_PATH=$(echo $(grep -v '^ *#' /etc/X11/xorg.conf | grep FontPath | awk '{print $2}' | sed -r "s/^[\"']|[\"']$//g") | sed 's/ /,/g')                                                                                      
 AGENT_EXTRA_OPTIONS_X="-fp $DEFAULT_FONT_PATH"

I am trying to find in my suse linux 11 where to find the profile/login to set these variables

any idea where is this located?
0
 
LVL 35

Expert Comment

by:torimar
ID: 33512770
You are not using FreeNX, you are using the original NX by Nomachines; so you should turn to their resources for troubleshooting:
http://www.nomachine.com/ar/view.php?ar_id=AR11B00098

That page contains a variety of hints and links to half a dozen more pages that are on the topic.

I think it could be a user/permission related issue. Remember you tweaked NX into letting you connect as root? Try connecting as a normal user/user "NX" first and see if that works.
0
 

Author Comment

by:learningunix
ID: 33512852
i tried updating /etc/profile and added AGENT_EXTRA_OPTIONS_X still didn't work :(

let me try what you suggested.
0
 

Author Comment

by:learningunix
ID: 33513220
i think so I am going to give up now ;)

in which file do I need to add

 DEFAULT_FONT_PATH=$(echo $(grep -v '^ *#' /etc/X11/xorg.conf | grep FontPath | awk '{print $2}' | sed -r "s/^[\"']|[\"']$//g") | sed 's/ /,/g')                                                                                      
 AGENT_EXTRA_OPTIONS_X="-fp $DEFAULT_FONT_PATH"

I added in /etc/profile and restarted the session but didn't work.


I guess i need to add somewhere in /usr/NX
0
 

Author Comment

by:learningunix
ID: 33514273
any ideas guys?
0
 

Author Comment

by:learningunix
ID: 33517070
i know what the issue. look at the image attached. the client does not know the "Geometry". not sure how to fix it.


image.bmp
0
 

Author Comment

by:learningunix
ID: 33554788
can you please force close the question as it is still unresolved and I am still having t
0
 
LVL 9

Expert Comment

by:crazedsanity
ID: 33831104
I would seriously suggest using any for of VNC, as suggested previously.  NX/FreeNX is most useful if you don't care about connecting to an existing session.  Although it requires learning something different, I really think it would ultimately be the best solution.
0
 
LVL 1

Accepted Solution

by:
Micha3615 earned 1000 total points
ID: 34018476
From what I can see you are trying to run a X11 Session, have your tried gnome or KDE.

This should be under your General tab, you should see desktop and then you can select if you want to rdp, under unix  run either a X11 desktop as KDE, GNOME, CDE and XDM or a single application by choosing the Custom option.

You can even select VNC if you have the vnc server running.

0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question