Solved

mailbox not forwarding to external address

Posted on 2010-08-23
24
2,114 Views
Last Modified: 2013-11-30
I have a user who insists on having his email forwarded to an external email address.  It was working fine until about a week ago when we discovered that it was forwarding internal mail to the external address,*@gmail.com, but not external mail addressed to him.

First thing I did was to delete the mail enabled contact and recreate it.  That had no effect, didn't make the issue worse but it didn't make it better.  I also ran the EXBPA on the Exchange server.  All it returned was an unrecognized signature.  I followed MS's instructions on the matter and accomplished nothing.  Error remains and I am not sure if it effects anything at all.  I went ahead and appied rollup package 4.  Now user is getting 2 copies of the email from internal but still no external mail forwarded to his gmail account.  I decided to setup my generic IS email account, where I have all the warnings sent, to forward email.  Created the mail enabled contact, set the attribute in the mailbox to forward and I am getting nothing.

Server has:
Windows Srever 2008 R2
Exchange 2010
Vipre for Exchange Security
SMTP
0
Comment
Question by:BMCISAdmin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 12
  • 3
  • 3
  • +4
24 Comments
 
LVL 5

Expert Comment

by:ploftin
ID: 33506657
Do you have the external destination email domains (Ie. @gmail.com or @youremailprovider.com) configured properly to allow you to route email to them? Are any bounce messages generated?
0
 

Author Comment

by:BMCISAdmin
ID: 33506672
I can send internal mail to the addresses internally.  It's only when the user get's an email from abc.com that it doesn't forward to his gmail account.  Not sure what you are asking.
0
 
LVL 14

Expert Comment

by:Psy053
ID: 33506908
I think that this may be what you are after:
http://technet.microsoft.com/en-us/magazine/ff381469.aspx
0
Forrester Webinar: xMatters Delivers 261% ROI

Guest speaker Dean Davison, Forrester Principal Consultant, explains how a Fortune 500 communication company using xMatters found these results: Achieved a 261% ROI, Experienced $753,280 in net present value benefits over 3 years and Reduced MTTR by 91% for tier 1 incidents.

 

Author Comment

by:BMCISAdmin
ID: 33507054
That is exactly what I did but it is not working for some reason now.  It was working up to a week ago then it stopped.  No patches have been applied to the server except the roll up patch I applied today.
0
 

Author Comment

by:BMCISAdmin
ID: 33509679
To summarize the problem.  If someone internal sends to the user's internal address it will forward.  If someone from external to the org sends to the users internal address it will not forward.

Digging through the logs I found that the host server had a BSOD about the time this started.  This is a virtual server on Hyper-V.
0
 

Author Comment

by:BMCISAdmin
ID: 33520324
Fixed the BSOD issue.  Apparently there is an issue between HyperV and the Intel Xeon 5500.  I applied MS KB975530 and the server at this point actually appears to be running better.
0
 

Author Comment

by:BMCISAdmin
ID: 33531248
As a test I turned off the server side rule and went in and created an inbox rule and it appears to be working for internal mail but not external mail.  This is becoming extremely frustrating.
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 33534646
Are there any other rules that could be affecting this ?

0
 

Author Comment

by:BMCISAdmin
ID: 33535329
I had the user remove all inbox rules and still nothing.
0
 
LVL 37

Expert Comment

by:Jian An Lim
ID: 33538115
have you try to put the rule in hub transport?

0
 

Author Comment

by:BMCISAdmin
ID: 33542811
Where would I do that?  i am still finding my way in 2010.
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33546622
get-mailbox mailboxname | fl *forward*

That will show you the settings

then run

set-mailbox mailboxname -DeliverToMailboxAndForward:$True -ForwardingAddress:"lincoln@gmail.com"

See if that works ?
0
 

Author Comment

by:BMCISAdmin
ID: 33557496
I am going to have the user watch it but powershell gave me the warning that the command completed but no settings have been changed.
0
 

Author Comment

by:BMCISAdmin
ID: 33566608
No good.  External mail is still not being forwarded.
0
 
LVL 37

Expert Comment

by:Jian An Lim
ID: 33572290
in exchange management console,
goto organisation rules, hub transport, transport rules
create a new transport rule

type in a name
sent to people (put the user name)
Blind copy to these address (put the forwarding email address)


0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33572323
BMCIS
Let me ask you this.

Can you configure email forward for another user and test it - see if it works ?
If it works for another user then it can be isolated to a mailbox issue.

If it doesnt work for the other user, then we will be looking at other exchange options.

thanks
0
 

Author Comment

by:BMCISAdmin
ID: 33575499
sunnyc7 It doesn't forward for any users.
0
 

Author Comment

by:BMCISAdmin
ID: 33575679
limjianan thanks for the suggestion but that did not work either.
0
 
LVL 37

Expert Comment

by:Jian An Lim
ID: 33575702
underlying there is some serious problem within exchange 2010

do you have any error message in event log?
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33575778
Bmcis admin
There are couple of things you can try.
A) check whether the forwarded emails are being generated
Go to emc toolbox message tracking center
Enter the email address of internal and external gmail address.
B) you mentioned its working for internal users and not for external, so I am thinking maybe relay issues related to external users.
C) is there a rule which allows relay for internal subnet / authenticated users only

I will ppst back if I figure out something else.
If emails don't show up in message tracking, I think you need to create a send connector for users/ applications to relay without authentication

0
 

Accepted Solution

by:
BMCISAdmin earned 0 total points
ID: 33576069
In responce to C, I personally have not set one up.  Where would I check for the relay rule?  Here are the errors in the event log, the last two refer to my old server for some reason.:
Error      9/1/2010 6:16:13 AM      MSExchange RPC Over HTTP Autoconfig      2003      General      The RPC over HTTP Proxy component is not installed or is not properly configured. Use the Windows Component Wizard to add the RPC over HTTP Proxy component to the Networking Services.

Warning      9/1/2010 6:01:49 AM      MSExchange ADAccess      2159      Validation      Process Microsoft.Exchange.RpcClientAccess.Service.exe (PID=3412). Configuration object CN=SMTP (MAIL-{DD4890AF-6009-45D1-BBA6-2E427227E30E}),CN=Connections,CN=Bachman Machine,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Bachmanmachine,DC=com read from BMCCAD01.Bachmanmachine.com failed validation and will be excluded from the result set.  Set event logging level for Validation category to Expert to get additional events about each failure.

Error      9/1/2010 6:01:18 AM      MSExchangeTransport      5015      Routing      Microsoft Exchange cannot find a route to the source transport server or home MTA server CN=MAIL,CN=Servers,CN=BACHMAN,CN=Administrative Groups,CN=Bachman Machine,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Bachmanmachine,DC=com for connector CN=Bachman,CN=Connections,CN=BACHMAN,CN=Routing Groups,CN=BACHMAN,CN=Administrative Groups,CN=Bachman Machine,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Bachmanmachine,DC=com in routing tables with timestamp 9/1/2010 11:01:18 AM. Microsoft Exchange is ignoring the source transport server.

Warning      9/1/2010 6:01:18 AM      MSExchangeTransport      5006      Routing      Cannot find route to Mailbox Server CN=MAIL,CN=Servers,CN=BACHMAN,CN=Administrative Groups,CN=Bachman Machine,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Bachmanmachine,DC=com for store CN=Mailbox Store (MAIL),CN=First Storage Group,CN=InformationStore,CN=MAIL,CN=Servers,CN=BACHMAN,CN=Administrative Groups,CN=Bachman Machine,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Bachmanmachine,DC=com in routing tables with timestamp 9/1/2010 11:01:18 AM. Recipients will not be routed to this store.
0
 
LVL 70

Expert Comment

by:Qlemo
ID: 34479226
This question has been classified as abandoned and is being closed as part of the Cleanup Program.  See my comment at the end of the question for more details.
0

Featured Post

PeopleSoft Has Never Been Easier

PeopleSoft Adoption Made Smooth & Simple!

On-The-Job Training Is made Intuitive & Easy With WalkMe's On-Screen Guidance Tool.  Claim Your Free WalkMe Account Now

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to install and use the NTBackup utility that comes with Windows Server.
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question