How can I fix this IE issue?

Please see the attached 2 images. The combo box is working fine in Firefox without border. but in IE it shows the borders. I want hide the border any way. Can you help?

I attached the css code also

Working fine

 IE Issue file
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Select</title>
    <style>
.textbox {
	float:right;
	background: #233f43;
	color: #FFFFFF;
	text-transform: uppercase;
	font-weight: bold;
	padding: 1px 3px 1px 3px;
	margin: 60px 20px 0px 0px;
	*padding: 0px 3px 0px 3px;
	*margin: 50px 30px 1px 0px;
	border: 0px solid #B2B2B2;
	-moz-border-radius: 6px;
	cursor: pointer;
}
  </style>

</head>

<body style="background-image:url(images/backgrounds/main.jpg); background-repeat:no-repeat;>
			<form name="frmLang">
			<select onChange="redirect()" name="lang" class="textbox" >
			<option value="english" selected="selected" >English</option>
			<option value="german" >German</option>
			<option value="korean">Korean</option>
			<option value="spanish" >Spanish</option>
			</select>	
			</form>
</body>
</html>

Open in new window

LVL 36
Loganathan NatarajanLAMP DeveloperAsked:
Who is Participating?
 
hehdaddyConnect With a Mentor Commented:
Since the OS handles the rendering of dropdown boxes in IE, I've always had a terrible time getting them to style. I am eager to see if one of the other experts has a solution. My gut feeling is that this is something that you won't be able to overcome - at least across different versions of IE on different Windows OS versions.
0
 
ajisasaggiCommented:
Remove "solid #B2B2B2" and try.
0
 
Loganathan NatarajanLAMP DeveloperAuthor Commented:
i tried.. same result again??
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
ajisasaggiCommented:
Actually I dont see the border on IE7. What version are you using?
0
 
Loganathan NatarajanLAMP DeveloperAuthor Commented:
@ ajisasaggi : I am using IE6

0
 
StephanConnect With a Mentor Lead Software EngineerCommented:
0
 
Loganathan NatarajanLAMP DeveloperAuthor Commented:
Kindly suggest me some other solution also.

I need to have language switcher behind the background transparent.

Just see it.
0
 
ajisasaggiConnect With a Mentor Commented:
IE6 does not support styling of dropdown elements. And I think the same is true for IE7.

I am using IE8 which allows this.
0
 
Loganathan NatarajanLAMP DeveloperAuthor Commented:
@ stephanonline

interesting, i will check
0
 
Geek_NabilConnect With a Mentor Commented:
The Form elements are not Native Web Elements, they are influenced greatly by the Browser and OS,

http://swatelier.info/at/forms/selectExp.htm

In the document above, is a good solution, but as mentioned it is not tested on Linux or Mac.
0
 
MorrisprojectCommented:
Try adding this to the CSS

* html select.textbox {border:none;}
0
 
Loganathan NatarajanLAMP DeveloperAuthor Commented:
mm, not working still
0
 
Geek_NabilConnect With a Mentor Commented:
The Form elements are not Native Web Elements, they are influenced greatly by the Browser and OS, you will not be able to style them as you need.

My Advice is to replace the combo box with a small dhtml menu to select the language, you can make it look better than the combo box and it will be standard in all browsers and OS.'

If you need help with the code of the dhtml menu, please do mention it.
0
 
Loganathan NatarajanLAMP DeveloperAuthor Commented:
thanks to all
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.