Solved

Outlook setup with Exchange 2010

Posted on 2010-08-24
16
647 Views
Last Modified: 2012-05-10
I am having issue setting up an account in Outlook 2007 with a new Exchange 2010 server. When I go to control panel -> Mail to setup the Exchange account, after entering name/email address/password, I could to 1) Establish network connection and 2) Search for test.user@testdomain.com server settings. However, I kept getting the username/password prompt and eventually the error message:

"The action cannot be completed. The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action."

I am able to login and send/receive emails with the account via OWA, which means there's no AD or  password issue here. I could go thru the first 2 steps during the setup which means autodiscover is working fine. So what makes it keep prompting the login box and fail to authenticate?

P.S. I also ran the Outlook Autodiscover option from Remote Connectivity Analyzer on the Exchange 2010 server and the test completed successfully.
0
Comment
Question by:wesdeneo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 2
  • +3
16 Comments
 
LVL 9

Expert Comment

by:Dan Arseneau
ID: 33514774
If you look at the prompt, does it return a server name?  It may be trying to authenticate against Exchange 2007 Public Folders.
0
 
LVL 4

Expert Comment

by:mrbrain646
ID: 33514782
https://www.testexchangeconnectivity.com/
try this and check your ssl certficates
0
 
LVL 16

Expert Comment

by:uescomp
ID: 33514812
open outlook and have it detect the account automatically vs setting it up via control panel.  If you are prompt for a username/password check to see if there are any saved passwords. To check those open run command and type: control userpasswords2 > click advanced tab > managed passwords, clear the passwords (if any).  Otherwise try typing your domain name in front of the username if prompt.

Example Username:  Domain\uescomp
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 

Author Comment

by:wesdeneo
ID: 33514837
@DanArseneau: Yes, it is showing the right server FQDN

@mrbrain646: Yes, that's the site where I ran the Microsoft Office Outlook Connectivity Tests with Outlook Autodiscover option. The SSL certificate was installed just yesterday and is showing valid from the test.
0
 

Author Comment

by:wesdeneo
ID: 33514877
@uescomp: There is no saved passwords as this is a new AD user created in the test domain. I tried using domain\username then got the aforementioned error message:


"The action cannot be completed. The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action."


If I don't include the domain, it just keeps prompting the login window
0
 
LVL 9

Expert Comment

by:Dan Arseneau
ID: 33514894
Tools - Account settings - Change... - More settings... - Connection - Outlook Anywhere checkbox.

Enabled?
Click on the Exchange Proxy Settings... button

Remove "only connect to proxy servers that have this principal name in their certificate".

I had this issue a while back and it helped with Outlook 2007
0
 

Author Comment

by:wesdeneo
ID: 33515165
@DanArseneau: Just tried. This time it gives me a "Your server or mailbox names cannot be resolved"

Also when I click on "Check Name", I can see the Account Settings window in the background showing the new Exchange Server account (my other accounts in Outlook are POP/SMTP), but for some reason it's just not authenticating (even though OWA works perfectly fine).
0
 
LVL 9

Expert Comment

by:Dan Arseneau
ID: 33515183
Change the NTLM authentication to Basic and see if that helps.  It may be set that way on the server.  Not recommended but possible.
0
 
LVL 16

Expert Comment

by:uescomp
ID: 33515636
either that or check your services and make sure exchange services are running (possible reboot).  I would also double check authentication as DanArseneau pointed out.
0
 

Author Comment

by:wesdeneo
ID: 33515987
Just checked Outlook Anywhere settings on Exchange server, it was set to NTLM. I set it to basic and use basic on my Outlook end but still no cigar.

for some reason Exchange is able to authenticate via OWA but not Outlook, what gives?
0
 

Author Comment

by:wesdeneo
ID: 33516402
Also, just for kicks, I tried setting up connection with the same account using either POP or IMAP. In both cases they worked. This should eliminate the possibility with the exchange certificate problem.
0
 
LVL 9

Expert Comment

by:Dan Arseneau
ID: 33516744
Start - Run - fixmapi and hit Enter.
0
 
LVL 11

Expert Comment

by:JuusoConnecta
ID: 33522303
To verify everything go to exchange management shell and type the following for a user who's name cannot be resolved:

test-outlookwebservices -identity firstname.lastname@domain.com | fl (or ft -autosize) and post your results here.

In outlook when setting up a new profil, instead of using autodiscover choose "Manually set-up". When you come to the field where you enter exchange server name and a username choose more settings and do the following -> Security tab -> make sure to mark "Encrypt data between microsoft office outlook and microsoft Exchange" and "logon network security is set to "Negotiate Authentication".

Under connection -> Outlook Anywhere -> Mark "Connect to microsoft Exchange using HTTP: -> click exchange proxy settings -> in connection settings typ in (after https:) webmail.yourdomain.com (the webmail address that is..) -> mark "Connect using SSL only -> Mark "Only connect to proxy servers that have this principal name in their ceritifcate -> and type : msstd:webmail.yourdomain.com -> set authentication to Basic,

cheers
0
 

Accepted Solution

by:
wesdeneo earned 0 total points
ID: 33523167
I found the solution for my own problem from this blog post:

http://messagexchange.blogspot.com/2008/12/outlook-anywhere-failing-rpc-end-points.html

Basically I receive the exact same RPC error from the second screenshot. Applied the registry fix, reboot and it's good to go.

0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 34680052
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Active Directory security has been a hot topic of late, and for good reason. With 90% of the world’s organization using this system to manage access to all parts of their IT infrastructure, knowing how to protect against threats and keep vulnerabil…
After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question