Solved

How to restore factory defaults on Cisco 1811 router

Posted on 2010-08-24
25
2,587 Views
Last Modified: 2012-05-10
I've been configuring a Cisco 1811 router and I'm pretty sure I messed it up, so I went to restore the factory defaults. I followed this set of instructions (fronm Cisco's site):

Method 1

This method uses the config-register 0x2102 command in global configuration mode.

   1.

      Check the configuration register on the router by issuing the show version command.

      The configuration register setting is displayed in the last line of the show version command output and should be set to 0x2102. If this is not the case, enter the config-register 0x2102 command once in global configuration mode.

          router#configure terminal
          router(config)#config-register 0x2102
          router(config)#end
          router#

      If the show version command is issued again, the same line in the command output will have '(will be 0x2102 at next reload)' appended to the current register setting.
   2.

      Erase the current start-up configuration on the router with the write erase command.
   3.

      Reload the router with the reload command. When prompted to save the configuration, DO NOT save.

          router#reload
          System configuration has been modified. Save? [yes/no]: n
          Proceed with reload? [confirm]

      Once the router reloads, the System Configuration Dialog appears.

                   --- System Configuration Dialog ---
          Would you like to enter the initial configuration dialog? [yes/no]:

      The router is now reset to the original factory defaults.

I got to the line that said " Would you like to enter the initial configuration dialog? [yes/no]:" and I quit otu of the hyperteminal as I wanted to do the configuration via the web interface (as I don't really understand the command line yet). The problem is the router isn't giving any ip addresses. I tried the default address (10.10.10.1) but that didn't work. If I do an ipconfig on the computer attached to the router it gets an invalid ip address (169.245.128.180) even though the computer is plugged into the router via cat 5 cable.. My question is how can I reset the router so that I can access the web portal (10.10.10.1)?
0
Comment
Question by:FreeRangers
  • 10
  • 7
  • 2
  • +3
25 Comments
 

Author Comment

by:FreeRangers
ID: 33515480
Now the computer isn't even acknowledging that a cable is plugged (yes, bot the cable and nic card on the computer work, I have tested this possibility).
0
 
LVL 3

Expert Comment

by:JNL2000
ID: 33515726
You need to connect via the blue cable.

Bypass the IP and the ethernet altogether.  You need to telnet into the device and configure it that way.  Once it is configurable you need to configure a lan port and then you can connect via ethernet cable.  The rest should be pretty easy.
0
 
LVL 33

Expert Comment

by:Todd Gerbert
ID: 33515739
I would run through the initial configuration dialog, it should prompt you for just a couple things - one of which will be an IP address, then you can set your PC's IP address manually to one in the same range (i.e. make the router 192.168.1.1 and your PC 192.168.1.2).  Then you should be able to use the web interface.
0
 
LVL 33

Expert Comment

by:Todd Gerbert
ID: 33515755
...incidentally, you can erase the configuration by issuing the command "write erase" - the instructions above should really only be necessary if you don't know the login/enable passwords.
0
 

Author Comment

by:FreeRangers
ID: 33515878
I tired to go through the initial configuration dialog and the only IP it asked me for was the ip address given by my ISP (as it had that ip in brackets)
0
 
LVL 33

Expert Comment

by:Todd Gerbert
ID: 33515921
It's easy enough to do by hand...
router>enable

router#configure terminal

router(config)#interface fastethernet0/0

router(config-if)#ip address 192.168.1.1 255.255.255.0

router(config-if)#no shutdown

router(config-if)#exit

router(config)#end

router#write memory

Open in new window

0
 

Author Comment

by:FreeRangers
ID: 33516672
ok so I did that and configured a static ip in the same range on the computer, but the computer still won't acknowledge that a network cable is plugged in (again both the cable and nic card on the computer work).
0
 
LVL 2

Expert Comment

by:fs40490
ID: 33518381
What does the interface itself show when you do a show interface command?

I believe that you may have run into an issue with the cable you are using.  While I know that you state it is a good cable and I agree, but is the cable a crossover cable?  When connecting 2 end devices directly together you need a crossover cable.  You could connect a switch between the two devices with two good straight throughs to accomplish the same thing.
0
 

Author Comment

by:FreeRangers
ID: 33521696
here is the out ptu of a show interface command (the results for fast ethernet 2-9 were the same so I just posted the results for FE2)

Async1 is down, line protocol is down
  Hardware is PQUICC3 Serial in async mode (TTY1)
  MTU 1500 bytes, BW 9 Kbit/sec, DLY 100000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation SLIP, loopback not set
  DTR is pulsed for 5 seconds on reset
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 6 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

FastEthernet0 is up, line protocol is up
  Hardware is PQ3_TSEC, address is xxxx.xxxx.xxxx (bia xxxx.xxxx.xxxx)
  Internet address is 192.168.0.1/24
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Half-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:06, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     14 packets output, 840 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
FastEthernet1 is administratively down, line protocol is down

  Hardware is PQ3_TSEC, address is xxxx.xxxx.xxxx (bia xxxx.xxxx.xxxx)
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto Speed, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

FastEthernet2 is administratively down, line protocol is down
  Hardware is FastEthernet, address is xxxx.xxxx.xxxx (bia xxxx.xxxx.xxxx)
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto-speed
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

Vlan1 is administratively down, line protocol is down
  Hardware is EtherSVI, address is xxxx.xxxx.xxxx (bia xxxx.xxxx.xxxx)
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 2 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
0
 

Author Comment

by:FreeRangers
ID: 33521703
one more thing the cable is a straight through cable, and the only thing connected to the cisco router is a computer (using straight through cable)
0
 
LVL 33

Expert Comment

by:Todd Gerbert
ID: 33521728
Your cable is plugged into FastEthernet0?
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 

Author Comment

by:FreeRangers
ID: 33521749
The cable from my modem is. The computer is plugged into number 9. I supposed I should have stated tat in my last post.
0
 
LVL 33

Expert Comment

by:Todd Gerbert
ID: 33521778
Then you need to configure an ip address on that interface (my example above assumed FastEthernet0 was connected to your computer, change it to FastEthernet9).
0
 
LVL 33

Expert Comment

by:Todd Gerbert
ID: 33521814
These commands should remove the IP address from eth0, and assign one to eth9.
router>enable

router#configure terminal

router(config)#interface fastethernet0/0

router(config-if)#no ip address

router(config-if)#shutdown

router(config-if)#exit

router(config)interface fastethernet0/9

router(config-if)ip address 192.168.0.24 255.255.255.0

router(config-if)no shutdown

router(config-if)exit

router(config)#end

router#write memory

Open in new window

0
 

Author Comment

by:FreeRangers
ID: 33522487
So I enter this line:
router(config-if)ip address 192.168.0.24 255.255.255.0

and I get the following message:
Ip addresses may not be configured on L2 links

what does this mean? I tried to continue on but I'm still not getting an ip address.
0
 

Author Comment

by:FreeRangers
ID: 33524337
This probably isn't a good idea (that's why I'm posting here for advice before I do anything), but would I be able to take the flash memory out of the cisco router plug it into a computer (via flash card adapter) and delete every file on the flash card. Then find the default files (presumably from cisco's website) put them on the flash card and have the router work like when I first took the router out of the box (get ip address and web interface without having to do any pre configuration, I just plugged in a cat 5 cable and was able to start set up).
0
 
LVL 2

Expert Comment

by:fs40490
ID: 33524466
I would not go that route at this time.

So after removing the IP from FE0/0 what does it show when you do a sho interface?

Is the cable that you are connecting from the router to the modem a cross over or a straight through?

The problem that you have with the FE0/9 is that it is not a routed interface it is part of the integrated switch.

0
 
LVL 33

Expert Comment

by:Todd Gerbert
ID: 33524490
Post your entire configuration as it is now.
0
 

Author Comment

by:FreeRangers
ID: 33524736
Running Config:

Current configuration : 1484 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname *host name*
!
boot-start-marker
boot-end-marker
!
enable secret 5 *password*
enable password *password*
!
no aaa new-model
!
!
dot11 syslog
no ip routing
!
!
no ip cef
!
!
!
multilink bundle-name authenticated
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
 no cdp enable
!
interface FastEthernet1
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
 no cdp enable
!
interface FastEthernet2
 shutdown
 no cdp enable
!
interface FastEthernet3
 shutdown
 no cdp enable
!
interface FastEthernet4
 shutdown
 no cdp enable
!
interface FastEthernet5
 shutdown
 no cdp enable
!
interface FastEthernet6
 shutdown
 no cdp enable
!
interface FastEthernet7
 no cdp enable
!
interface FastEthernet8
 shutdown
 no cdp enable
!
interface FastEthernet9
 shutdown
 no cdp enable
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Async1
 no ip address
 encapsulation slip
 no ip route-cache
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
line 1
 modem InOut
 stopbits 1
 speed 115200
 flowcontrol hardware
line aux 0
line vty 0 4
 password *password*
 login
!
no process cpu extended
no process cpu autoprofile hog
end
0
 
LVL 28

Accepted Solution

by:
mikebernhardt earned 500 total points
ID: 33545509
Do this, for now:
interface vlan1
 ip address 192.168.0.24 255.255.255.0
 no shut
interface f9
 no shut

Plug you computer into port 9 with a straight-through cable and it should work fine. You will of course have to give your PC an IP address in the same range.

The VLAN interface is a virtual interface tied to the LAN ports on the router. Before doing the above, you could also try this, but I don't know if it will work on that router:

interface f9
 switchport
  ip address 192.168.0.24 255.255.255.0
  no shut
0
 
LVL 28

Expert Comment

by:mikebernhardt
ID: 33545528
Oops, sorry! That final config suggestion should be
interface f9
 no switchport  <-- note the "no"
  ip address 192.168.0.24 255.255.255.0
  no shut

If you want the oother ports to be available for your LAN, then you should configure the VLAN interface anyway, so skip the "no switchport" business and do it as suggested at the top of my last post.
0
 

Author Comment

by:FreeRangers
ID: 33545532
That worked! Thanks!
0
 
LVL 22

Expert Comment

by:Jody Lemoine
ID: 33545540
This can be confusing as there are two definitions of "factory default" in play here.  Traditionally, Cisco routers had to have their original configuration done via the serial console.  If you completely erase (or disable via setting the configuration register) the startup configuration, this is where you'll be... no IP address, no web access, no telnet access.  If you want to get the the newer "factory configuration" that let's you configure via web, that's a bit different.  From a privileged mode prompt, issue a "dir flash:" command and look for a ".cfg" file.  Copy that to the startup configuration using the "copy flash:cpconfig.cfg startup-config" (replacing cpconfig.cfg with the file from the directory listing) and reboot.  That will put you back to the configuration you  had when you opened the box.
0

Featured Post

Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

Join & Write a Comment

If your business is like most, chances are you still need to maintain a fax infrastructure for your staff. It’s hard to believe that a communication technology that was thriving in the mid-80s could still be an essential part of your team’s modern I…
PRTG Network Monitor lets you monitor your bandwidth usage, so you know who is using up your bandwidth, and what they're using it for.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now