Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

terminal server rdp user cant run exe file

Posted on 2010-08-24
8
Medium Priority
?
1,569 Views
Last Modified: 2013-11-21
When a user RDP's in, He needs to run Sage Accounts Production, The programme is an (exe), when I ran the program it tries to open the suddenly closes. If I give the user administrator rights it works OK.

How can I get this file to run as a user?
As far as I am aware I have checked the permissions (left them everyone full access) Removed Windows 7 internet security which somebody suggested.

Thanks in advance
0
Comment
Question by:raisedcrazy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 8

Accepted Solution

by:
ConUladh earned 400 total points
ID: 33515923
Any other security software installed? If it was a permissions issue I would expect an error message to that effect.

You could try turning Data Execution Prevention off as a test.

Edit c:\boot.ini so that /noexecute=alwaysoff (make sure you change it back if its not the cause)
0
 

Author Comment

by:raisedcrazy
ID: 33515952
thanks trying now
0
 
LVL 8

Expert Comment

by:ConUladh
ID: 33515997
That's a long shot though.. do you have any other security software installed?
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 

Assisted Solution

by:memoman
memoman earned 400 total points
ID: 33516043
I would check both NT and Share permissions. You mentioned you checked one, but maybe not the other?

I can't see the solution to this one, but you may want to check out: http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_23469127.html

Also, another potential source of the issue may be this:
When you right click the affected file, and choose Properties, you see a security message at the bottom of the window that reads:

Security:
This file came from another computer and might be blocked to help protect this computer.

Maybe you downloaded the file or copied it from another computer on your network and now Microsoft says you are not allowed to access it. You just need to click Unblock button which is next to the above information.

0
 
LVL 17

Assisted Solution

by:Spike99
Spike99 earned 400 total points
ID: 33516357
I have never used Sage Accounts, but we have seen a similar issue with Sage AccPac.  The solution is to give the user FULL rights to the HKLM\Software key and all subkeys for the program on the terminal server and to give the users MODIFY rights to the local program folder on the TS & the network share where the program data is stored.

Here's the article on sage's site about these permissions:
http://kb.accpac.com/cgi-bin/sagesoftwareonline2.cfg/php/enduser/std_adp.php?p_faqid=20424

Alicia
0
 
LVL 16

Assisted Solution

by:Brian Pringle
Brian Pringle earned 400 total points
ID: 33517819
There is also a "feature" in Windows called "Data Execution Prevention", or DEP for short.  It is possible that it is preventing the execution.

- Right-click "My Computer" or "Computer" and click "Properties".
- Click "Advanced System Settings"
- Click the "Advanced" tab
- Click the "Settings" button under the "Performance" section.
- If the option is selected for "Turn on DEP for all programs and services except those I select:", click the "Add" button.
- Browse to the executable and click "OK".

This will add the program to the list of programs that are not checked before running.  
0
 
LVL 2

Assisted Solution

by:DavidGerald
DavidGerald earned 400 total points
ID: 33520884
I have got round issues with sage line 50 reports on terminal server by creating a new administrative windows account, set it to deny remote logon and make sure its rights only extend as far as that server.  Create a shortcut on the users TS desktop to the sage exe file but in the target put C:\Windows\System32\runas.exe /savecred /user:<domain>\<newadminaccount> "X:\Program Files (x86)\Common Files\Sage\<sage.exe>"

This will run sage under an admin account, the password will be saved on first run and should resolve your issue.

Spike99 mentioned registry fix, I do vaguely remember many year ago a similar issue with sage and having to give fulll access to a number of user hive registry keys.
0
 

Author Closing Comment

by:raisedcrazy
ID: 33625140
Thanks Chaps...
0

Featured Post

Ask an Anonymous Question!

Don't feel intimidated by what you don't know. Ask your question anonymously. It's easy! Learn more and upgrade.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The environment that this is running in is SCCM 2007 R2 running on a Windows 2008 R2 server. The PXE Distribution point is running on its own Windows 2008 R2 box. This is what Event viewer showed after trying to start the WDS service:  An erro…
Remote Apps is a feature in server 2008 which allows users to run applications off Remote Desktop Servers without having to log into them to run the applications.  The user can either have a desktop shortcut installed or go through the web portal to…
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question