Emails not being delivered to comcast or aol when relaying from iis through exchange 2003

Ok I have a quandry.

Emails sent to aol or normally go through without a hitch from our exchange server. tested and works fine.

The issue arises when i have to relay an email from the webserver through the exchange server.

below is some of the code i use. it works when sending to any other domain, like gmail, but not aol and comcast.

can someone shed some light on this?
SmtpClient myClient2 = new SmtpClient("", 110);
        myClient2.UseDefaultCredentials = false;
        myClient2.Credentials = new System.Net.NetworkCredential("", "password");

Open in new window

Who is Participating?
innotionentConnect With a Mentor Author Commented:
I figured it out.
i had pickupfromiis set instead of network.
after i changed that it started to work fine.
Barry GillChief of StaffCommented:
what do your logs say?

Also, as these two machines are both behind your firewall (I assume) then does resolve to a local address for the weserver? if not, then a firewall rul may be preventing traffic from your network being bounced against it and redirected to back inside your network.

Another thing to check is are the messages being delivered by Exchange? do they get into a queue? Is comcast blocking them? thi can be found from the logs.

Can you confirm that your server is allowing basic authentication from the webserver IP address?
innotionentAuthor Commented:
I will check the logs to see what is going on.

Mail goes out from the webserver to gmail, yahoo and our mailserver and other mailservers just fine.

It's AOL and Comcast that's the issue.
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

Barry GillChief of StaffCommented:
they have their own specialist RBL's and some unique handling requirements
innotionentAuthor Commented:
I think my issue is that even though I'm specifying the smtp server. it's still putting headers from the mail server.

i need to send from the mail server exclusively
Barry GillChief of StaffCommented:
sorry, I misread that as "you send to gmail etc through the smarthost already just aol/comcast don't get it"
do you want to send one to me at barrulus at outies dot co dot za and I will have a look at the headers?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.