Export table in mysql using sql query

Posted on 2010-08-24
Last Modified: 2012-05-10

I am using MySQL Workbench 5.2 OSS to view and when necessary, remove records from a table via SQL Statements.

I am trying to run the statement below to export all records from a table named master_rate_records as a text file with the same name, but it is telling me there is an error in my SQL syntax (error code 1604).

I've tried to reword it a few times with no luck. I figured it was time to ask the experts.

Thanks in advance!
SELECT * FROM master_rate_records
  INTO OUTFILE 'master_rate_records.txt'
          ENCLOSED BY '"'
          LINES TERMINATED BY '\n'

Open in new window

Question by:McFoxx
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2

Author Comment

ID: 33517060
I tried the following and it was able to export a file.... however I was expecting something arounf the range of 100MB, I only got a 70K file with only the first 1000 lines. Is this some sort of limit I can bypass?

Thanks in advance!
INTO OUTFILE 'C:\\master_rate_records.txt'
FROM master_rate_records

Open in new window

LVL 60

Expert Comment

by:Kevin Cross
ID: 33517118
None that I know of (limits on OUTFILE), but I did notice after loading the new Workbench there is a limit to the rows returned ... let me see if I can track down where to change it.
LVL 60

Accepted Solution

Kevin Cross earned 150 total points
ID: 33517128
Okay, I am not losing my mind. If you go to Edit --> Preferences, click on SQL Editor tab of Workbench Preferences, you will see a section towards the bottom called Query Results. The first check box in this section is Limit Rows and it was checked by default on my installation with a row count of 1000 so you should see something similar.  

Uncheck the limit rows box or arbitrarily increase the 1000 to some other value.

Author Comment

ID: 33522802
mwvisa1, thanks a ton!

It worked, the query has been running for a few minutes now, so I know it's doing it's thing.

Thanks for your help!

Featured Post

DevOps Toolchain Recommendations

Read this Gartner Research Note and discover how your IT organization can automate and optimize DevOps processes using a toolchain architecture.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Access Report formatting issue 5 71
T-SQL: Please describe what a page split is 5 57
Display info from DB to Label in 7 44
These days, all we hear about hacktivists took down so and so websites and retrieved thousands of user’s data. One of the techniques to get unauthorized access to database is by performing SQL injection. This article is quite lengthy which gives bas…
As technology users and professionals, we’re always learning. Our universal interest in advancing our knowledge of the trade is unmatched by most industries. It’s a curiosity that makes sense, given the climate of change. Within that, there lies a…
Video by: Steve
Using examples as well as descriptions, step through each of the common simple join types, explaining differences in syntax, differences in expected outputs and showing how the queries run along with the actual outputs based upon a simple set of dem…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question