keep NIC on after shutdown / disable power management

I'm trying to keep my NIC on after the computer is shut down to allow for Wake On Lan.  I have confirmed that Wake On Lan works if I put the computer into Sleep mode.  I have WOL enabled in the BIOS.  I have WOL set to "Magic Packet" in Device Manager --> Network Adapter.  What is not working whatsoever is disabling the Power Management for the adapter.  No matter how many times I uncheck "Allow the computer to turn off this device to save power", once I shut down the computer the NIC is offline.  When I boot back up again that box is checked.  The other two boxes in Power Management remain checked and greyed out after I uncheck that one ("Allow this device to wake the computer" and "Only allow management stations to wake this computer").  (Also, setting "Shut Down Wake-On-LAN to 'disabled" appears to grey out "allow this device to wake the computer").

I have searched and MS only references this problem twice in their KBs:  once regarding USB device (KB930312) and disable power management for network adapters in XP (KB837058).  I have tried the latter option, editing the registry value for PnPCapabilities to be 38.  This had no affect on my adapter and it remained off when I shut down my computer.  Wake On LAN  does not work after shutdown, and there are no lights on the NIC when shut down.  

My ultimate goal here is to be able to turn my computer on remotely when it is shut down.  Any free method (does not have to be magic packet) would work.  I'm aware LogMeIn Pro can do this but I was looking for something free.  Why does Vista not honor my settings and keep turning my network adapter off?

Vista x64 SP2
NIC: Realtek PCIe GBE Family Controller w/latest drivers
Dell Studio 540
wirbicki2Asked:
Who is Participating?
 
KenneniahConnect With a Mentor Commented:
It wasn't meant to be condescending and snarky, but I do see why it would come across that way therefore I apologise for the wording.

Bottom line however is that no setting in Windows affects anything during the power off state after a shutdown. You do have the system BIOS, but there is also a BIOS in the network card. With Intel, while booting up look for the Intel Boot Agent message to show up shortly after turning on your computer. Try CTRL-S to access it's BIOS settings at that time.
0
 
DarrylHadfieldCommented:
Pardon my ignorance, but how would you know that your NIC is without power entirely, unless you're using a WOL-enabled initiator to send the magic packet to it?

To the best of my knowledge, WOL is established within the BIOS of a motherboard, regardless of whether or not your NIC is on-board or whether it's an add-on card.

Disabling WOL within the OS will only take effect if it's in sleep mode.  What you're doing doesn't really seem to make sense to me - I think perhaps I'm misunderstanding.

What is your desired end result?  Just to power on your machine, when you're out of town or across the city or something?  To be honest, I'd question the value of even shutting down the machine at all..  set the video to go dark, set the HDD to spin down after a period of inactivity, but let the machine stay awake - you can hit the system remotely without having to boot it up.  Teamviewer is one way to access the system remotely (although it won't power up your machine).

I don't know if the Studio 540 supports it, but you could check the BIOS to see if it supports other methods of remote power-up.
0
 
Jackie ManCommented:
According to the advice of  bhiga, the information below may be useful for you.

"I had this problem when I had Symantec Endpoint Protection's firewall installed and it took me a long time to figure it out.

If you have a third-party firewall software installed, try uninstalling it. Disabling the firewall was not enough for me. It had to be uninstalled.

I believe this is because SEP installs an additional network driver (Teefer2 miniport) that intercepted the WoL packets and did not allow them through to the OS. I'm not sure if this is how other firewall software works, but it might be the case.

After uninstalling the firewall component and using the default Windows Firewall, WoL works perfectly for me. "

Source: http://forum.wegotserved.com/index.php/topic/10640-wake-on-lan/
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
wirbicki2Author Commented:
@DarrylHadfield:

"Pardon my ignorance, but how would you know that your NIC is without  power entirely, unless you're using a WOL-enabled initiator to send the  magic packet to it?"

The lights on the NIC are off  completely, and WOL does not work when it's shut down.  It DOES work when the computer is asleep.

"To the best of my knowledge, WOL is established within the BIOS of a  motherboard, regardless of whether or not your NIC is on-board or  whether it's an add-on card."

Yes I have it enabled in the BIOS, and also confirmed the settings on the adapter properties in device manager.  WOL works, as I said, but only when the computer is in sleep mode, not shut down.

"What is your desired end result?  Just to power on your machine, when you're out of town or across the city or something? "

The desired end result is to be able to power my machine back on (even if completely shut down) if I am away from it.  I was out of town recently and I guess there was a power surge here.  My APC UPS gracefully shut down my computer when the UPS had 5 minutes of battery left.  I want to be able to power my machine back on from a remote location if that happens.  I also have "resume from AC interrupt" also enabled in the BIOS, but I don't believe the scenario described above would qualify as AC interrupt, since the machine gets shut down.

0
 
wirbicki2Author Commented:
@jackieman:

I only have the Vista firewall enabled.  Nothing else.  There is no other adapter listed in Control Panel --> Network Connections.  If I do ipconfig /all from a command prompt, I see my Realtek controller, and "Teredo Tunneling Pseudo-Interface", but I believe the latter is part of Vista.
0
 
KenneniahCommented:
You do realize that when your computer is shutdown, Windows is not running don't you? No settings within Windows can affect the behavior of your computer when it's shuttdown. It works while in sleep mode, because memory has not been cleared at that point so technically Windows is still loaded. When shutdown, there is nothing in system memory.

Your only options are going to be settings in BIOS. Wake on LAN is only for waking from sleep. The only option would be under Power Management for remote power on, which I'm not sure if your BIOS supports. You could check with Dell for an updated BIOS.
0
 
DarrylHadfieldCommented:
Honestly, I'd just take off the UPS management - not the UPS itself, just the management.. so that when power dies, the UPS continues to power the system, and when the UPS finally runs out of battery power (if it does) then the system will hard 'off' - and when the power comes back, it'll resume.

Other options are going to be pricey.
0
 
wirbicki2Author Commented:
@Kenneniah:

"You do realize that when your computer is shutdown, Windows is not running don't you?"

Wow.  How incredibly condescending and snarky.  

"No settings within Windows can affect the behavior of your computer when it's shuttdown."

That is why I came here.  I enabled the only setting in BIOS that applied and it didn't work.  I wasn't sure if there was anything else I could try.  I will see if there is updated BIOS.  From what I'm reading you also must have the card configured correctly, which is NOT just in the BIOS.
0
 
wirbicki2Author Commented:
@DarrylHadfield:

I will consider that.  I enabled UPS shutdown to prevent corrupt/dirty file system if not properly shut down.
0
 
DarrylHadfieldConnect With a Mentor Commented:
Agreed...  certainly a good idea, and the whole point of the UPS management software to begin with.

That said, there are also ways to mitigate that - not the least of which is an external USB drive that would likely be much more resilient regarding loss of power.

The question then begs to be asked.. Does your UPS mgmt software allow for power-up when power resumes?  I know some (Cybertron is one I looked at a few months ago) allow for an additional device that jacks into a serial port, which in turn lets the UPS toggle the system to power back on, after it's been gracefully shut down..
0
 
wirbicki2Author Commented:
@Kenneniah:  Thanks I will take a look at that.  I think I did see the Intel Boot Agent as one of the options in the BIOS startup list but it was disabled.  I'll enable it and see what settings there are within the card's BIOS.

@DarrylHadfield:  It doesn't look like the APC PowerChute has any options for power-up, but I'll browse their forums.
0
 
KenneniahCommented:
Oops, it's a Realtek not Intel. Not sure if it has configurable settings or not.

For example though, on our Optiplexes the needed setting is in system BIOS under Remote Wakeup. If your BIOS doesn't have something along those lines it just might not be supported on that motherboard. In that case Darryl's advice might be the only option.
0
 
KenneniahCommented:
I need to pay more attention :P  I focused on the "Allow the computer to turn off....." setting. The other settings such as "Shut Down Wake-On-Lan" since they are driver based, not Windows and can modify the BIOS of the NIC most likely do affect power off situations.
Today has not been my day for reading comprehension, speaking well etc. Anyone have a method for starting the day over?
0
 
DarrylHadfieldCommented:
A sharp rap to the base of the skull will knock you out quite nicely, and when you wake up, you can start over.

Course, you're gonna need a heck of a Tylenol as a part of THAT process! ;)
0
 
KenneniahCommented:
It might work :)  Maybe a better choice would be to actually get some sleep tonight and hope my brain works better tomorrow. For now, I'm just telling people to ignore anything I said or did today.
0
 
wirbicki2Author Commented:
@Kenneniah::

OK so I got into the NIC BIOS; no options there really just various PXE boot options.  In the motherboard BIOS, I did double-check and I have "Remote Wake Up" enabled...

But It doesn't specifically say "Wake up from S5" (shut down) as described in this Intel article:

http://www.intel.com/support/network/sb/cs-008459.htm

So I guess if the Remote Wake Up enabled in my BIOS doesn't do it then I'm screwed and buying a new NIC wouldn't help right?
0
 
DarrylHadfieldCommented:
Correct.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.