Solved

oracle_install_question

Posted on 2010-08-24
26
818 Views
Last Modified: 2013-12-21
I want to install oracle 11g R2 on solaris x 86 server by logging in remotely using SSH.
I login in from my PC using windows 2000 pc and vpn.

In the oracle install manual, it says:
NOTE: Unless you intend to complete a silent-mode installation, you must install the software from an X window system workstation, an X terminal, or a PC or other system with X server software installed.

What does this mean. Do i need to install some software on my PC or the solaris server to get this X window interface.
0
Comment
Question by:sam15
  • 14
  • 9
  • 3
26 Comments
 
LVL 4

Accepted Solution

by:
mhenry20 earned 500 total points
ID: 33517784
Hi,

It means you need to either configure VNC for solaris or install an X server on your PC.  I use Cygwin X server.  It worksd well enought to install Oracle.  You need to set your DISPLAY environment variable to your PC IP address.  Run cygwin x x server on your pc.  When you run runinstaller.sh it will open a X window on your PC.

You can test your x server by runing xterm or xclock on solaris.  If they work and open a terminal or a clock on your PC then it is working.

You can get Cygwin via open source for free.

Good Luck.
0
 

Author Comment

by:sam15
ID: 33517905
Do you mean download the setup.exe on this page and install it on the windows 2000 PC?

http://x.cygwin.com/

How does this work. you run x server locally on the PC but the oracle installer is on the server. You call the oracle installer exe file on the server using x window program on the pc?
0
 
LVL 4

Expert Comment

by:mhenry20
ID: 33521723
Yes you run the setup.exe on that page.  You then select install from internet, give it a directory or take the default, local package directory, direct connect.  

Choose a download site.
Select Packages:
click default next to X11
Select required Packages.

Run the X server on your PC by running the startxwin.bat batch file in the cygwin\bin directory where you installed cygwin.  You should get an xterm window and a tray icon with a X.  This will indicate that X windows server is running.

In the xterm window you may want to run: xhost databaseserverip

This will add the database server ip to your allowed list so it can connect to your PC.


You run the cygwin X windows server on your PC.  When you run the Oracle installer (runinstaller.sh) it connects to the X server on your PC as indicated in the DISPLAY environment variable on the database server.  The installer will display on your PC as a X windows application.  Once you get to that point it is pretty straight forward.

Good look.
0
 
LVL 1

Expert Comment

by:tcorliss
ID: 33523829
Another Windows client for xwindows is:  xming, you will also need to install xming font package.
0
 

Author Comment

by:sam15
ID: 33526787
I tried your instructions for isntalling cygwin and it did not work.

I ran the setup and it create a folder SSH under program files.
There was SSH application only .

When i installed an i got to the packages list I only saw one package which is ghost scipr.t
I could not see X11 you mentioned.

Is this the right link for download or am i missing something?
0
 
LVL 4

Expert Comment

by:mhenry20
ID: 33526922
http://cygwin.com/setup.exe Is the setup I run.

When you choose to install from the internet you should get window listing a bunch of packages with X11 listed as the last package.  If you click the word default next to the package name it should change to install.

I think your link is correct.  I have tried to add some images to help.
Capture.PNG
Capture2.PNG
Capture3.PNG
0
 

Author Comment

by:sam15
ID: 33527395
I am not on that pc now but when i try your link on windowsv vista it works like you say.
I tried installing from internet first on windows 2000 but it was not doing much, so i did it from local disk.
It did not list any of the packages i see now.
I will try tomorrow again and show you the screens if there was issues.

thanks a lot,
0
 

Author Comment

by:sam15
ID: 33532769
itdid not seem to work.
The install took  almost 1 hours. is this normal.

See the screens attached. At the end I got a small erro about scripts.

I also tried to run "startxwin.bat" and i got an error. see screen attached.

Do you seem some problem. what do you suggest.
0
 

Author Comment

by:sam15
ID: 33532784
i forgot to attach the file. here it is
cygwin.doc
0
 

Author Comment

by:sam15
ID: 33533291
interesting it seems cgywin is the only free X window out there. I as wondering if it is not compatble with windows 2000 but it seems it is.

http://cds.dl.ac.uk/cds/interface_and_utilities/xwindows.html
0
 
LVL 1

Expert Comment

by:tcorliss
ID: 33533492
As I mentioned earlier:

Another Windows client for xwindows is:  xming, you will also need to install xming font package.

This is free and easy to use.  Works fine on Windows XP, so it should also work fine on Windows 2000.
0
 

Author Comment

by:sam15
ID: 33533730
You mean this software and it can run the oracle installer remotely?

http://sourceforge.net/projects/xming/

I tried to install it and it says the program requires windows NT 5.01 or later.
0
 
LVL 4

Expert Comment

by:mhenry20
ID: 33534061
An hour seems pretty long.  I think for me it took around 20-30 minutes.  The install looks normal though from your screen prints.  I have the same messages.  You might see if you have XWin Server program in your program files.  I just notices on my new install it is actually running C:\cygwin\bin\run.exe /usr/bin/bash.exe -l -c /usr/bin/startxwin.exe.  This is what my Start-Programs shortcut for X win looks like.

It couls just be a problem with the startxwin.bat file.  Normally cygwin installs to c:\cygwin.  You could try copying the entire contents of your c:\Program Files\OPenSSH to there and see if that cures the problem.
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 

Author Comment

by:sam15
ID: 33536579
you are a genius

I did what you said. Start/programs/Cygin-X/X server and i see a terminal window.
It is running
exe /usr/bin/bash.exe -l -c /usr/bin/startwin

I ran "xterm" and i saw another window open up.
I ran "xclock" and i see a clock. Does this mean everything is working now?

You said I have to set the environment variable DISPLAY on the oracle server Do i ssh via putty and run this?
export DISPLAY = mypcipaddress.

Then i run the runinstaller.sh under /bin in the putty/ssh session and the oracle installed will run in my windows x server?

0
 
LVL 4

Expert Comment

by:mhenry20
ID: 33536865
Hi,

You set display on the server via putty like:

export DISPLAY=mypcipaddress:0.0

Notice the addition of :0.0 on the end.  This indicates which X server instance.  0.0 is the usual value.  If you hoover over the X icon in your PC's task tray it should display something like "Cygwin/X server:0.0"  that will tell you for sure which instance.  You almost garaunteed that it would be :0.0 though.

Yes you run the runinstaller.sh in putty/ssh and it will open a connection back to your PC.  You can also test X by running xclock on the solaris server.  It should popup a clock on your PC desktop.  That will validate your DISPLAY setting.

If you have problems you can try turning X11 tunneling on in your putty settings.  It is under connection->ssh->tunnels.  If you do this then the display setting will be set for you to localhost and you won't need to set it.  You only do one or the other set DISPLAY to your pc address or tunnel X11 in putty but not both.

Good luck
0
 
LVL 4

Expert Comment

by:mhenry20
ID: 33536887
Hi,

Also if you get a connection refused message when you try to run an x application in putty you need to run xhost serveripaddress on your pc's xterm window.  That will add the server as an allowed X host.

0
 

Author Comment

by:sam15
ID: 33537525
i tried to test the xclock as i do nto have oracle there yet.

I did set the DISPLAY variable on the server to my ip address with :0.0 too.
But the xclock would not run. is not part of the solari O/S.
is there other tests i can do for graphical programs.

# xclock
ksh: xclock:  not found
# csh
test1# xclock
xclock: Command not found
test1# bash
# xclock
bash: xclock: command not found
# echo $PATH
/sbin:/usr/sbin:/usr/bin:/usr/ucb:/usr/ccs/bin:/usr/local/bin:/opt/VRTSob/bin:/u                              sr/symcli/bin

0
 
LVL 1

Expert Comment

by:tcorliss
ID: 33537604
Open Two putty sessions:

putty as root
cd /usr/openwin/bin
./xhost +

open second putty session as oracle
DISPLAY=ip_address_of_windows_client_not_unix_server:0.0
export DISPLAY
cd /user/openwin/bin
./xclock

cd staging directory
cd /export/home/10.2_64/database

$ ORACLE_BASE=/export/home/oracle
$ ORACLE_SID=test1
$ export ORACLE_BASE ORACLE_SID

$ unset ORACLE_HOME
$ unset TNS_ADMIN

./runInstaller

per 363436.1 ignore error or run
./runInstaller -ignoreSysPrereqsn
0
 

Author Comment

by:sam15
ID: 33537773
I cant login to server using root. it seems blocked. I log in using my account and then su as root
I found the xclock program but it seems the display cant route it back.

does this have to do with client x wndow configuration or something on server blocks traffic or VPN on  client.
NOTE: oracle manual says configure tthe security settings of the X server software to permit remote hosts to display X applications on the local system.

 what do i need to do.

I got my op address from going to command prompt and typing ipconfig.

# pwd
/export/home/mtc
# export DISPLAY=10.10.100.100:0.0
# xclock
ksh: xclock:  not found
# cd /usr/openwin/bin
# pwd
/usr/openwin/bin
# ./xclock
Error: Can't open display: 10.10.100.100:0.0 # ./xhost
./xhost:  unable to open display "10.10.100.100:0.0"
0
 
LVL 4

Expert Comment

by:mhenry20
ID: 33538230
You need to run xhost serveripaddress on the PC.

For example
If the solaris server IP is 1.1.1.1
and the pc IP is 2.2.2.2

Then on the PC you start Xserver and in the window that opens you type:
xhost 1.1.1.1

Next putty ssh to the Solaris server:
# export DISPLAY=2.2.2.2:0.0
# /usr/openwin/bin/xclock

The clock should display on your pc and the solaris will just sit there  waiting for the xclock program to end.


If that doesnt work I would try the putty X11 forwarding.
0
 

Author Comment

by:sam15
ID: 33538322
thanks, i will do this in the morning as i left the office.
I will try the domain (www.xxx.com) since i do not have server ip address. if it does not work, i will use
hostname | nlslookup.

hopefully the server clock will show up and mission accomplished.

have a good night.
0
 

Author Comment

by:sam15
ID: 33543043
I did what you suggested but got this message
Error: Can't open display:1.1.1.1:0.0

Is there a way to figure out why.

How do i try the putty x11 forwarding.
0
 
LVL 4

Expert Comment

by:mhenry20
ID: 33546945
To try Putty X11 Forwarding you open putty ssh and go to the configuration pane.  Expand Connection->SSH->X11.  Check the Enable X11 forwarding checkbox.  In the X-Display location if it does not autofill enter localhost:0.  Save the settings for this session and connect to the solaris.

Logged into Solaris and see if xclock works.

I do not have to change my DISPLAY variable at all when I do the tunnel.  It should be set to something like localhost:10.0.

here is an image of what my Putty settings look like:


PuttyX11.PNG
0
 

Author Comment

by:sam15
ID: 33547194
I do not see a save option for X11 in putty. There is an open button.
I check the box and enter localhost:0 and then select the session tab abd open the host.
is there a way after you log in to check that x11 is enabled?

I did also try this without settin DISPLAY and with it and it cant find the display. do you see anything wrong.

# echo $DISPLAY

# cd /usr/openwin/bin
# ./xclock
Error: Can't open display:
# export DISPLAY=localhost:10.0
# ./xclock
Error: Can't open display: localhost:10.0

# ./xclock
Error: Can't open display: localhost:10.0
# export DISPLAY=localhost:10.0.
# ./xclock
Error: Can't open display: localhost:10.0.
#
0
 
LVL 4

Expert Comment

by:mhenry20
ID: 33547443
Click on the session category and then you can save it.

To check the setting (or set it again) after you have a session open you right click the title bar and select "Change Settings..."
0
 

Author Comment

by:sam15
ID: 33655145
sorry for delay. I was on travel.
your answers were excellent. I still di not have this working.
I will post another question though.
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

Background In several of the companies I have worked for, I noticed that corporate reporting is off loaded from the production database and done mainly on a clone database which needs to be kept up to date daily by various means, be it a logical…
Using SQL Scripts we can save all the SQL queries as files that we use very frequently on our database later point of time. This is one of the feature present under SQL Workshop in Oracle Application Express.
This video shows, step by step, how to configure Oracle Heterogeneous Services via the Generic Gateway Agent in order to make a connection from an Oracle session and access a remote SQL Server database table.
Video by: Steve
Using examples as well as descriptions, step through each of the common simple join types, explaining differences in syntax, differences in expected outputs and showing how the queries run along with the actual outputs based upon a simple set of dem…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now