Solved

Reporting Services Error - Team Foundation Server 2010

Posted on 2010-08-24
13
4,988 Views
Last Modified: 2013-11-27
Hey,

I am having an issue with Team Foundation Server 2010 and what appears to be the reporting services. I only know the bare minimum about TFS and how it works with Visual Studio so I really need some help here.

From what I understand, my client creates a new project via VS and once he completes everything and goes to browse the project portal he is presented with this error: (see attached file for actual screenshot)

Reporting Services Error
An error has occurred during report processing. (rsProcessingAborted)
Query execution failed for dataset 'dsProjectGuid'.
For more information about this error navigate to the report server on the local machine, or enable remote errors

Are you able to point me in the right direction?
error.png
0
Comment
Question by:kibatsu
  • 4
  • 3
  • 2
  • +1
13 Comments
 
LVL 18

Expert Comment

by:Dennis Aries
ID: 33518634
According to Microsoft (Lukasz Pawlowski):
"This, unfortunately, is a known issue.  The problem is that if you are viewing the report and then you update it, there is some metadata which needs to be rebound when you press the View Report button.  This doesn't get rebound correctly.  

The solution is to navigate back to the folder containing the report and run it again."
A cause might be that the user has no access to the required reports:
*Right-Click on the report server and select properties.
*Under general select "Enable my reports folder for each user" option.
*Then select the appropriate role from the drop down list.(Remember the user you want is in this member role group)
 
Sometimes the problem solves itself somehow and the problem is gone in a day.

 
0
 
LVL 2

Author Comment

by:kibatsu
ID: 33518684
Hey thanks for getting back to me. Just a quick question, you say to "Right-Click on the report server and select properties."
Where would I find said "report server"?
0
 
LVL 18

Expert Comment

by:Dennis Aries
ID: 33518932
In your SQL Management Studio, connect to 'reporting services', then right-click on your server.
 
0
 
LVL 16

Expert Comment

by:13598
ID: 33521725
Look at someone resolved the issue:
In our case the error turned out to be a missing permission on the reporting services user account. The reporting services account requires "Log On Locally" on the tier running reporting services. Adding the user to the administrators group also grants this permission, which could explain why that change also resolves the problem.
Also if it used to work and now it doesn't: did the user password change?
0
 
LVL 16

Expert Comment

by:13598
ID: 33521966
I also found this as a workaround although it doesn't seem to work for everybody but it is worth the try. Make sure to restart the services (and if you can the server) after making this change:
Is the identity that you're using to access reports/view the project portal configured as a TFS Content Manager in Reporting Services?

Try this: go to the reporting services interface, mine is hosted here [http://<myreportserver>/Reports]

Click on the "Properties" tab.
Click on "New Role Assignment"

Add the identity you're using and assign it the TFS Content Manager role.  
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 2

Author Comment

by:kibatsu
ID: 33528878
Hey guys,

Thanks for your responses!

@djjaries
- I made the change and asked the user to test, but received the same error in the portal.

@13598
- Are you able to elaborate on the first answer?
- I went to that location, but there was no properties tab...
0
 
LVL 16

Expert Comment

by:13598
ID: 33531564
Since you mention you couldn't find the tab I will assume that you are referring to my second post. This should help you (I extracted it from here: http://msdn.microsoft.com/en-us/library/bb552341.aspx )  :

To grant permissions in Team Foundation Server
1.Open the Global Groups window by performing one of the following sets of steps:
If you are using Team Explorer:
1.In Team Explorer, connect to the server that is running Team Foundation Server and for which you are setting permissions.
2.Right-click the server, point to Team Foundation Server Settings, and then click Group Membership.
3.In the Global Groups window, click Server\Team Foundation Administrators, and then click Properties.
4.In Add member, click Windows User or Group, and then click Add.
5.Type the account name of the user whom you want to add to the Team Foundation Administrators group, and then click OK twice.
6.Click Close to close the Global Groups window.
If you are using the administration console for Team Foundation:
1.Open the administration console for Team Foundation.
For more information, see Open the Team Foundation Administration Console.
2.Expand the server, and then click Application Tier.
3.In the Administrative Console Users section, click Add.
4.In Add Team Foundation Server Administration Console User, type the user account that you want to add as a member of Team Foundation Administrators.
If you are not sure of the alias, click Search. You can also expand the Advanced Features section and modify the selections for Add required permissions to create collections and Add required permissions to change service accounts as best suits your operational needs and the security requirements for the user whom you are adding.
5.When you are satisfied with your selections, click OK.
6.Review the progress information in the Add Administration Console User window.
7.(Optional)When the process completes, click the link to open the log file.
8.Click Close to return to the administration console.
0
 
LVL 2

Author Comment

by:kibatsu
ID: 33554997
Thanks 13598,
This has already been filled out correctly, double checked to make sure.
Also just tested as Administrator and am getting the same error... maybe this isn't an authentication thing?
0
 
LVL 23

Expert Comment

by:Admin3k
ID: 33599393
If you are the TFS admin,try granting the user running the Task Burndown report , as well as the TFS service accounts the needed permissions on reporting services  and sharepoint using the TFS admin tool.
0
 
LVL 2

Accepted Solution

by:
kibatsu earned 0 total points
ID: 33658583
Hey guys,
I had to get MS Support to actually investigate this for me, they managed to rectify the issue. Here is their summary.


Hi Daniel,

As we discussed in the live meeting, here is the summary of your problem and what I did in the live meeting,

1.      At the very beginning, we found the following error is reported when we accessing the reports,

processing!ReportServer_0-9!c1c!09/05/2010-20:46:33:: e ERROR: Throwing Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: , Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: Query execution failed for dataset 'dsProjectGuid'. ---> System.Data.SqlClient.SqlException: Invalid object name 'GetProjectNodeInfoFromReportFolder'.

2.      I checked the report UDL file you sent to me, and I found the report will retrieve data from SQL engine as parameters of the reports and the query for it to retrieve data is,

        SELECT TOP 1 p.ProjectNodeGUID, p.ProjectNodeName FROM
        (
                SELECT ProjectNodeGUID, ProjectNodeName, 1 AS RowRank FROM GetProjectNodeInfoFromReportFolder(@ReportPath)
                UNION
                SELECT '00000000-0000-0000-0000-000000000000' AS ProjectNodeGUID, 'missing' AS ProjectNodeName, 0 AS RowRank
) p ORDER BY p.RowRank DESC

However, when the report server tried to retrieve data from database, it found the function GetProjectNodeInfoFromReportFolder does not exist in the data source stored in report server. After checking, I found the report used shared data source TfsReportDS and TfsOlapReportDS. However, the connection string for both shared data source disappeared. I suspect that the encryption key for the reporting service was deleted and caused all encryption data lost.

3.      Then I involved TFS engineer in the case and checked the configuration of their existing environment which is similar as yours. In their environment, I found the initial catalog for data source TfsReportDS is Tfs_Warehouse and the initial catalog for data source TfsOlapReportDS is Tfs_Analysis. We re-configured the connection string and credential information. After that, the reports is back to normal and we could reports in MOSS site.

As we discussed, I will proceed to close this case, thanks for your kind assistance in this case. I hope you are overall satisfied with the service and support.

Best regards,
Peter
0
 
LVL 23

Expert Comment

by:Admin3k
ID: 33665792
Glad your problem is solved, and thanks for sharing the MS solution with us,this is why Microsoft advises to backup the Reporting services encryption key during Migration scenarios, I would consider this is a first time for me to see what could go wrong when this key is lost .
Best Of luck
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

JSON is being used more and more, besides XML, and you surely wanted to parse the data out into SQL instead of doing it in some Javascript. The below function in SQL Server can do the job for you, returning a quick table with the parsed data.
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Via a live example, show how to shrink a transaction log file down to a reasonable size.
Viewers will learn how to use the UPDATE and DELETE statements to change or remove existing data from their tables. Make a table: Update a specific column given a specific row using the UPDATE statement: Remove a set of values using the DELETE s…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now