Solved

Error when running "Set-ReceiveConnector" on my exchange 2007 server.

Posted on 2010-08-25
7
883 Views
Last Modified: 2012-05-10
I'm trying to increase the size of messages on one of the connectors and I get the below, what am I doing wrong?

[PS] C:\Windows\System32>Get-ReceiveConnector | fl Id*

Identity : FP-SERVER1\Default FP-SERVER1
Identity : FP-SERVER1\Windows SBS Fax Sharepoint Receive FP-SERVER1
Identity : FP-SERVER1\Windows SBS Internet Receive FP-SERVER1

[PS] C:\Windows\System32>SET-SENDCONNECTOR -IDENTITY FP-SERVER1\Default FP-SERVE
R1 -MaxMessageSize 31457280
Set-SendConnector : A parameter cannot be found that matches parameter name 'FP
-SERVER1'.
At line:1 char:18
+ SET-SENDCONNECTOR  <<<< -IDENTITY FP-SERVER1\Default FP-SERVER1 -MaxMessageSi
ze 31457280

0
Comment
Question by:tribz
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
7 Comments
 
LVL 8

Expert Comment

by:Mkris9
ID: 33519005
Is Default FP-SERVER1 the name of the send connector that you want to change message size limits ? because, Get-ReceiveConnector | fl Id* gets the receive connectors, not send connectors
0
 
LVL 1

Author Comment

by:tribz
ID: 33519042
Thanks thats put me partly on track. I've set the Send connector now with the max message size. What would be the command for setting the receive connector on FP-SERVER1 and Windows SBS Internet Receive FP-SERVER1 above?
0
 
LVL 27

Expert Comment

by:shauncroucher
ID: 33519057
SET-SENDCONNECTOR -IDENTITY "FP-SERVER1\Default FP-SERVER1" -MaxMessageSize 31457280

You need to put the name in " "

Shaun
0
Backup Solution for AWS

Read about how CloudBerry Backup fully integrates your backups with Amazon S3 and Amazon Glacier to provide military-grade encryption and dramatically cut storage costs on any platform.

 
LVL 1

Author Comment

by:tribz
ID: 33519066
Isnt that for the send connector and not the receive connector?
0
 
LVL 8

Expert Comment

by:Mkris9
ID: 33519081
Set-ReceiveConnector -identity Default FP-SERVER1 -MaxMessageSize 30MB
0
 
LVL 8

Accepted Solution

by:
Mkris9 earned 500 total points
ID: 33519086
sorry its Set-ReceiveConnector -identity "FP-SERVER1\Default FP-SERVER1" -MaxMessageSize 30MB
0
 
LVL 1

Author Comment

by:tribz
ID: 33519098
Thanks, had to wrap it on quotes but worked fine.

Think I was a bit to close to this to see the obvious! Cheers
0

Featured Post

Free eBook: Backup on AWS

Everything you need to know about backup and disaster recovery with AWS, for FREE!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question