• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1251
  • Last Modified:

IBM Lotus Designer 8.5.1 is very very slow in opeing design elements

It has been several months since we have installed LN 8.5.1 and I have being having a big problem with developer’s productivity due to the performance of LN 8.5.1.

Workstation power has nothing to do with this since we have even tried quad processor PC's and still are very slow.


It has become so serious that we are thinking of reverting back to LN 7.2

Please advise if there are any tweaks available to make the client run faster or if there is a way to remove eclipse which seems to make it slow down.
0
Inteliscape
Asked:
Inteliscape
1 Solution
 
MtnChickCommented:
Have you installed the fix packs?  I believe there are four and they have solved some isses I've experienced with 8.5
0
 
doninjaCommented:
0
 
larsberntropCommented:
For heavy users, the XMS parameter needs to be set as well, see comments on linked article.

An other very important step in maintaining speed is the use of "Working sets".

Create working sets for each application and it's templates.  It's very easy to switch on/of different sets.

Explanation:
If you "Remove" a database representation from the navigator, you also remove all the helper files the designer has created.  When reopening the database, this all has to be recreated => slow process

When you use working sets to manage the navigator, Domino Designer can refresh it's representation instead of rebuilding it => fast process

Another tip:  if you have Project:Build Automatically turned on, Domino Designer checks the entire design for errors, this of course will slow you down on a big new db.  Turn it off if needed.

cheers, let us know if this helps you!
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
QuinFCommented:
I was at 8.5.1 FP4 and just installed 8.5.2 today.  MUCH Better.  Try upgrading.
0
 
jmaritzCommented:
Mine was also very slow even after making changes to memory settings.
The problem was the working sets, it creates local files in your workspace directory called Data\workspace\.metadata\.plugins\org.eclipse.core.resources\.projects , if you delete a working set and do not remove the database in that working set individualy it keeps the files. After removing all my working sets I still had database in the root of my designer applications view. I then deleted all the projects in the folder above. Restarted my designer client and now it is flying. But you have to remember to remove databases from your working sets before deleting the working set. Also make sure that there is no working sets in the data\workspace directory that you have removed before, domino creates a directory for each working set.
0
 
InteliscapeAuthor Commented:
I need to try it out for a few days and will let you know if i still find it heavy and slow.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now