Solved

mailbox unavailable. the server response was 5.7.1 unable to relay for

Posted on 2010-08-25
30
1,581 Views
Last Modified: 2013-11-30
I'm running windows server 2003. I have three web sites configured on the server and I have POP3 and SMTP running. I can send email from only one web site. When I try to send email from the other 2 sies the email fails to mailbox unavailable. the server response was 5.7.1 unable to relay for emailaddress. Here's the smtp log file:
#Software: Microsoft Internet Information Services 6.0
#Version: 1.0
#Date: 2010-08-25 12:50:52
#Fields: time c-ip cs-method cs-uri-stem sc-status
12:50:52 209.195.152.229 EHLO - 250
12:50:52 209.195.152.229 AUTH - 535
12:50:52 209.195.152.229 MAIL - 250
12:50:52 209.195.152.229 RCPT - 550
12:50:52 209.195.152.229 QUIT - 240

Can anyone help.
Thanks
0
Comment
Question by:whiwex
  • 12
  • 10
  • 8
30 Comments
 
LVL 6

Expert Comment

by:fluk3d
ID: 33521429
You need to add the Public IP you are using on your website to the SMTP protocol so it has authority to relay.
0
 
LVL 6

Expert Comment

by:fluk3d
ID: 33521467
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 33521475
On your smtp server go to relay options and allow the ip of your website server to relay there.. if the web server is on a different server than the smtp server, and their are both on the internal network, allow the internal ip of the web server on the smtp.. if you are using smtp on IIS open the IIS console, go to smtp and on properties go to relay and allow the ip.. also you can test from web server to smtp server running this command:

telnet smtpservername 25

and post result if needed
0
 

Author Comment

by:whiwex
ID: 33521787
in properties IIS>Default SMTP Virtual Server>Access>Relay I have only the list below checked and in the list I have
127.0.0.1
192.168.2.60 which is my server address\
Do I need to add my internet address 209.195.152.229  also.
0
 
LVL 6

Expert Comment

by:fluk3d
ID: 33521824
Yes
0
 

Author Comment

by:whiwex
ID: 33522001
I added the ISP's address and it is working. Is this going allow others to us me as a relay?
0
 
LVL 6

Expert Comment

by:fluk3d
ID: 33522010
No only that list of IP's are allowed to relay.
0
 
LVL 6

Expert Comment

by:fluk3d
ID: 33522025
if  you are not confident with that you can run a open relay test

http://www.mailradar.com/openrelay/
0
 

Author Comment

by:whiwex
ID: 33522124
I ran the test and three of them failed. I'm not sure what they mean. Here is one of them:
[Method 14]
<<< 220 ctcg1.ctcg.online.server.com Microsoft ESMTP MAIL Service, Version: 6.0.3790.4675 ready at Wed, 25 Aug 2010 10:35:34 -0400
>>> HELO mailradar.com
<<< 250 ctcg1.ctcg.online.server.com Hello [193.230.245.6]
>>> MAIL FROM: <antispam@[209.195.152.229]>
<<< 250 2.1.0 antispam@[209.195.152.229]....Sender OK
>>> RCPT TO: <mailradar.com!relaytest>
<<< 250 2.1.5 mailradar.com!relaytest@ctcg1.ctcg.online.server.com
>>> QUIT
<<< 221 2.0.0 ctcg1.ctcg.online.server.com Service closing transmission channel
[TEST NOT PASSED]
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 33522126
Only that external ip, which i assume is the external ip of your web server, will be allowed to relay
0
 
LVL 6

Expert Comment

by:fluk3d
ID: 33522139
^ Please post a screenshot of your relay settings
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 33522155
the test failed because he used your smtp server to send to mailradar.com domain... you must configure your smtp server to allow relaying only to your smtp domain.. for example domain.com.. he should not be able to relay to other smtp domains... do this on the smtp options in IIS
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 33522178
>>> RCPT TO: <mailradar.com!relaytest>

recipient of destiny that he uses when connecting to your smtp server is mailradar.com.. he should get relay denied.. configure smtp domain in iis
0
 

Author Comment

by:whiwex
ID: 33522232
The 209.195.152.229 is the static IP address that my ISP gave me. The IP address of the web server is 192.168.2.60

My relay settings are grant access to
192.168.2.60
127.0.0.1
209.195.252.229

I figure out how to do a screen shot.
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 33522293
under smtp virtual server, in IIS, you have "Domains"

what do you have configured there?
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 
LVL 6

Expert Comment

by:fluk3d
ID: 33522313
that should be suffice - I would not worry about being an open relay please see greatVargas post above to see why those relay tests failed.

i tried them on my machine as well and they failed due to the fqdn name of my smtp server however still not an open relay.
0
 

Author Comment

by:whiwex
ID: 33522479
GreatVargas do you mean domains under default smtp virtual server?
If so I have the my three web site domain names and the server name which is
ctcg1.ctcg.online.servercom and also this
12ce9265-31f4-41e6-9f1d-b675f89004e4._msdcs.ctcg.online.server.com
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 33522538
the mails that the web site sends have which destination domain? @domain.com.. whats the domain.com? also see what you have configured right clicking domains and going to properties...
0
 

Author Comment

by:whiwex
ID: 33522664
The 3 web sites configured are
stalsmanna.com
aquinasacademyscrips.com
helpthemlearnandplay.com
All three send mail.
I'm not sure where to find Domains to right click the properties
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 33522967
under smtp virtual server you have domains.. if you right click there you dont have properties option? they send mails to where? random mail addresses? and they send mails as what username/mail?
0
 

Author Comment

by:whiwex
ID: 33523081
No I don't have a properties when I rgiht click default virtual server.
They send mail to numerious email address each web site one has a admin@domainname and a customerservice@domainname
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 33523147
ctcg1.ctcg.online.server.com

ehats this domain name? why is it there? if you dont know.. remove it.. restart the smtp server... teste the mails sent by the site.. and test the open relay link and post the results please...
0
 

Author Comment

by:whiwex
ID: 33523646
I can't delete it. When I right click it I have no option to delete it?
ctcg1.ctcg.online.server.com is the full computer name of my server
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 33523836
does your mail server uses authentication? if so you can disable anonymous on the smtp server and enable authentication...

i checked the problem on your server and what happens is:

mail from can be any address, the server does not rejects it.. because it has anonymous (you can check if i'm right)

mail to can only be one of the accepted domains you have configured (@accepteddomain)..

so what can happen here? you can get spam sent be anonymous authenticating on your servers... this can cause only internal spam and i dont think that can put you on mail RBL's.. my advice is for you to do one of two thinks:

1- understand why does your web server gets to the smtp server by the external ip.. arent they both on the internal network?
if you can understand why maybe you can remove that external ip from the relay allowed list
2- see if your web server can authenticate on the smtp server and remove the anonymous...

option 3 is leave everything as is.. it shouldnt be much of a problem and if you need to go as anonymous and identified with external ip to the smtp server there's nothing else you can do
0
 

Author Comment

by:whiwex
ID: 33524251
When I unckeck anonymous my email fails to :
The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.3 Client was not authenticated

0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 33527090
Ok.. thats normal.. if you want to enable authentication you need to work on the site code.. on the email form of the site.. either you do it on the code or leave everything as is..
0
 
LVL 6

Expert Comment

by:fluk3d
ID: 33527091
Your setting are fine the test failed because of your help tagline
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 33527098
or you can try and find why the internal ip is not enough for authentication on the smtp server
0
 

Author Comment

by:whiwex
ID: 33527327
What do you mean by the help tagline.

Also the smtp server and the web server are on the same server
0
 
LVL 15

Accepted Solution

by:
GreatVargas earned 500 total points
ID: 33527686
try and remove the external ip address and add the 127.0.0.1 and see if it works like this.. what smtp server ip do you have on the code? the external? if they are on the same server is not normal that you need the external ip to relay there
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Microsoft Outlook is not just an email client but it is full featured Personal Information Manager. But sometimes Outlook gets disconnected and you simply can’t access it. What steps can you perform before calling IT support? In this article we will…
Granting full access permission allows users to access mailboxes present in their database. By giving full access permission one can open and read the content of any mailbox but cannot send emails from that mailbox.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now