Solved

How to Enter DNS Settings on a Win2k3 Server

Posted on 2010-08-25
56
442 Views
Last Modified: 2012-05-10
Hi Experts
My Question is about DNS
I inherited a small network with the following configuration
Win2k3 Server >>> Running Active Directory
Dell Power Connect Switch
SMC (Comcast) Router / Switch      
12 Users / PC’s
2 Networked Printers
      
The workstations configuration is as follows
IP: 192.168.0.1  
Sub: 255.255.255.0
Gateway: 192.168.0.2
DHCP: 192.168.0.100
DNS:  68.87.73.242  >>>> This is set manually

My Question is, why are the workstations set to DHCP but have a manual entry for DNS?

The Sever has 2 Nics and only 1 is plugged in.

Could someone help me check the DNS settings running on the Server and what should be plugged into what with settings?

Thank you in advance
0
Comment
Question by:1williamquinn
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 30
  • 10
  • 10
  • +4
56 Comments
 
LVL 24

Expert Comment

by:Mike Thomas
ID: 33521396
1 NIC is fine

"My Question is, why are the workstations set to DHCP but have a manual entry for DNS?"
Who knows

|Really the clients should be looking at your server for DNS (configured vua dhcp) and your DNS server can be configured to forward requests to 68.87.73.242 (for internet name resolution)

0
 
LVL 1

Expert Comment

by:michiele
ID: 33521433
Ok dns is set to an external ip address (68.87.73.242 ). This is probaly becoude the root (.) domain still exist within your DNS server. You can safely delete this zone so DNS will use its root hints to resolve dns requests.

Regards,
Michiel
0
 
LVL 10

Expert Comment

by:c_a_n_o_n
ID: 33521483
To check the server's DNS Server settings
Start > Administrative Tools > DNS

To check the servers DNS settings
Start > Control Panel > Network Connections > (select the active network card) > Press proteries button
On the General tab > scroll to Internet Protocol (TCP/IP) > Press the properties button
There are your settings

As for the why, I have seen this case where the workstations are DHCP from a large network, and on that large network there is another domain that doesn't offer DHCP, however the network resources from the servers would not be accessible if the DNS entries were not manually added since those servers on the domain were not added to the large network's DNS servers.  
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 
LVL 23

Expert Comment

by:Stelian Stan
ID: 33521484
Go to your DHCP server -> Scope -> Scope Options -> Configure Options -> 006 DNS Server and the IP Address for your DNS server, click OK and you should be good to go.
0
 
LVL 10

Expert Comment

by:c_a_n_o_n
ID: 33521534
You could also try to set the DNS on a workstation to "Obtain DNS server address automatically" and press OK to see the results.  May be as simple as that.
0
 
LVL 27

Expert Comment

by:Steve
ID: 33522063
Firstly, the server is fine on one NIC. the ability to use a 2nd NIC is often used for failover or teaming. Also often used when the server is a firewall (EG ISA server) but none of this would be worth you worrying about so ignore the 2nd NIC.

The reason why all the PCs have a manual IP set for DNS is usually laziness. A problem probably existed at some point in the past and the administrator either didnt know how to fix it or couldnt be bothered.
The DNS on a domain is usually the Domain controller and the domain controller deals with the external DNS server.
I would recommend chancing it to this but be cautious as you do not know why this was implemented i the first place.

I'd set a couple of PCs to pick the DNS up by DHCP and point to the server's IP. Check these PCs work OK before applying it to the rest, just in case....
0
 

Author Comment

by:1williamquinn
ID: 33523573
I set one of the workstations to DHCP (Obtain an IP address automatically)
+
Obtain DNS server address automatically
The IP provided/ obtained is in the correct range (192.168.0.1)
However the DNS is (192.168.0.100) and will not let me out to the internet

I can browse the network by name >>> run >>> //Server     or     //workstation 2
0
 
LVL 27

Expert Comment

by:Steve
ID: 33523995
is .100 your server runnign DNS?

change DHCP to give out the IP of your server as DNS.
0
 
LVL 71

Accepted Solution

by:
Chris Dent earned 250 total points
ID: 33524310

> However the DNS is (192.168.0.100) and will not let me out to the internet

You need to shift your focus to that server for a few minutes then.

Have you defined Forwarders? By default it will use Root Hints, so if you have Forwarders defined and it is not working, take them out. For reference, you'll find Forwarders as follows:

1. Open the DNS console
2. Right click on your server
3. Select Properties
4. Select the Forwarders tab

Global forwarders are listed under "all other DNS domains".

If you do not have Forwarders configured, expand Forward Lookup Zones and see if you have a zone called ".", if you do, delete it. This one is quite unlikely.

Finally, if none of that gets anywhere you will have to look at the network level. TCP/IP configuration on the server. After that it'd need you to look at any Router / Firewall you have configured on your network.

Chris
0
 

Author Comment

by:1williamquinn
ID: 33531029
The Win2k3 Server has a static IP of 192.168.0.100
I can check the forwarders later today when on site
Update- I found some dated screen shots of the server configuration.
At one point the Server had the following TCP IP Settings
Connection Main\ 1  >>> Network Adapter
192.168.0.100
255.255.255.0
192.168.0.2
DNS 192.168.0.100

Local Area Connection 2  >>> Network Adapter
192.168.0.101
255.255.255.0
192.168.0.2
DNS 192.168.0.100
      
Currently the Server only has 1 Network Card active with the cable going into the switch
0
 

Author Comment

by:1williamquinn
ID: 33531556
Question:  When the workstations are set to Obtain DNS server address automatically and I receive the 192.168.0.100 is this a DNS Forwarding issue or DHCP ?
0
 
LVL 24

Expert Comment

by:Mike Thomas
ID: 33531581
When your clients are set to automatic they get whatever your dhcp is set to hand out, forwarders are configured on the DNS server in the console under the forwarders tab, the dns server will forward requests it cannot resolve to the DNS servers you have specified.


0
 

Author Comment

by:1williamquinn
ID: 33531766
Thank you, so when entering the information into the DNS Forwarders, what IP am I adding ?
The SMC (ISP) Router 192.168.0.2 or the DNS it has on its configuration page 68.87.73.242

Will this affect the internal name resolution of the printers and workstations?
0
 

Author Comment

by:1williamquinn
ID: 33541740
Hi Experts
Hoping to get some advice regarding my last question

Thank you
0
 
LVL 71

Expert Comment

by:Chris Dent
ID: 33541798

> Thank you, so when entering the information into the DNS Forwarders, what IP am I adding ?

I reckon 68.87.73.242 although it shouldn't make a lot of difference.

> Will this affect the internal name resolution of the printers and workstations?

It shouldn't. They should only refer to the internal DNS server as well, but they are not aren't they?

Chris
0
 

Author Comment

by:1williamquinn
ID: 33542251
Thanks Chris
I have not had the chance to look at the Server >>> the DNS forwarders

Re-cap
When I set the workstations to …..
Obtain DNS server address automatically
The IP provided/ obtained is in the correct range (192.168.0.1)
However the DNS is (192.168.0.100) and will not let me out to the internet

I can browse the network by name or use >>> run >>> //Server     or     //workstation 2

0
 

Author Comment

by:1williamquinn
ID: 33542335
Additional information,
I discovered this configuration situation when I tried to add a Netgear Router as an Access Point.

The wireless clients were able to connect to the Access Point / Router (With DHCP Off)
and get a valid IP but got the same DNS as the wired workstations.
I tried to plug the Access Point directly into the SMC (ISP) router with no change
0
 
LVL 71

Expert Comment

by:Chris Dent
ID: 33542415

On your server, please run:

nslookup www.google.com 192.168.0.100

That's the server's IP address isn't it?

We need to know if it's DNS service is able to resolve names or not.

Chris
0
 

Author Comment

by:1williamquinn
ID: 33542761
Thanks Chris

Yes the server is 192.168.1.100

0
 
LVL 71

Expert Comment

by:Chris Dent
ID: 33542778

And the command results? :)

Chris
0
 

Author Comment

by:1williamquinn
ID: 33542781
Will run nslookup ....
0
 

Author Comment

by:1williamquinn
ID: 33543047
Hi Chris
I am not on site but had someone type the command for me/us
The results (nslookup is not a recognized ….)

0
 
LVL 71

Expert Comment

by:Chris Dent
ID: 33543095

eh? Well... nslookup is part of *every* Windows installation, so either they broke the installation, or mis-spelt nslookup :)

Chris
0
 

Author Comment

by:1williamquinn
ID: 33543204
Only on a Friday ¿
 Let’s try this again

The first command with only ns lookup typed  >>>
             Server1(companyname.net) 192.168.0.100
The full command with nslookup www.google.com >>>>
           Server1(companyname.net) 192.168.0.100 DNS Timed Out
0
 
LVL 71

Expert Comment

by:Chris Dent
ID: 33543259

:)

Okay, so the local DNS server is responding but it isn't able to find public names.

Can you head back to the Forwarders section (DNS Console / Server Properties / Forwarders) and remove all Forwarders.

Leaving that blank will make the server use Root Hints which should be more reliable than any single server.

Then run the same command again:

nslookup www.google.com 192.168.0.100

If it times-out again can you run this (still from the server:

nslookup www.google.com 8.8.8.8

8.8.8.8 is a public DNS server owned by Google themselves. If things are going to be consistent then that command should time-out as well.

Chris
0
 

Author Comment

by:1williamquinn
ID: 33543512
Thanks Chris
Just a quick question about the cabling
The server is connected to a managed switch and then to the ISP Router   does this have anything impact on what is happening?
0
 
LVL 71

Expert Comment

by:Chris Dent
ID: 33543539

It may, which interface has the Default Gateway?

If both of them do you need to remove it from one. Only the interface connected to the outside world (the Internet) should have a default gateway configured (the other interface should have it blank).

Chris
0
 

Author Comment

by:1williamquinn
ID: 33543670
Bear with me ….Are you asking if the Server or Switch has the Gateway configured?
0
 
LVL 71

Expert Comment

by:Chris Dent
ID: 33543691

The Server please.

If you have a network diagram that would help, even if it's really basic.

I have to head off home now, so I won't respond for a couple of hours, but post anything you find or any questions you have.

Chris
0
 

Author Comment

by:1williamquinn
ID: 33543792
Thanks Chris for all your help
Because I inherited this network, your suggestion of creating a network diagram is the best approach.  I will be at the clients Monday / Tuesday next week and will gather the needed info and will send it along.

Thanks Again
1wq
0
 
LVL 27

Expert Comment

by:Steve
ID: 33552552
Pls answer the following:

post the results from ipconfig /all on the server
can you access the internet on the server?
Is the dns server service running? (check in services.msc)
can the server ping its default gateway?
0
 

Author Comment

by:1williamquinn
ID: 33557783
Thank you for the info
Could you please give me a list of all things needing to be checked / recorded?
0
 

Author Comment

by:1williamquinn
ID: 33560227
More Information

On The Server (Ipconfig /all)

Local Area Connection 2
192.168.0.101 >>> IP
255.255.255.0  >>> Subnet
192.168.0.2  >>> Gateway
192.168.0.100 >>> DNS
68.87.71.226 >>> DNS


Local Area Connection
192.168.0.100
255.255.255.0
192.168.0.2
Only one DNS >>> 192.168.0.100
___________________________________________________________
I can PING 192.168.0.2 Gateway
i can get out on the internet

__________________________________________________________

Under DNS Forwarders

DNS Domains  has >>>> All other DNS Domains

Then under selected Domain Forwarders >>> 216.41..... + 2 others 204.
non of these have the 68.87 address

Thanks for the help with this
0
 

Author Comment

by:1williamquinn
ID: 33560481
Hi Guys

On site now any chance you are availible?
0
 

Author Comment

by:1williamquinn
ID: 33560673
Scope Options Under DHCP is >>>> 006 >>>192.168.0.100
0
 
LVL 27

Expert Comment

by:Steve
ID: 33560695
Does youre server have / Nics or was that 2 diffrerent ipconfig /alls?
0
 

Author Comment

by:1williamquinn
ID: 33560725
Thank you
yes it has 2 NICS only one is plugged in at this time >>> please see above
0
 
LVL 27

Expert Comment

by:Steve
ID: 33560767
Ok, firstly you should only have one nic on the same subnet. You should also have a default gateway on ONE unless you have setup routing on the server.

Also, what is .100? And why do you have an alternative dns on the server's nic? The server on a domain should only point to itself for dns.
0
 

Author Comment

by:1williamquinn
ID: 33560826
The server has a static 192.168.0.100

the only active connections is the local connection
192.168.0.100
with DNS of 192.168.0.100
0
 

Author Comment

by:1williamquinn
ID: 33560953
Do I need to add the ISP Router DNS to the Forwarders?
0
 
LVL 27

Assisted Solution

by:Steve
Steve earned 250 total points
ID: 33560975
As your server thinks it has two NICs i will have two entries for itself in DNS which will be causing chaos.
Delete it from the forward and reverse lookup zones and chech the dns server is onky set to accept dns requests on .100.
Do this then an ipconfig /flushdns on a pc. See if this helps....
0
 

Author Comment

by:1williamquinn
ID: 33561037
The only entry that is listed in dns is 192.168.0.100
0
 
LVL 27

Expert Comment

by:Steve
ID: 33561394
ok, have re-read the thread and would like to confirm some things to be sure we're on the right track.

Server currently has only one NIC connected. Please set the other NIC to dhcp and disable it to be sure its settings are not affecting the issue.

192.168.0.100
s/n 255.255.255.0
g/w 192.168.0.2
dns 192.168.0.100

Server can ping gateway 192.168.0.2 and can access internet.

Clients pick up IP from dhcp and have same gateway and DNS but cannot access internet.
Can clients ping the server on .100?
can clients ping the gateway on .2?

run nslookup on client and server.
see what results are returned when looking up the 'servername' and 'www.google.com'

please confirm and post responses to the above.
Thanks.
0
 
LVL 71

Expert Comment

by:Chris Dent
ID: 33564953

Apologies, yesterday was a public holiday here.

> Do I need to add the ISP Router DNS to the Forwarders?

No. You can have them, but you do not need them.

Did you manage to clear up the Default Gateways on your server?

Chris
0
 

Author Comment

by:1williamquinn
ID: 33573024
Hi Guys,
Just for clarification
When the workstations are set to Obtain an IP Address Automatically they get a 192.168.0.100 address
When the workstations are set to Obtain DNS Address Automatically they get 192.168.0.100
(the server address)
This will not let the workstations connect to the internet.

When the workstations DNS is manually set to 68.87.73.242
This will allow the workstations to get out on the internet
From the workstations I can go to (run > IP of Server) and connect to it + (run> server name) and connect to it

The server has 2 network cards with only 1 active
192.168.0.100
255.255.255.0
192.168.0.2
192.168.0.100

When I typed from the server nslookup
I received the following
Server1(companyname.net) 192.168.0.100

When I typed from the server nslookup www.google.com 192.168.0.100
I recived the following
Server1(companyname.net) 192.168.0.100
Server1(companyname.net) 192.168.0.100 DNS Timed Out


Under DNS Forwarders
DNS Domains  has >>>> All other DNS Domains

Then under selected Domain Forwarders >>> 216.41.xxx..... + 2 others 204.41.xxx
Non of these have the *.*

Thank again for the help with this

0
 

Author Comment

by:1williamquinn
ID: 33582761
Just checking in

Any suggestions on things to try?
0
 
LVL 71

Expert Comment

by:Chris Dent
ID: 33584703

Remove the Forwarders then try again, or run this from your server:

nslookup www.google.com 8.8.8.8

We need to know why your internal DNS server is not working.

Chris
0
 

Author Comment

by:1williamquinn
ID: 33606566
Thanks Chris

I will be on site this Tuesday.... thank you again
0
 
LVL 27

Expert Comment

by:Steve
ID: 33606697
@1williamquinn

As requested above, please:

>remove the static IP and disable the unused NIC.
>Advise if the PCs can ping the server.
>run nslookup on client AND server. Please post the results here.

Also, check the event logs on the server as it seems unlikely a problem would exist with DNS without an event being logged.

Thanks,

0
 

Author Comment

by:1williamquinn
ID: 33614182
Thanks T-T
Most of the PC’s have a mapped drive to the server by name \\server
Although I haven’t tried it, I think that the workstations can ping the server
There is a shared printer /scanner that dumps scans to a directory on the server that is also working fine.

Will check the event logs  tomorrow
Thanks again
0
 

Author Comment

by:1williamquinn
ID: 33653405
Hi Guys,

Just wanted to update you, I will not be able to run the tests you asked for in till the week of 20th

Thank you for helping me with this
1wq
0
 

Author Comment

by:1williamquinn
ID: 33773725
Update

Guys,

Just wanted to update you, I will  run the tests you asked for this week (27th)

Thank you for helping me with this
1wq
0
 
LVL 27

Expert Comment

by:Steve
ID: 33783644
just as a reminder:
check event logs for warnings or errors
run NSlookup on client & server and post on here so we can compare
check dns server service is running on server

0
 

Author Comment

by:1williamquinn
ID: 33800936
Hi Totallytonto,

I had run ns lookup on the Server before please see above dated
(08/31/10 09:31 PM, ID: 33573024)

Thanks
1wq
0
 
LVL 27

Expert Comment

by:Steve
ID: 33860507
if you would like help resolving this, please run an NSLookup on a client and server exactly the same and post the results so I can compare them.

also perform and report back on the following:
check event logs for warnings or errors
check dns server service is running on server
0
 

Author Closing Comment

by:1williamquinn
ID: 34480744
Very sorry for not getting back to sooner, multiple items needed immediate attention
Thank you both
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Trying to figure out group policy inheritance and which settings apply where can be a chore.  Here's a very simple summary I've written which might help.  Keep in mind, this is just a high-level conceptual overview where I try to avoid getting bogge…
Learn about cloud computing and its benefits for small business owners.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question