Solved

How do I configure Dual WAN on Cisco 1721 for sharing bandwidth and failover?

Posted on 2010-08-25
6
1,059 Views
Last Modified: 2012-05-10
I have a Cisco 1721 with a Wic1-ADSL and a WIC 4ESW installed.  I have DSL service and fixed-wireless service.  I have a /29 for both connections.  I would like a config which bundles both connections to share the bandwidth, but also will allow for all traffic to pass to one or the other in case of failure.  I have another device in the house which provides DHCP, wireless, etc so if the combination would just feed a single private IP address (172.30.30.1/30 for example), I can setup my internal router to do the rest.  

I currently have the router configured (not by me) to use the fixed-wireless connection full time, and only failover to the DSL if the wireless goes down.  This works fine, but I hate to pay for the DSL which I will only use a couple times a year in this method.  It would be much better for me if I used both connections concurrently and it would failover to using a single connection in the event that either would fail.

I can provide current config details if necessary, but can anyone help me with this config?

ED7
0
Comment
Question by:electricd7
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
6 Comments
 
LVL 28

Expert Comment

by:bgoering
ID: 33522104
You can get some primitive outbound load balancing by configuring your router with two default routes

ip route 0.0.0.0 0.0.0.0 ip.of.wireless.network
ip route 0.0.0.0 0.0.0.0 ip.of.dsl.network

Good Luck
0
 

Author Comment

by:electricd7
ID: 33522359
Thanks for the suggestion, but I need a little more help than that.
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33522410
Please go ahead and post the config for your router.
0
Raise the IQ of Your IT Alerts

From IT major incidents to manufacturing line slowdowns, every business process generates insights that need to reach the people required to take action. You need a platform that integrates with your business tools to create fully enabled DevOps toolchains.

You need xMatters.

 

Author Comment

by:electricd7
ID: 33522440
version 12.4
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname chad-c1721
!
boot-start-marker
boot-end-marker
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization network default local
!
aaa session-id common
memory-size iomem 15
clock timezone EST -5
clock summer-time EDT recurring
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
no ip domain lookup
ip domain name joink.com
ip name-server 63.134.128.164
ip name-server 63.134.128.165
ip name-server 63.134.128.162
ip name-server 63.134.128.163
ip sla monitor 100
 type echo protocol ipIcmpEcho 63.134.155.225 source-interface FastEthernet0
 timeout 500
 frequency 3
ip sla monitor schedule 100 life forever start-time now
!
!
!
!
!
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 2
!
track 100 rtr 100 reachability
 delay down 5 up 10
!
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
 hold-queue 224 in
!
interface ATM0.1 point-to-point
 description ** DSL **
 ip address 63.134.180.106 255.255.255.248
 ip nat outside
 ip virtual-reassembly
 pvc 0/35
 !
!
interface FastEthernet0
 ip address 63.134.155.228 255.255.255.248
 ip nat outside
 ip virtual-reassembly
 speed auto
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface Vlan1
 ip address 172.30.30.1 255.255.255.252
 ip nat inside
 ip virtual-reassembly
!
ip local policy route-map LocalPolicy
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 63.134.155.225 10 track 100
ip route 0.0.0.0 0.0.0.0 63.134.180.105 251
!
no ip http server
no ip http secure-server
ip nat inside source route-map DSL interface ATM0.1 overload
ip nat inside source route-map Wireless interface FastEthernet0 overload
ip nat inside source static tcp 172.30.30.1 23 63.134.155.228 23 extendable
ip nat inside source static tcp 172.30.30.1 22 63.134.155.228 2222 extendable
ip nat inside source static tcp 172.30.30.1 23 63.134.180.106 23 extendable
ip nat inside source static tcp 172.30.30.1 22 63.134.180.106 2222 extendable
!
ip access-list extended PingWireless
 permit icmp host 63.134.155.228 host 63.134.155.225
!
route-map Wireless permit 10
 match interface FastEthernet0
!
route-map DSL permit 10
 match interface ATM0.1
!
route-map LocalPolicy permit 10
 match ip address PingWireless
 set ip next-hop 63.134.155.225
 set interface FastEthernet0
!
!
control-plane
!
!
line con 0
 privilege level 15
line aux 0
line vty 0 4
 privilege level 15
 transport input telnet ssh
!
ntp clock-period 17180089
ntp server 63.134.128.162
ntp server 63.134.128.163
ntp server 63.134.128.164
ntp server 63.134.128.165
end
0
 
LVL 28

Accepted Solution

by:
bgoering earned 500 total points
ID: 33522605
I think this document (http://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_example09186a00808d2b72.shtml) describes pretty closely what you are trying to do.

If not let me know how it differs
0
 

Author Comment

by:electricd7
ID: 33522766
Yea that looks promising.  I will give it a shot and report back.  Thanks.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question