Solved

Windows 7 lag when accessing a file server share

Posted on 2010-08-25
5
1,822 Views
Last Modified: 2012-05-10
When accessing one particular file server (FS06) from a new Dell Optiplex 980 Windows 7 64 bit computer, there is a 10-12 second lag on opening \\FS06 and each folder thereafter (even if you go back to a folder you’ve already opened).  Accessing other servers on our network is instantaneous.  FS06 and our other servers are in the same location.  The network adapter is the onboard Intel 82578DM.  FS06 is Server 2003 x64.  

If you disable the network connection and then enable it (on the optiplex 980 Win7-x64), browsing shares on FS06 returns to “normal”, until you restart that is, then the problem returns.  

If you install XP on the 980, it works fine.  

All other computer models in our enterprise access FS06 without any problems.  

The Optiplex 960 Win7-x64 had this problem, but it was solved by using an older driver version.  XP did not have this problem on the 960 no matter what driver version.

I have tried every driver version available from Dell and Intel with no luck.  

I tried adding a PCI network card (also Intel) and I had the same problem.

The Optiplex 980 is on the latest BIOS version.

I tried disabling the "Link Layer Topology Discovery" components of the local area connection, no change.

I've tried several 980's, this seems to be a problem with this model, its network driver, or Win 7.

Has anyone else run into this problem.  At this point, this is delaying our Win 7 deployment. We have an unreliable work-around: powershell scripts that disable and enable the network connection in the AM, but it doesn't always run, (scheduling powershell scripts has been fun) and if the user restarts mid day, they run into this problem again.  I'd love a real solution, but i'm thinking its a driver issue and I'm waiting on Dell/Intel to fix the problem...
0
Comment
Question by:Coilcraft
  • 4
5 Comments
 
LVL 6

Expert Comment

by:fluk3d
ID: 33522071
Have you tried accessing the share

\\SERVER
\\FULLFQDN \\SERVER.DOMAIN.LOCAL
\\IP ADDRESS

Please report back
0
 

Author Comment

by:Coilcraft
ID: 33522251
problem still there weather you use \\fs06,  \\fs06.domain.com,  \\ip-address

also it pings at <1ms
0
 

Author Comment

by:Coilcraft
ID: 33523180
I've been trying different network cards, all have the same problem.  leading me to believe this is a Win 7 problem

Onboard  Intel 82578DM - every driver version i could find - same problem
Intel pro/1000 GT - latest intel driver - same problem
Netgear GA311 (realtek chipset) - Microsoft driver - same problem
Netgear GA311 (realtek chipset) - llatest Netgear driver - same problem
Netgear GA302T - no Win7 driver - couldn't test
0
 

Author Comment

by:Coilcraft
ID: 33568433
I tried 3 more PCI gigabyte cards, no luck.  Anyone have any other ideas?
0
 

Accepted Solution

by:
Coilcraft earned 0 total points
ID: 33570000
The Fix:

In an elevated command prompt, type:

netsh interface tcp set global autotuning=disabled

http://www.sysprobs.com/windows-7-network-slow


This article refers to Vista, but I think it’s the same in Win 7

The symptoms exist due to the new re-written TCP stack in Windows Vista that aims to take full advantage of hardware advances such as gigabit networking. Among the new feature in Windows Vista TCP/IP is Receive Window Auto-Tuning Level for TCP connections. TCP AutoTuning enables TCP window scaling by default and automatically tunes the TCP receive window size for each individual connection based on the bandwidth delay product (BDP) and the rate at which the application reads data from the connection, and no longer need to manually change TcpWindowSize registry key value which applies to all connection. Theoretically, with TCP auto-tuning, network connection throughput in Windows Vista should be improved for best performance and efficiency, without registry tweak or hack. However, this is not always the case, and may cause some Internet related issues and problems.
The workaround or solution to the above problem is to disable the TCP/IP AutoTuning in Windows Vista. Disabling auto tuning of TCP Windows Size should not cause any negative effects, only that TCP Window Size will always at default value without ability to optimization to each connection. Anyway, if there is any side effect after turn off auto tuning, simply re-enable back it.

http://www.mydigitallife.info/2007/03/22/disable-tcp-auto-tuning-to-solve-slow-network-cannot-load-web-page-or-download-email-problems-in-vista/
0

Featured Post

Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup" or a blinking cursor with black screen. A loop for Auto repair will start but fix nothing.  You will be panic as there are no back…
Most of the applications these days are on Cloud. Cloud is ubiquitous with many service providers in the market. Since it has many benefits such as cost reduction, software updates, remote access, disaster recovery and much more.
This Micro Tutorial will teach you the basics of configuring your computer to improve its speed. It will also teach you how to disable programs that are running in the background simultaneously. This will be demonstrated using Windows 7 operating…
This Micro Tutorial will give you a basic overview of Windows Live Photo Gallery and show you various editing filters and touches to photos you can apply. This will be demonstrated using Windows Live Photo Gallery on Windows 7 operating system.

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question