?
Solved

remote connection to a workstation on a windows sbs2008 server based network

Posted on 2010-08-25
16
Medium Priority
?
442 Views
Last Modified: 2012-05-10
Can someone please help me, as this is driving me crazy! I need to connect to my desktop back in the office, and this has been working great using the https://remote.domainname.co.uk facility of Windows SBS2008.

The workstation I am on today is a Microsoft XP Pro SP2. (but I have this problem in a number of locations).

Now for some reason on many different workstations I can no longer connect. I type the URL for the network in a browser, and it presents the logon screen as usual. I then enter the username and password, and we get the small box appearing that has to remain active for the duration of the connection.

We then get the following error message :-

The Microsoft Terminal Services Client ActiveX control (also known as RDP client control) is either not available, or is not enabled. For mor information about installing and enabling this ActiveX control, see the Microsoft Technet Website (http://go.microsoft.com/fwlink/?LinkID=103719).

Now when I look at this it just mentions that when SP3 had been installed there could be a problem and offers a fix it for me option or details for manually enabling ActiveX.

I have tried the fix it for me, but it just says that it is not appropriate for my OS, and does nothing. The workstation I am working at today is only SP2.!! So why should this problem keep cropping up?

I have tried to manage my add ons, but it is not shown, and resetting everything does not achieve anything. Does anyone have any suggestions as how to resolve this, and why is this happening more and more when using various workstations.

Any ideas?
0
Comment
Question by:nigelbeatson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6
  • 2
  • +1
16 Comments
 
LVL 18

Expert Comment

by:Cluskitt
ID: 33522499
Have you checked if terminal services are enabled?
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 33522540
Firstly to connect to SBS 2008 RWW you need to have XP SP3, Vista SP1, or newer.
This will also install the newer RDP client you will need Ver 6.1 or newer.
The active -x issue is quite common. Assuming you have met the above conditions make sure the Active-x component is not disabled under add-ons in internet explorer and if that doesn't work click the "reset" button in internet explorer under internet options | advanced.
0
 

Author Comment

by:nigelbeatson
ID: 33522546
How do I do that? do you mean on the client or the remote workstation? No changes have been made at my office workstation, and I am unsure why this keeps cropping up all over the place.

Could you expand on your suggestion please?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 6

Expert Comment

by:Elwin3
ID: 33522548
download this and install on the XP sp2 client and try again http://support.microsoft.com/kb/952155
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 33522580
I also assume that RWW was set up and working from some clients. If not you need to run the connect to the internet and configure by internet address wizards.

Following is a good link regarding the Active-x issue:
http://www.sbslinks.com/fixmyrww.htm
0
 

Author Comment

by:nigelbeatson
ID: 33522595
Sorry Robwill, I replied before your message appeared.

I am not actually using Remote desktop to connect, but just typing the address in the browser. This used to work just fine. I would like to understand why it should suddenly become problematic unless SP3 is installed.

I have tried the reset (using SP2 of course - i will upgrade to Sp3 as you suggest) but why is this happening now?

Many thanks.
0
 
LVL 6

Expert Comment

by:Elwin3
ID: 33522652
probably happending because a update has been applied to the sbs 2008 server.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 33522674
Did it work with SP2 before? It would work fine with SBS2003 but should cause issues with SBS2008 as I understand it. Very odd. If so it is usually related to the active-x component bing disabled. There are several fixes as outlined, but you often have to try all of them.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 33522686
ps- can some users connect OK? If so the problem is client side.
0
 

Author Comment

by:nigelbeatson
ID: 33522709
Yes, I can connect from some locations but it seems to be getting fewer and fewer.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 33522736
Sounds like security updates are being deployed to workstations and as it happens it is killing the Active-X add-on.
0
 

Author Comment

by:nigelbeatson
ID: 33533328
The strange thing is that ActiveX does not appear in my list of add ons to manage. I can select it from a list to add, and I am told it has completed ok, but it never appears on the list of add ons to manage.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 33533379
In that case try the reset option.
0
 

Author Comment

by:nigelbeatson
ID: 33539971
I carried out the application of SP3 to the xp workstation, and when the little box pops up now, it gave the warning about running activex in the top. When authorising this to run, it still did not connect. I then upgrade to ie v8, and this now works fine.

Does this mean that all workstations anywhere in the worl require sp3 and ie v8 before rdp will now work?

Many thanks.
0
 
LVL 77

Accepted Solution

by:
Rob Williams earned 2000 total points
ID: 33541291
As I recall you do need XP SP3, or at least the TS connection client components of RDP 6 (included with XP SP3), but you do not need IE8. There are other components in IE that need to be available than just the active-x TS add-on such as accepting cookies. The reset should resolve those, but I assume your installing IE8 did so.

If trying other workstations try installing SP3 and then seeing if you can enable the add-on if needed, without adding IE8.

Probably a good idea to upgrade everybody to SP3. t included a lot of security updates and support for XP SP2 ended as of July this year.
0
 

Author Closing Comment

by:nigelbeatson
ID: 33552410
Many thanks
0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If your system is showing symptoms of browser hijacks or 'google search redirects' check out my other article (http://rdsrc.us/u3GP7A) first and run the tool TDSSKiller (http://rdsrc.us/GDBBs4) to get rid of the infection. Once done, and if the …
If you have done a reformat of your hard drive and proceeded to do a successful Windows XP installation, you may notice that a choice between two operating systems when you start up the machine. Here is how to get rid of this: Click Start Clic…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question