Solved

NOLOCK by Default

Posted on 2010-08-25
1
1,089 Views
Last Modified: 2012-05-10
Is there a setting in Server Management Studio (or with SQL) that will run all of my SELECT queries with NOLOCK by default? I know I can specify in the actual query, but I do not want to. I just want it set for the entire session.
0
Comment
Question by:leonstryker
1 Comment
 
LVL 1

Accepted Solution

by:
ajanthony earned 500 total points
ID: 33523162
In SQL 2008 Server Management Studio

Click Tools -> Options.
In the treeview, Underneath Query Execution -> SQL Server -> Advanced.

Set transaction isolation level to READ UNCOMMITTED
0

Featured Post

Backup Solution for AWS

Read about how CloudBerry Backup fully integrates your backups with Amazon S3 and Amazon Glacier to provide military-grade encryption and dramatically cut storage costs on any platform.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Nowadays, some of developer are too much worried about data. Who is using data, who is updating it etc. etc. Because, data is more costlier in term of money and information. So security of data is focusing concern in days. Lets' understand the Au…
This article explains how to reset the password of the sa account on a Microsoft SQL Server.  The steps in this article work in SQL 2005, 2008, 2008 R2, 2012, 2014 and 2016.
Via a live example, show how to extract insert data into a SQL Server database table using the Import/Export option and Bulk Insert.
Via a live example, show how to shrink a transaction log file down to a reasonable size.

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question