Solved

That damn assembly again! ('System.Web.Extensions.Design, Version=1.0.61025.0)

Posted on 2010-08-25
12
881 Views
Last Modified: 2013-11-27
Hey Comrades,

So I've been given a task to make some mods to an existing website.  I download the website on my local machine to work on and try running it and get the damn assembly error.

Could not load file or assembly 'System.Web.Extensions.Design, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

On my machine I have the 3.5 framework and the dll I have is version 3.5.xxx.xxx

Now of course it cannot find that assembly so I downloaded the DLL from the webserver and confirmed its the 1.0.61025.0 version.  I add the assembly as a reference and it still cannot find the file.

Perhaps I am not educated enough in assembly files but what do I need to do to get this running again?

*note  I tried updating the webconfig file with the Web.Extensions new version but I the AjaxControl.DLL craps out because it seems to be looking for the old version of the dll as well.

Please assist.
0
Comment
Question by:lino_evolution
12 Comments
 
LVL 8

Expert Comment

by:Mohit Vijay
ID: 33523965
Let me help you friend...

Go into GAC and check there should be a assembly available with the name of System.Web.Extensions.Design.
right click on it and note down version, culture and publickkeytocken.

Specify these value on your site's web.config file.

Also you have to add the reference of this dll in your site's code.

Please let me know if you need more clarification. I am sure that above solution will work for you.

Thanks!
0
 
LVL 16

Expert Comment

by:13598
ID: 33524020
Because it is an older version you need to reference these:
Microsoft.Web.Extensions.dll and Microsoft.Web.Extensions.Design.dll

The newer version is the one that uses system.web.extensions. If you added a reference to the system.web.extensions you will get the error because the assembly reference for that version is in microsoft.web.extensions.
0
 
LVL 6

Expert Comment

by:hehdaddy
ID: 33524040
If the above doesn't work, try this. This often solves problems when I swap out DLLs.

Close Visual Studio.
Open a CMD window and do a IISRESET.
Using Windows Explorer, navigate to: C:\WINDOWS\MICROSOFT.NET\FRAMEWORK\v2.0.50727\TEMPORARY ASP.NET FILES\ and delete everything in that folder.
Open Visual Studio.
Open your Solution.
Do a Clean.
Do a Build.

Cheers.
0
DevOps Toolchain Recommendations

Read this Gartner Research Note and discover how your IT organization can automate and optimize DevOps processes using a toolchain architecture.

 

Author Comment

by:lino_evolution
ID: 33524971
VjSoft. I had already tried that and still recieve an error because of the AjaxControlToolkit.dll.  I am wondering if that DLL uses the older version of the web extensions.  Now I am trying to use the older DLL rather than updating the app to reflect the new DLL.

13598. Not sure what you mean.  That I need to reference Microsoft.Web.Extensions.Design.dll older version as well?

hehdaddy:  I cannot compile because it reports a whole bunch of unrecognized errors (cannot recongnize StringBuilder, or HttpContext, I am sure this is a result of the web.extenstions not applied properly
0
 
LVL 16

Expert Comment

by:13598
ID: 33524992
The older version of ajax extensions need the references to Microsoft.Web.Extensions.dll and Microsoft.Web.Extensions.Design.dll not system.web.extensions.
You said you installed the older version of ajax, correct?
For the project to be able to use those you need to reference Microsoft.Web.Extensions.dll and Microsoft.Web.Extensions.Design.dll. Did you add those references?
0
 
LVL 16

Accepted Solution

by:
13598 earned 125 total points
ID: 33525013
They should have already been there but since you opened the solution when those dlls didn't exist in your PC (since you didn't have the older Ajax version installed) the solution may be unable to find them. If they were already there under the references I would remove them, close the solution, re-open the solution and re-add them.
0
 
LVL 16

Expert Comment

by:13598
ID: 33525031
And I would also remove the references to system.web.extensions.
0
 

Author Comment

by:lino_evolution
ID: 33525053
I have both DLL's

Is it as simply as copy the DLL's to my computer and right clicking.. select "ADD reference" then browse for the hard files?
0
 
LVL 16

Expert Comment

by:13598
ID: 33525072
Yes you could try that or simply under the Properties/references tab. You also need to remove the system.web.extensions so the app doesn't get confused and tries to use that one and fails.
0
 

Author Comment

by:lino_evolution
ID: 33525114
awesome, looks like that did the trick 13598, I copied the files and Added them by browsing the file.

Now is that the best way or can it be added to the GAC in parrallel with the newer versions.
0
 
LVL 16

Expert Comment

by:13598
ID: 33525168
Usually by changing the reference to be copy local = true puts it in the GAC.
About using both versions of ajax, not long ago I saw a good detailed article on how to use both versions. Let me try to find it.
PS. I just don't understand why they couldn't have left the dlls in the same place. It certainly complicate things.
0
 
LVL 16

Expert Comment

by:13598
ID: 33525472
I can't find the article but if I run into it again I will remember to post it here. I now remember it was for VS2008 and ASP.NET AJAX 1.0 Websites since 2008 is a multitargeting environment where you can select which framework to use. I don't know if that is what you are using or not.
'Now is that the best way or can it be added to the GAC in parrallel with the newer versions'
If the references are set to copy local= true they should be automatically installed in your GAC if enough permissions exist. If not the best way is to just copy them or from the reference browse to them or simply remove and readd. Now that you have both versions on your development machine I don't believe you would have this issue again. The issue was caused because you didn't have the dlls where the reference path said they were. You should now be able to work with different version projects as long as your references point to the correct path.
0

Featured Post

Master Your Team's Linux and Cloud Stack!

The average business loses $13.5M per year to ineffective training (per 1,000 employees). Keep ahead of the competition and combine in-person quality with online cost and flexibility by training with Linux Academy.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

IP addresses can be stored in a database in any of several ways.  These ways may vary based on the volume of the data.  I was dealing with quite a large amount of data for user authentication purpose, and needed a way to minimize the storage.   …
The object model of .Net can be overwhelming at times – so overwhelming that quite trivial tasks often take hours of research. In this case, the task at hand was to populate the datagrid from SQL Server database in Visual Studio 2008 Windows applica…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…

808 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question