Tech or Treat! Write an article about your scariest tech disaster to win gadgets!Learn more

x
?
Solved

permission rights are not being propagated from folder to files

Posted on 2010-08-25
5
Medium Priority
?
358 Views
Last Modified: 2013-12-04
I have a folder that is shared on a 2003 server.  A user calls me today and says that he is unable to access some excel files in the folder.  He gets an error message saying that he only has read only rights or that the file is encrypted.  
While logged on as administrator on the server, I noticed that many of the excel files are missing permissions for the everyone group.  After I add the everyone group and allow read access to the folder, he is able to access the file.  
There are approximately 500 files in the folder, so I'd like to make sure that all access rights on the files are the same as the folder.  When I click on the right click on the shared folder and goto properties->security->advanced and check allow inheritable permissions, it appears that nothing changes.  
0
Comment
Question by:akyuen
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 6

Accepted Solution

by:
ob1_ earned 1800 total points
ID: 33523552
Right-click the parent folder, go to properties, security, advanced, on the permissions tab check the box to "Replace permission entries on all child objects...". This will apply the folder permissions to all files in the folder.
0
 

Author Comment

by:akyuen
ID: 33523875
thanks ob1.  I now find out that I have some files that I do not have access rights to, even though I am an administrator.  Is there an easy way to just replace permission entries on all child objects and overwrite the permissions on those files that I do not have access rights to? or do I actually have to take ownership of each of those files?
0
 
LVL 6

Expert Comment

by:ob1_
ID: 33523895
Go to the Owner tab and replace owner on all subcontainers and objects. Then go back to the permissions tab end replace permissions on all child objects. That should do it.
0
 
LVL 3

Assisted Solution

by:petelettin
petelettin earned 200 total points
ID: 33524047
ob1's comment will also remove existing permissions.

Pete :-)
0
 

Author Comment

by:akyuen
ID: 33524383
Thanks guys.  It worked perfectly.
0

Featured Post

Are You Ready for GDPR?

With the GDPR deadline set for May 25, 2018, many organizations are ill-prepared due to uncertainty about the criteria for compliance. According to a recent WatchGuard survey, a staggering 37% of respondents don't even know if their organization needs to comply with GDPR. Do you?

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many of us in IT utilize a combination of roaming profiles and folder redirection to ensure user information carries over from one workstation to another; in my environment, it was to enable virtualization without needing a separate desktop for each…
In a recent article here at Experts Exchange (http://www.experts-exchange.com/articles/18880/PaperPort-14-in-Windows-10-A-First-Look.html), I discussed my nine-month sandbox testing of the Windows 10 Technical Preview, specifically with respect to r…
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
Suggested Courses

648 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question