• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 768
  • Last Modified:

Can't Save Attachments in Outlook 2007

When I right click and select Save As for an Excel, Word, etc. attachment in Outlook 2007 the only file type available is All Files.  I should see XLS, DOC, etc.  I can open the attachment and do a Save As from with Excel or whatever.  
0
woodwyn
Asked:
woodwyn
1 Solution
 
javaftperCommented:
this is normal and the expected behaviour of the save attachment operation.

In the ' save attachment' window, the file name will be something like 'sheet.xls' for an Excel spreadsheet and the file type box will say 'ALL FILES'.

This is how all of the major e-mail client software producers handle the save attachment operation.  When you click to save the file it will be saved in the format it was sent to you, eg .xls unless you wish to change it.
0
 
woodwynAuthor Commented:
I disagree.

This is a new issue that started on this system recently after adding an additional account to Outlook.  On another system with the same OS and Outlook verions if I right click an attachment and select Save As I see the default options as Microsoft Office Excel...(*.xls) for Excel attachments, ...(*.doc) for Word attachments, ...(*.jpg) for JPG files, etc.



0
 
omgangIT ManagerCommented:
Perhaps you need to redo the file associations on that system.  When I right-click and attachment and choose Save As I see two options in the Save as type box
The default for the specified file typ (e.g. Microsoft Office Word 97-2003 (*.doc) for Word docs)
All Files (*.*)
The default is the specific type for the file being saved.
This is in Outlook 2007

In Outlook 2003 the behavior is as described by javaftper.  I only see All Files (*.*) regardless of the attachment file type.

What version of Outlook are you working with?
OM Gang
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
omgangIT ManagerCommented:
Never mind my last question.  I see in your original Q you noted Outlook 2007.  Check the file associations on the system.
OM Gang
0
 
woodwynAuthor Commented:
Wish I knew this already, but ...  Any tips on how I "redo file associations"?
0
 
omgangIT ManagerCommented:
XP?  Vista?  7?
OM Gang
0
 
woodwynAuthor Commented:
Windows 7
0
 
omgangIT ManagerCommented:
Control Panel --> Default Programs --> Associate a file type or protocol with a program
OM Gang
0
 
DanMarCommented:
You can shift-right click the file and select open with and choose the default progrem.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now