VPN connections causing DNS issues for local domain.

We are having an issue where a user who sits on a 10.1.1.1 network makes a VPN connection to a 192.x.x.x net work and then it registers the 192.x.x.x in the local 10.1.1.1 DNS server causing issues.  How can I prevent the user from registering a 192.x.x.x address on our DNS server that should only have 10.x.x.x entries?  It there a way to prevent the VPN connection from registering with DNS?
WyleHouAsked:
Who is Participating?
 
Dave773Connect With a Mentor Commented:
Under the network adapter TCP/IP settings for the VPN client, you need to disable registration of the connection's address in DNS.

Untitled.png
0
 
alexmclvCommented:
Is the user connecting from a Windows machine? If he/she is just connecting using Windows' built-in VPN client, you can modify the properties of the connection to prevent it from registering its DNS address by:

- Right-click the VPN connection and select Properties.
- Click the Networking tab.
- Select Internet Protocol (TCP/IP) and click the Properties button.
- Click the Advanced button.
- Click the DNS tab.
- UNCHECK the "Register this connection's addresses in DNS" checkbox.
- Click OK until you close out of all windows.
0
 
WyleHouAuthor Commented:
The users are using a checkpoint VPN client.
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
Dave773Commented:
That's fine... the checkpoint client probably dynamically creates a "virtual" network adapter at the time of connection.
Do you use group policies in your network?
0
 
Dave773Commented:
One option is to disable this setting in group policy... When your client PC gets his 10.x.x.x address from DHCP, the DHCP server should register that connection in DNS for the client and the PC setting becomes unnecessary.
The other option is to have the user connect to the VPN, then when the virtual adapter shows up, if its not already there, you can disable the setting at that time.
 
0
 
WyleHouAuthor Commented:
Yes, we do use group policies in our network.  Are you saying to disable the setting on all connections and then just let the DHCP server register the client with DNS?  If so do you know where in the GP setting is located?
0
 
Dave773Commented:
I would just disable it in the vpn virtual adapter setting manually to start.
0
 
WyleHouAuthor Commented:
I just talked to the user and they were using the checkpoint but have now switched to a Juniper client and it does create a connection only when connected.  I had the user uncheck the setting when he was connected and then reconnect and the setting stayed.  I think this is going to fix the issue.
0
 
Dave773Commented:
Nice. Let me know.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.