IE always need refresh to see new changes

what is the setting that makes IE to remember the details of the last session, that even if the content of a website is changed, it is caching it and displaying old data only.

Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

avarmaavarmaConnect With a Mentor Commented:
The previous 'sessions' are remembered through cookies set in IE.
To change the default cookie behavior, go into the privacy settings:

Check the box 'Override automatic cookie handling
Block first party cookies, block 3rd party cookies.

This will ensure that no sessions are remembered.

Also - to clear out existing session memory (existing cookies), use the Temporary Internet Files --> Settings as mentioned by the user above
Dave_LaSalleConnect With a Mentor Commented:
Temporary Internet Files > Settings  under the Tools menu
Neil RussellConnect With a Mentor Technical Development LeadCommented:
Tools-Internet Options browser history setings
Make sure that Never is NOT selected!  See image

Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

anushahannaAuthor Commented:
Thanks for your help on the Temporary Internet Files & browser history.

I am using IE 7; I do not see the Tools-->Settings option. Could you guide me where else it could be?
Neil RussellConnect With a Mentor Technical Development LeadCommented:
Click Tools - Internet Options.
Select General Tab.
Click the Settings button under Browsing History.
Set Check for newer versions of stored pages to "Every time I visit the webpage."
More Detail: Set Caching to Every Visit to the page
Click OK.
Click the Delete button under Browsing History.
Click the Delete All button.
Put a check in the checkbox "Also delete files and settings stored by add-ons."
Click the Yes button.
When it is finished, click OK.
anushahannaAuthor Commented:
great. thanks much.
All Courses

From novice to tech pro — start learning today.