Solved

Need to make my web service visible to the outside world

Posted on 2010-08-25
9
548 Views
Last Modified: 2012-06-27
I have my web service running here:

http://localhost/poswebservice/mobileservice.asmx

but I need to make it visible to the outside world.

I have configured in (in IIS) to use port 80.  What do I need to do on my Cisco router to make it visible to the Internet?

Thanks,
newbieweb
0
Comment
Question by:newbieweb
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
9 Comments
 
LVL 4

Assisted Solution

by:thepanch
thepanch earned 150 total points
ID: 33525152
you need to find, if your isp is able to let you be in mode "dmz" that means you got an ip able to be accesed by all user over the internet, if so, you just need to set the "dmz" to the computer is runing the webservice and then, just change the path http://---- DMZ ip ---/poswebservice/mobileservice.asmx, if you dont want to use the ip, or you cant get into dmz mode, then i suggest you to use the no-ip service, you can find it on google. and it comes with a very well explained documentation.

I hope it works
0
 

Author Comment

by:newbieweb
ID: 33525183
I have no problem routing the IP to the PC.  I use DynIP, which has worked for years for me.  

The problem I have involves opening up a port.

I hope you'd explain what exactly I need to do there.

Is this "Port Forwarding"?  I configure my router to forward port 80 to that exact machine where the service is running.

The complexity may be that I must also configure my router so that this machine has a static address within the network.  Otherwise, starting machines in a different order can cause the forwarded port to go to the wrong machine.

Is this all right?

I hope for some confirmation I am doing the right thing.  And that there's nothing else to do...

Thanks,
newbieweb

0
 
LVL 4

Expert Comment

by:thepanch
ID: 33525288
when you got the dmz, you dont need to do porf forwarding, by default dmz pc has all access, and thats why it is called dmz, demilitarized zone, so you are vulnerable there.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 8

Accepted Solution

by:
jimmyray7 earned 350 total points
ID: 33525354
The DMZ info the panch gave is if you want to put that server on a public IP.  It's not port forwarding, the server itself would be sitting on the public internet.

Your idea of port forwarding is probably the better plan.  See this document to set up the access lists and NAT (needed to translat your private address to the public IP):

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a0080093e51.shtml

And you are correct, you should set your server to a static IP so that it doesn't change.
0
 

Author Comment

by:newbieweb
ID: 33527313
I use myname.dynip.com which points perfectly at my server, for SubVersion.  It's worked for years.

Tonight I have forwarded port 8182 to the server where my web service (MobileService) and SubVersion are running.

On the server, this resolves fine:
http://localhost:8182/poswebservice/mobileservice.asmx

But outside the network, this fails:
http://pp1001.dynip.com:8182/poswebservice/mobileservice.asmx

In IIS I right clicked, chose Peroperties, the entered 8182 for TCP Port.

Is this right?
Is there anything else I must do?
0
 

Author Comment

by:newbieweb
ID: 33527479
Should this command work inside the network where the server resides?

If the port forwarding is working, does this work on other PC's in the network?  Or stil just from the actual server?

http://localhost:8182/poswebservice/mobileservice.asmx

0
 
LVL 8

Expert Comment

by:jimmyray7
ID: 33533466
In addition to the port forwarding, did you create NAT rules per the document I posted?
0
 
LVL 4

Expert Comment

by:thepanch
ID: 33533692
localhost always search inside your pc is the same as 127.0.0.1 is a loop back to you
i hope it works
0
 

Author Closing Comment

by:newbieweb
ID: 33553979
Thanks.
0

Featured Post

Is Your DevOps Pipeline Leaking?

Is your CI/CD pipeline a hodge-podge of randomly connected tools? You’ve likely got a tool to fix one problem & then a different tool to fix another, resulting in a cluster of tools with overlapping functionality. Learn how to optimize your pipeline with Gartner's recommendations

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
TCP Reset from Server 3 111
Tool to test the firewall  protection 9 88
SonicWall NSA 3600 HA Content Filtering 3 28
Sonicwall TZ215 and VoIP for One User 6 12
Imagine you have a shopping list of items you need to get at the grocery store. You have two options: A. Take one trip to the grocery store and get everything you need for the week, or B. Take multiple trips, buying an item at a time, to achieve t…
This article shows how to deploy dynamic backgrounds to computers depending on the aspect ratio of display
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question