Solved

Cisco ASA 5505 - cannot connect to the internet from the inside network

Posted on 2010-08-25
6
1,278 Views
Last Modified: 2012-05-10
Hi,
I am a noob to Cisco IOS and cannot get the PC on the inside network to connect to the internet. There is a Trendnet router that will be replaced by a Cisco 5505.  Here are the settings the ISP gave me that are the current settings of the Trendnet.  static ip: 10.0.3.205    mask: 255.255.255.0  gateway: 10.0.3.1  DNS: 10.0.3.1 and 64.147.222.11

I have DHCP turned on inside and have set the outside vlan set to the static ip the ISP gave me.

The config on the ASA 5505 is:

ASA Version 7.2(4)
!
hostname hangerhall
domain-name default.domain.invalid
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.100.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 10.0.3.205 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns domain-lookup inside
dns server-group DefaultDNS
 domain-name default.domain.invalid
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 10.0.3.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.100.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 30
ssh timeout 5
console timeout 0
dhcpd dns 10.0.3.1 64.147.222.11
!
dhcpd address 192.168.100.100-192.168.100.131 inside
dhcpd enable inside
!

username admin password gBAHRIjXeUXu2sLz encrypted
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:196b9882c8b86ee7b927dbe1d8fce0ce
: end

Thanks for your help.
0
Comment
Question by:jerminate
6 Comments
 
LVL 2

Expert Comment

by:texasjpm
ID: 33526533
You need to set an interface to inside for example run.

conf t

interface Ethernet0/1
 switchport access vlan 1
0
 
LVL 2

Expert Comment

by:texasjpm
ID: 33526593
Sorry i dont know what i was thinking Vlan 1 is you native vlan. I do not see anything in the config that pops out at me as missing or wrong. Are you running ASDM? If so can you pull some logs of what you see when trying to connect from the inside?
0
 
LVL 14

Expert Comment

by:anoopkmr
ID: 33528049
how u are testing the internet ?
can u able to reach 10.0.3.1 from PIX.

ICMP will be blocked by default ,so try the below commands

policy-map global_policy
 class inspection_default
inspect ICMP

0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 1

Accepted Solution

by:
nwhitaker2 earned 500 total points
ID: 33530895
Try putting the IP addresses that the ISP gave you on your laptop computer and see if you can get out to the Internet with just those IP addresses.  If that works, then you know you can get out with those IP addresses and that is not the problem.  I did not see where you have DNS defined either, so you should be able to ping outside IP addresses from the ASA, asuming that the test above worked, but it will not resolve names until you set this up.  Use the below as an example to do this.  Use the domain name you used on the ASA, it can be anything you want, it does not have to be the domain of your network.
Conf t
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
 domain-name yourdomain
dns server-group dnslookup
 name-server 10.0.3.1
 name-server 64.147.222.11
 domain-name yourdomain
0
 

Author Comment

by:jerminate
ID: 33535204
Thank you for your help...  I was wondering about the DNS and was not sure how to get the requests from the inside network to the outside  ISP DNS.  I will try that and get back to you.
0
 

Author Comment

by:jerminate
ID: 33770865
It was a DNS issue.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Cisco Routing with 2 ISP connection 5 49
shrewsoft VPN client and DNS 6 48
Simple Guest VLAN Help 17 39
Cisco prime 3 22
How to configure Site to Site VPN on a Cisco ASA.     (version: 1.1 - updated August 6, 2009) Index          [Preface]   1.    [Introduction]   2.    [The situation]   3.    [Getting started]   4.    [Interesting traffic]   5.    [NAT0]   6.…
This article will cover setting up redundant ISPs for outbound connectivity on an ASA 5510 (although the same should work on the 5520s and up as well).  It’s important to note that this covers outbound connectivity only.  The ASA does not have built…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now