Solved

Exchange 2007 owa with Forefront TMG, owa not working after configuring autodiscovery NTLM with a new listener

Posted on 2010-08-25
8
1,062 Views
Last Modified: 2012-05-10
I've published Exchange 2007 owa with Forefront TMG.  It was working perfectly well until I decided to create another listener for autodiscover NTLM authentication.  autodiscovery is working great now, but owa seems to be broken.  The strange thing is that from one of my machines it works perfectly well as it always has.  Which leads me to believe that this machine is in some rule somewhere that is giving it extra access permission.  I also noticed that the computer that it's working for shows the owa site as in the local intranet, where as on the other computers I can't get them to recognize the site in the local intranet.  I've attached a file that has TMG logs from the working computer and one that doesn't.  Any ideas?  Thanks!
FTMG-OWA-log.txt
0
Comment
Question by:mbromb
  • 5
  • 3
8 Comments
 
LVL 32

Expert Comment

by:endital1097
ID: 33526891
i would start by looking at the web publishing rules and make sure there are no overlapping paths
0
 

Author Comment

by:mbromb
ID: 33526920
none that i can see. It was working before the autodiscovery rule change, and i've haven't changed the paths, but I did add another public name.
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33526962
the OWA publishing rule should have the paths /Exchange /owa /public /exadmin (i don't have a box to verify, but I think that is all of them)

Autodiscover publishing rule should only have the /Autodiscover and /rpc paths unless your web services vdir uses the same fqdn, then it should also include /ews /oab /unifiedmessaging

i will try to connect and verify if no one else posts before i can
0
Edgartown IT Case Study

Learn about Edgartown's quest to ensure the safety and security of the entire town's employee and citizen data. Read the case study!

 

Author Comment

by:mbromb
ID: 33526994
I have /public/*, /owa/*, /exchange/*, /exchweb/* .  I made a change with this because of this problem.  I had a separate rule for the OWA path so that it would use negotiation auth to the CAS servers. I've since added it back into the main owa rule which uses basic to simplify things.   But one machine works perfectly well even after refreshing, clearing temp files and form, passwords, etc.  
0
 
LVL 32

Accepted Solution

by:
endital1097 earned 300 total points
ID: 33527008
sometimes you need to restart the isa firewall service
0
 

Author Comment

by:mbromb
ID: 33527017
If that fixes it, I think I'll drop a brick and then give you 300 points.  Hold that thought..... :)
0
 

Author Comment

by:mbromb
ID: 33527056
I can't believe the time I wasted on this!  thank you! thank you! thank you!
0
 

Author Closing Comment

by:mbromb
ID: 33527059
Thank You!!!
0

Featured Post

SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A safe way to clean winsxs folder from your windows server 2008 R2 editions
In-place Upgrading Dirsync to Azure AD Connect
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question