Solved

I can't get my VM's to use bridged networking in VMWare Server

Posted on 2010-08-25
5
1,399 Views
Last Modified: 2013-12-06
I'm trying to get VM's to work in vmware server 2, I used to be able to, but this time I just can't get it to work. Here's the setup.

Host:
Debian 5.0.5 Lenny 32bit
/etc/network/interfaces contains the following interfaces:
eth0 xx.xx.xxx.26
eth0:0 xx.xx.xxx.27
eth0:1 xx.xx.xxx.28
eth0:2 xx.xx.xxx.29
eth0:3 xx.xx.xxx.30 (5 static IP's assigned by the ISP to the dedicated )

They are all assigned netmask 255.255.255.248 and a gateway of xx.xx.xxx.25.

When I set up vmware server 2, I had it bridge with eth0:0. So when I created my VM (Debian 5.0.5) I set it up with the IP of eth0:0, my gateway, and my ISP's name server. VMware Server 2 however constantly says the bridge is disconnected, and the VM can't connect. If I go to the NIC set up for the VM on the VMWare Infrastructure page, and select Connect, it automatically goes back to Disconnected. I've been working on this for days and it's really getting to the point of giving up, I've tried so many things, I don't know what piece I'm missing. I used the patch to allow vssock to build, I wonder if that's the cause. Maybe someone can enlighten me.

Thanks!
0
Comment
Question by:Casey Weaver
  • 3
  • 2
5 Comments
 
LVL 28

Accepted Solution

by:
bgoering earned 500 total points
Comment Utility
It sounds like you have all of your IPs assigned to the host, whereas you wish to assign one to the VM. Correct me if I misunderstood: you said you set up your VMware server to bridge to 0:0 that has an ip of  xx.xx.xxx.27. Then you created a VM and also assigned it to xx.xx.xxx.27. If that is the case you can't do that - the VMs NIC will never see traffic because the VMware host alread has it in use.

what you need to do is.
1. remove one of your sub interfaces and its associated IP address
2. run the vmware-config.pl script to create the bridging to eth0 instead of a sub interface
3. assign whatever ip address you made available in step 1 above to your virtual machine
4. See if it works

If you intend to use 4 of the IPs in virtual machines you can go ahead and delete all of the subinterfaces and there associated iPs.

Also it may work if you just remove the xx.xx.xxx.27 address from eth0:0 - but I am not sure because I have never tried bridging to a sub interface before.

Good Luck
0
 
LVL 7

Author Comment

by:Casey Weaver
Comment Utility
I tried the quick route and tried to bridge it to 0:0, and remove the eth0:0 entries from interfaces, but it didn't work. So tonight when I get off of work I'll try to reconfigure vmware. It's time consuming because due to the compiling issues vmware has, it has to be completely uninstalled, then reinstalled with compiling script with new settings. I'll let you know how it goes.

Thank you very much for your response!
0
 
LVL 28

Expert Comment

by:bgoering
Comment Utility
No problem - I have never tried to bridge VMware server to a sub interface myself, but I know it has worked well for me in the past bridging to physical interface. Typically if you are dedicating your box as a VMware server host you won't need to assign but one of the IPs available. At one time I was running (at home) VMware server on linux with two bridged interfaces: eth0 and eth1, eth0 was LAN, eth1 was WAN. Ran virtual firewall (monowall) and this combination was my gateway/firewall for Internet. Only had 3 IP available from ISP so I converted to ESXi so that I didn't have to waste an IP for VMware Server. ESX(i) can bridge interface without IP, don't think server can do that (I believe I tried) which is likely why just removing the ip for 0:0 didn't work for you. I kind of only suggested that as an afterthought.

Anyway I ramble - Good Luck
0
 
LVL 7

Author Comment

by:Casey Weaver
Comment Utility
Just reporting in that your idea was spot on, it needed the physical interface, eth0, not the virtual one eth0:0. I went into the main server's /etc/network/interfaces and removed eth0:3 completely from it and restarted the network. Then I uninstalled and reinstalled vmware, this time telling it to bridge to eth0 instead of eth0:0. I then took my VM, assigned it xx.xx.xxx.30 with all the gateway, name server ,ect, and voila it worked. Thank you so much for that, I've been banging my head over something so trivially simple.

BTW I'm used to how ESXi worked, but it doesn't seem that VMWare Server 2 is nearly so refined :).
0
 
LVL 7

Author Closing Comment

by:Casey Weaver
Comment Utility
Very well detailed, and the answer was spot on!
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Suggested Solutions

The purpose of this article is to fix the unknown display problem in Linux Mint operating system. After installing the OS if you see Display monitor is not recognized then we can install "MESA" utilities to fix this problem or we can install additio…
In this step by step tutorial with screenshots, we will show you HOW TO: Enable SSH Remote Access on a VMware vSphere Hypervisor 6.5 (ESXi 6.5). This is important if you need to enable SSH remote access for additional troubleshooting of the ESXi hos…
Teach the user how to configure vSphere clusters to support the VMware FT feature Open vSphere Web Client: Verify vSphere HA is enabled: Verify netowrking for vMotion and FT Logging is in place or create it: Turn On FT for a virtual machine: Verify …
Teach the user how to install log collectors and how to configure ESXi 5.5 for remote logging Open console session and mount vCenter Server installer: Install vSphere Core Dump Collector: Install vSphere Syslog Collector: Open vSphere Client: Config…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now