DNS vs share problem Win2008 R2

Hi,

I have this strange thing:
I am connected on a server 2008 R2 machine and my share does not work.

the thing is that if I go to: \\servername I get "Windows cannot access \\servername" (see screenshot)
but when I go to: \\servername.domain.local , everything is okay..

I can ping servername without any problem.

Can someone tell me what can cause this? and what can we do about it?

thx
share.JPG
techneitsolutionsAsked:
Who is Participating?
 
techneitsolutionsConnect With a Mentor Author Commented:
there is no issue anymore
problem solved, changed the logon script
0
 
sasi_kmrCommented:
this is DNS issue.

check whether you have perferred DNS in your local machine,

or

check the DNS in the domain server.

thanks,
$a$i
0
 
techneitsolutionsAuthor Commented:
Hi,

My servers have static IP's and the DNS servers also are configured.

I have 2 DNS servers configured.

the other machines does not have problems connecting to \\servername though..

any thoughts?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
sasi_kmrCommented:
enable netbios in your local machine.

0
 
techneitsolutionsAuthor Commented:
that does not work?

anything else perhaps?
0
 
jasonlcssCommented:
does it work if you configure your machine with static IP settings? Where you can enter your own IP, Gateway and DNS server?
0
 
sasi_kmrCommented:
remove the client from the domain and re join it again and see.
0
 
techneitsolutionsAuthor Commented:
the thing is, I am not on a client machine you know.

I am connected on a server. and on that server I want to open \\servername instead off \\servername.domain.local but then I get the error in the screenshot.

so, yes, it is a static IP and I don't think I can rejoin this server at this moment.

is there anything else I can do?

thx
0
 
sasi_kmrCommented:
check whether the server service is started in your services.msc
0
 
beechy_Commented:
Go in the properties of your Local Area Connection, TCP/IPv4, advanced, DNS, and add domain.local in 'DNS suffix for this connection' on both.
0
 
techneitsolutionsAuthor Commented:
beecht, what do you mean on both?

on both machines? it is only on this server that the problem persists.. on other servers, I can go to \\servername without any problem..
0
 
beechy_Commented:
Sorry, I meant on all machines.  In your statically configured machines (i.e. servers) do as I said above.  To configure your DHCP clients, add domain.local to your DHCP scope options, option 015 - DNS Domain Name.
0
 
techneitsolutionsAuthor Commented:
I changed it on the 2 machines that have the problem and it does not change..
Before I change the rest, this must work right? :)
0
 
sasi_kmrCommented:
start the Service SERVER in the services.msc and check.

0
 
techneitsolutionsAuthor Commented:
SERVER service is started on the machines..
0
 
beechy_Commented:
On your problem machines go to computer properties, computer name, and check for 'primary DNS suffix of this computer' (in the advanced settings somewhere - it's in there!)
0
 
beechy_Commented:
aAlso did you reboot both after changing the DNS suffix in the network adapters like I said previously?
0
 
techneitsolutionsAuthor Commented:
I performed a DHCP client restart so everything was changed i guess..
0
 
Darius GhassemCommented:
Post ipconfig /all from the servers.

What DNS suffixes do you have?
0
 
techneitsolutionsAuthor Commented:
Hi,

What I noticed is that the primary dns suffix correct is on all the machines...

I don't understand why i cannot go to \\servername then..

are there other toughts?

thx
0
 
beechy_Commented:
I f all else fails you can always revert to the good old hosts file on your problem machines, not the fix you are looking for but might help you out in the short term.
0
 
techneitsolutionsAuthor Commented:
I temporaly changed the logonscript to \\servername.domain.local which is okay now.

But I still just am wondering what can be the cause of this issue..
0
 
Darius GhassemCommented:
Post ipconfig /all please
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.