Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4171
  • Last Modified:

Notice: Undefined variable: PHP_SELF in /Applications/XAMPP/xamppfiles/htdocs/xampp/lang/en.php on line 166

Hi, When installing XAMPP to OSX Leopard and after sudo ... start and after http://localhost:80 opens XAMP page where I chose "English" I got this:
Notice: Undefined variable: PHP_SELF in /Applications/XAMPP/xamppfiles/htdocs/xampp/lang/en.php on line 166

Dont know what to do second to start XAMPP.
0
Veikko_Niemi
Asked:
Veikko_Niemi
  • 2
1 Solution
 
svgmucCommented:
Option 1: Enable register_globals in the php.ini
Option 2: Replace $PHP_SELF by $_SERVER['PHP_SELF']
0
 
Veikko_NiemiAuthor Commented:
Because it seems out that I cant write to php.ini, where should I save as a copy of it?
php.init explains:

PHP looks for it in the current
; working directory, in the path designated by the environment variable
; PHPRC, and in the path that was defined in compile time (in that order).

Does that mean that I should save as it under htdocs? But I cant write under it, too! And when I do php programs I should save all programs under htdocs where I cant write?!?

I'm really newbie in Mac and php!
0
 
Veikko_NiemiAuthor Commented:
Now I know how to change permissions as an admin and could save php.ini with register_globals on .
That really helped!!

Thanks!
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now