How to correct install remote desktop license server after testperiod of 180 days is gone

We have a new single server (2008 standard) acting as both domain controller and terminal server.

I thought I had done it correctly by enabling the license server and added the licenses from Microsoft. But after 180 days we are now told by the server that the trial period of 180 days are gone, and no remote desktop users are able to login. Not even administrators.

So, I am locally logged in at console but need your help with step-by-step what to do for activating the terminal server licensing stuff correctly?

Some additional info:
* Trying to start the 'REmote desktop licensing serices" give: Could not start, refer to service-specfik error code 31"
* users have been able to use the remote desktop until today.

Please ask for details and I will get back with respone.

Thanks in advance
Martin_RadboAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tomas ValentaIT ManagerCommented:
there are two steps - activation of the Licencing server and adding licences. It looks like you have not activated your licenced server.
Tomas ValentaIT ManagerCommented:
Martin_RadboAuthor Commented:
Sure.

During activating the role "licensing server", in the end of the installation process I get an error message saying that the installation fails and an erro code (can not see it now, but will update you as soon as I have restarted the server and tried again.
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Martin_RadboAuthor Commented:
"Attempt to install Remote Desktop Licensing failed with error code 0x80070643. Fatal error during installation"
Martin_RadboAuthor Commented:
servermanager.log show this (among a lot of other things). See Code below:
---------------------------------------------------------------------------
name     : Remote Desktop Licensing
state    : Changed
rank     : 2
sync tech: CBS
ant.     : empty
pred.    : Remote Desktop Services
provider : TerminalServerRoleProvider

2748: 2010-08-26 11:13:43.011 [Sync]                      Calling sync provider of Remote Desktop Licensing ...
2748: 2010-08-26 11:13:43.011 [TS]                        Sync:: guest: 'Remote Desktop Licensing', guest deleted?: False
2748: 2010-08-26 11:13:43.011 [TS]                        Begin installation of 'Remote Desktop Licensing'...
2748: 2010-08-26 11:13:43.011 [TS]                        Install: Guest: 'Remote Desktop Licensing', updateElement: 'Licensing-UI;Licensing'
2748: 2010-08-26 11:13:43.011 [TS]                        Installation queued for 'Remote Desktop Licensing'.
2748: 2010-08-26 11:13:43.011 [CBS]                       installing 'Licensing-UI Licensing ' ...
2748: 2010-08-26 11:13:48.487 [CBS]                       ...parents that will be auto-installed: '<none>'
2748: 2010-08-26 11:13:48.487 [CBS]                       ...default children to turn-off: '<none>'
2748: 2010-08-26 11:13:48.565 [CBS]                       ...current state of 'Licensing-UI': p: Staged, a: Staged, s: UninstallRequested
2748: 2010-08-26 11:13:48.565 [CBS]                       ...setting state of 'Licensing-UI' to 'InstallRequested'
2748: 2010-08-26 11:13:48.627 [CBS]                       ...current state of 'Licensing': p: Staged, a: Staged, s: UninstallRequested
2748: 2010-08-26 11:13:48.627 [CBS]                       ...setting state of 'Licensing' to 'InstallRequested'
2748: 2010-08-26 11:13:48.674 [CBS]                       ...'Licensing-UI' : applicability: Applicable
2748: 2010-08-26 11:13:48.721 [CBS]                       ...'Licensing' : applicability: Applicable
2748: 2010-08-26 11:13:56.162 [CbsUIHandler]              Initiate: 
2748: 2010-08-26 11:13:56.162 [InstallationProgressPage]  Installing...
2748: 2010-08-26 11:14:30.217 [CbsUIHandler]              Error: -2147023293 : 
2748: 2010-08-26 11:14:30.217 [CbsUIHandler]              Terminate: 
2748: 2010-08-26 11:14:30.388 [InstallationProgressPage]  Verifying installation...
2748: 2010-08-26 11:14:30.435 [CBS]                       ...done installing 'Licensing-UI Licensing '. Status: -2147023293 (80070643)
2748: 2010-08-26 11:14:30.466 [TS]                        AfterInstall: 'Remote Desktop Licensing'
2748: 2010-08-26 11:14:30.482 [TS]                        Did not find any AfterInstall messages for Remote Desktop Licensing
2748: 2010-08-26 11:14:30.482 [TS]                        Skipping post-install actions of Remote Desktop Licensing due to a pending reboot or errors during install
2748: 2010-08-26 11:14:30.482 [TS]                        Skipped configuration of 'Remote Desktop Licensing' because install operation failed.
2748: 2010-08-26 11:14:30.482 [Provider]                  
[STAT] ---- CBS Session Consolidation -----
[STAT] For 
          'Remote Desktop Licensing'[STAT] installation(s) took '47.4189087' second(s) total.
[STAT] Configuration(s) took '0.0002545' second(s) total.
[STAT] Total time: '47.4191632' second(s).

2748: 2010-08-26 11:14:30.482 [Provider] Error (Id=0) Sync Result - Success: False, RebootRequired: False, Id: 131
2748: 2010-08-26 11:14:30.482 [Provider] Error (Id=0) Sync Message - OperationKind: Install, MessageType: Error, MessageCode: -2147023293, Message: Attempt to install Remote Desktop Licensing failed with error code 0x80070643., AdditionalMessage: Fatal error during installation
2748: 2010-08-26 11:14:30.482 [InstallationProgressPage]  Sync operation completed
2748: 2010-08-26 11:14:30.482 [InstallationProgressPage]  Performing post install/uninstall discovery...
2748: 2010-08-26 11:14:30.482 [Provider]                  C:\Windows\system32\ServerManager\Cache\CbsUpdateState.bin does not exist.
2748: 2010-08-26 11:14:30.482 [CBS]                       IsCacheStillGood: False.

Open in new window

Tomas ValentaIT ManagerCommented:
is there in event log of the server any other messages ? It looks like permission problem. Are you installing this program under domain admin account ?
Martin_RadboAuthor Commented:
The event log is quite clear and not much error messages their at all.
In code section below I've pasted the message from the installation try.
Log Name:      Setup
Source:        Microsoft-Windows-ServerManager
Date:          2010-08-26 10:56:49
Event ID:      1616
Task Category: None
Level:         Error
Keywords:      
User:          TRESORTRAVEL\adminkonto
Computer:      tsserver.tresortravel.local
Description:
Installation failed. 

Roles:

Remote Desktop Services
   Error: Attempt to install Remote Desktop Licensing failed with error code 0x80070643.  Fatal error during installation
   The following role services were not installed:
   Remote Desktop Licensing


Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-ServerManager" Guid="{8C474092-13E4-430E-9F06-5B60A529BF38}" />
    <EventID>1616</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x4000000000000000</Keywords>
    <TimeCreated SystemTime="2010-08-26T08:56:49.458798400Z" />
    <EventRecordID>253</EventRecordID>
    <Correlation />
    <Execution ProcessID="3888" ThreadID="3936" />
    <Channel>Setup</Channel>
    <Computer>tsserver.tresortravel.local</Computer>
    <Security UserID="S-1-5-21-4238183721-339467969-4062046215-500" />
  </System>
  <UserData>
    <EventXML xmlns:auto-ns3="http://schemas.microsoft.com/win/2004/08/events" xmlns="Event_NS">
      <message>

Roles:

Remote Desktop Services
   Error: Attempt to install Remote Desktop Licensing failed with error code 0x80070643.  Fatal error during installation
   The following role services were not installed:
   Remote Desktop Licensing

</message>
      <identifiers>131</identifiers>
    </EventXML>
  </UserData>
</Event>

Open in new window

Martin_RadboAuthor Commented:
If someone know which permission could be wrong I would happily try to change them and give it a try.
Tomas ValentaIT ManagerCommented:
If it is possible remove all Remote desktop components from server, restart server and then install back.
Martin_RadboAuthor Commented:
There is just one installed, i.e. the "Remote Desktop services". I could remove it but I would not like to loose all work have done with folders, policies, program installations and stuff like that for my remote desktop users.

But I assume that is not a problem, the Role is just a role and after reinstalling it I would be back again, right?
Tomas ValentaIT ManagerCommented:
I think all work you mentioned will stay on place. Only Remote Desktop configuration can be removed.
Martin_RadboAuthor Commented:
I removed the role, restarted, installed again (choosing both 'Terminal services' and Terminal server licensing", installation was fine, rebooted (was told to) and then almost at login prompt it tried to finish installation, failed, told med it "reverted the install" and then I could login.

Server manager then opened automatically and tried to finish but failed, and then told me to restart. After a few loops like this, I finally got the answer attached.
dump.jpg
Tomas ValentaIT ManagerCommented:
are there in event logs error or warning messages during start of the system or later ?
Tomas ValentaIT ManagerCommented:
Do you have other W2K8 server there we can try to install only Licencing service and on problematic server install only Remote Desktop service ?
Martin_RadboAuthor Commented:
No, this is only server, unfortunately. Small company=no money....   :-)
Martin_RadboAuthor Commented:
Problem solved.

Did a complete repair of the OS by server CD and after I could easily finalize the necessary step for activating the license.

Thanks anyway for your efforts to help me out.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.