Solved

Home SBS 2003 outgoing mail stuck in queue

Posted on 2010-08-26
13
931 Views
Last Modified: 2013-11-30
I  am in the process of setting up a home SBS 2003 Server which sits behind a hardware router.

Incoming email is working fine, but for some reason outgoing is stuck on the SMTP connector and unable to send out. I am trying to work out DNS and firewall wise what is required internally on SBS 2003 box, but also with my Domain DNS (if any).

Please help :-)
0
Comment
Question by:Flipp
  • 4
  • 4
  • 2
  • +3
13 Comments
 
LVL 10

Expert Comment

by:dhruvarajp
ID: 33529530
check if these are spam emails if not
remote the smarthost from connector
and see the queue going down

thank you
Dhruv
0
 
LVL 8

Assisted Solution

by:Mkris9
Mkris9 earned 50 total points
ID: 33529535
Couple of things to check -

Is port 25 open from LAN to internet ? - can check it using 'telnet 74.125.157.27 25' from command prompt
What outbound routing are you using ? ISP's smart host ? or DNS routing ?
0
 
LVL 6

Author Comment

by:Flipp
ID: 33529536
They are not spam emails - they are all test emails being sent from OWA of a test user. Not sure what you mean by 'remote the smarthost from connector'?
0
 
LVL 8

Expert Comment

by:Mkris9
ID: 33529552
What have you configured here  - Use DNS or use Smart host ?

http://www.msexchange.org/img/upl/image0041087372386778.jpg
0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 150 total points
ID: 33529565
If you are a Home User, your ISP may be blocking TCP port 25 outbound (quite normal for ISP's as they are trying to prevent spam) - which is what Mkris9 is getting at.
You may need to change your outbound TCP port to 587 (Secure SMTP) and make sure you open up your firewall to allow this port out from your server and then you should be okay.
To change the port, go to the SMTP Virtual Server properties> General Tab> Advanced Button> Edit Button, change port from 25 to 587.  Click OK numerous times!
0
 
LVL 4

Assisted Solution

by:ythevenot
ythevenot earned 25 total points
ID: 33529594
actually the ISP may block SMTP traffic (not only port 25), ie changing the port does not necessarily help.
If this the case, you will have to use your ISP mail server as a smart host.
Can you send emails to your internal users?
what error messages do you see if you check the server queue?
make sure that the name resolution is working for the domains you are sending emails (with nslookup for example).
these are few things to check. Also use the troubleshooting tools from exchange to have an idea of what can be the issues.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 6

Author Comment

by:Flipp
ID: 33538046
1. I have 'Use DNS to route to each address space on this connector' configured in Exchange
2. I can confirm by way of www.canyouseeme.org and checking port 25 is Open
3. If I check the Queue in Exchange System Manager, it simply shows the SMTP Connector trying send and resolve domainname.com of the outgoing emails.

DNS of NIC is 127.0.0.1
DNS Forwarder is set to DNS Servers of ISP - should this by my local router instead?
Perhaps my DNS is not setup correctly?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33538063
Dowload and run the Exchange 2003 Best Practices Analyzer:
http://www.microsoft.com/downloads/details.aspx?FamilyID=dbab201f-4bee-4943-ac22-e2ddbd258df3&displaylang=en
Also the SBS 2003 Best Practices Analyzer:
http://www.microsoft.com/downloads/details.aspx?familyid=3874527A-DE19-49BB-800F-352F3B6F2922&displaylang=en
DNS on your NIC should be the IP address of your server not 127.0.0.1.  Forwarders are fine pointing to your ISP's DNS servers.
0
 
LVL 56

Accepted Solution

by:
Cliff Galiher earned 25 total points
ID: 33538777
I believe alanhardisty is correct. It is very likely that your ISP is blocking port 25; an extremely common practice on residential connections.
For the record, while you tested to see if port 25 was open using canyouseeme, that can only test connections inbound from the internet to your server. We've already established that port 25 is open because your initial question states that incoming email works fine.
The problem is that outgoing email does *not* work, thus port 25 may be blocked for outbound traffic. Those are two distinctly different types of blocks and due to the common practice of malware attempting to send mail, it is far more common for ISPs to only block port 25 outbound while leaving all inbound traffic unblocked, hwnce the results you describe are exactly what I'd epect in such a scenario.
-Cliff
 
0
 
LVL 6

Author Closing Comment

by:Flipp
ID: 33539451
Thank you one and all ...... alanhardisty you are in fact correct, but thank you cgaliher for the additional post.

I am now onto my ISP talking through options on how to get this going while upgrading Exchange to SP2.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33539484
This is extremely common in a home environment.  You might find that changing the port to port 587 will make the emails flow as mentioned above.
Thanks for the points and good luck.
0
 
LVL 6

Author Comment

by:Flipp
ID: 33539492
They confirmed that the only way around is to get a static IP - only a few bucks a month so probably best.

Cheers
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33539499
Fair enough!  As long as it is not big bucks per month, it makes much more sense to go with a fixed IP.
If you need any more help, just post again.
Alan
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now